auto-import changelog data from iputils-20020927-9.1.src.rpm
Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9.1 - rebuilt Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9 - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609). Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8 - One more update to ifenslave.c Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7 - Updated ifenslave.c and README.bonding to latest version. Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> - rebuilt Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5 - Bumped release and rebuilt Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4 - Fixed DNS lookup problems (#68212). - Added warning if binding problem failed on subinterface (#81640). Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3 - Removed bonding tarball and replaced it with ifenslave.c and README - FHS compliance for all tools, now to be found in /bin with compat symlinks to old places.
This commit is contained in:
parent
8045949f55
commit
ffeee16d82
@ -1,2 +1 @@
|
||||
bonding-0.2.tar.gz
|
||||
iputils-ss020927.tar.gz
|
||||
|
33
iputils-20020927-addrcache.patch
Normal file
33
iputils-20020927-addrcache.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- iputils/ping.c.addrcache 2002-09-20 17:08:11.000000000 +0200
|
||||
+++ iputils/ping.c 2003-05-15 16:41:19.000000000 +0200
|
||||
@@ -1124,6 +1124,12 @@
|
||||
{
|
||||
struct hostent *hp;
|
||||
static char buf[4096];
|
||||
+ static __u32 addr_cache = 0;
|
||||
+
|
||||
+ if ( addr == addr_cache )
|
||||
+ return buf;
|
||||
+
|
||||
+ addr_cache = addr;
|
||||
|
||||
if ((options & F_NUMERIC) ||
|
||||
!(hp = gethostbyaddr((char *)&addr, 4, AF_INET)))
|
||||
--- iputils/ping6.c.addrcache 2002-09-20 17:08:11.000000000 +0200
|
||||
+++ iputils/ping6.c 2003-05-15 16:41:19.000000000 +0200
|
||||
@@ -893,7 +893,14 @@
|
||||
*/
|
||||
char * pr_addr(struct in6_addr *addr)
|
||||
{
|
||||
- struct hostent *hp = NULL;
|
||||
+ static struct hostent *hp = NULL;
|
||||
+ static struct in6_addr addr_cache = {{{0,0,0,0}}};
|
||||
+
|
||||
+ if ( addr->s6_addr32[0] == addr_cache.s6_addr32[0] &&
|
||||
+ addr->s6_addr32[1] == addr_cache.s6_addr32[1] &&
|
||||
+ addr->s6_addr32[2] == addr_cache.s6_addr32[2] &&
|
||||
+ addr->s6_addr32[3] == addr_cache.s6_addr32[3] )
|
||||
+ return hp ? hp->h_name : pr_addr_n(addr);
|
||||
|
||||
if (!(options&F_NUMERIC))
|
||||
hp = gethostbyaddr((__u8*)addr, sizeof(struct in6_addr), AF_INET6);
|
12
iputils-20020927-ping-subint.patch
Normal file
12
iputils-20020927-ping-subint.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- iputils-ss021109-vanilla/ping.c Thu Nov 7 23:53:21 2002
|
||||
+++ iputils/ping.c Sun Jan 12 03:39:24 2003
|
||||
@@ -285,6 +285,9 @@
|
||||
perror("ping: IP_MULTICAST_IF");
|
||||
exit(2);
|
||||
}
|
||||
+ } else if (icmp_sock >= 0) {
|
||||
+ /* We possible tried to SO_BINDTODEVICE() a subinterface like 'eth0:1' */
|
||||
+ perror("Warning: cannot bind to specified iface, falling back");
|
||||
}
|
||||
}
|
||||
}
|
88
iputils.spec
88
iputils.spec
@ -1,18 +1,23 @@
|
||||
Summary: Network monitoring tools including ping.
|
||||
Name: iputils
|
||||
Version: 20020927
|
||||
Release: 2
|
||||
Copyright: BSD
|
||||
Release: 9.1
|
||||
License: BSD
|
||||
Group: System Environment/Daemons
|
||||
Source0: http://ftp.sunet.se/pub/os/Linux/ip-routing/iputils-ss020927.tar.gz
|
||||
Source1: bonding-0.2.tar.gz
|
||||
Source1: ifenslave.c
|
||||
Source2: README.bonding
|
||||
Patch0: iputils-20001007-rh7.patch
|
||||
Patch1: iputils-20020124-ping_sparcfix.patch
|
||||
Patch2: iputils-20020124-rdisc-server.patch
|
||||
Patch3: iputils-20020124-countermeasures.patch
|
||||
Patch4: iputils-20020927-addrcache.patch
|
||||
Patch5: iputils-20020927-ping-subint.patch
|
||||
Patch6: iputils-20020927-icmp_seq.patch
|
||||
Prefix: %{_prefix}
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
BuildPreReq: docbook-utils perl-SGMLSpm
|
||||
BuildPreReq: glibc-kernheaders >= 2.4-8.19
|
||||
|
||||
%description
|
||||
The iputils package contains basic utilities for monitoring a network,
|
||||
@ -21,19 +26,21 @@ ECHO_REQUEST packets to a specified network host to discover whether
|
||||
the target machine is alive and receiving network traffic.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name} -a 1
|
||||
|
||||
rm -f bonding-0.2/ifenslave
|
||||
mv -f bonding-0.2/README bonding-0.2/README.ifenslave
|
||||
%setup -q -n %{name}
|
||||
cp %{SOURCE1} .
|
||||
cp %{SOURCE2} .
|
||||
|
||||
%patch0 -p1 -b .rh7
|
||||
%patch1 -p1 -b .ping_sparcfix
|
||||
%patch2 -p1 -b .rdisc-server
|
||||
%patch3 -p1 -b .countermeasures
|
||||
%patch4 -p1 -b .addrcache
|
||||
%patch5 -p1 -b .ping-subint
|
||||
%patch6 -p1 -b .icmp_seq
|
||||
|
||||
%build
|
||||
make
|
||||
make ifenslave -C bonding-0.2
|
||||
gcc -Wall -Wstrict-prototypes -O3 ifenslave.c -o ifenslave
|
||||
make -C doc man
|
||||
|
||||
%install
|
||||
@ -44,19 +51,25 @@ mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
|
||||
install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
%ifos linux
|
||||
install -c arping ${RPM_BUILD_ROOT}/sbin/
|
||||
ln -s ../../sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
|
||||
ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
|
||||
install -c ping ${RPM_BUILD_ROOT}/bin/
|
||||
install -c bonding-0.2/ifenslave ${RPM_BUILD_ROOT}/sbin/
|
||||
install -c ifenslave ${RPM_BUILD_ROOT}/sbin/
|
||||
%else
|
||||
install -c arping ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c ping ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c bonding-0.2/ifenslave ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c ifenslave ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
%endif
|
||||
install -c ping6 ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c rdisc ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c tracepath ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c traceroute6 ${RPM_BUILD_ROOT}%{_sbindir}/
|
||||
install -c rdisc ${RPM_BUILD_ROOT}/sbin/
|
||||
install -c ping6 ${RPM_BUILD_ROOT}/bin/
|
||||
install -c tracepath ${RPM_BUILD_ROOT}/bin/
|
||||
install -c tracepath6 ${RPM_BUILD_ROOT}/bin/
|
||||
install -c traceroute6 ${RPM_BUILD_ROOT}/bin/
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
|
||||
ln -sf /bin/ping6 ${RPM_BUILD_ROOT}%{_sbindir}
|
||||
ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
|
||||
ln -sf /bin/tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}
|
||||
ln -sf /bin/traceroute6 ${RPM_BUILD_ROOT}%{_sbindir}
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
|
||||
install -c doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
|
||||
@ -70,27 +83,58 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc RELNOTES bonding*/README.ifenslave
|
||||
%doc RELNOTES README.bonding
|
||||
%{_sbindir}/clockdiff
|
||||
%ifos linux
|
||||
%attr(4755,root,root) /bin/ping
|
||||
/sbin/arping
|
||||
%{_sbindir}/arping
|
||||
%attr(4755,root,root) /bin/ping
|
||||
/sbin/ifenslave
|
||||
%else
|
||||
%attr(4755,root,root) %{_sbindir}/ping
|
||||
%{_sbindir}/arping
|
||||
%{_sbindir}/ifenslave
|
||||
%endif
|
||||
%attr(4755,root,root) %{_sbindir}/ping6
|
||||
/sbin/rdisc
|
||||
%attr(4755,root,root) /bin/ping6
|
||||
/bin/tracepath
|
||||
/bin/tracepath6
|
||||
%attr(4755,root,root)/bin/traceroute6
|
||||
%{_sbindir}/ping6
|
||||
%{_sbindir}/tracepath
|
||||
%{_sbindir}/tracepath6
|
||||
%attr(4755,root,root) %{_sbindir}/traceroute6
|
||||
%{_sbindir}/rdisc
|
||||
%{_sbindir}/traceroute6
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
* Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9.1
|
||||
- rebuilt
|
||||
|
||||
* Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
|
||||
- Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
|
||||
|
||||
* Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
|
||||
- One more update to ifenslave.c
|
||||
|
||||
* Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
|
||||
- Updated ifenslave.c and README.bonding to latest version.
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
|
||||
- Bumped release and rebuilt
|
||||
|
||||
* Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
|
||||
- Fixed DNS lookup problems (#68212).
|
||||
- Added warning if binding problem failed on subinterface (#81640).
|
||||
|
||||
* Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
|
||||
- Removed bonding tarball and replaced it with ifenslave.c and README
|
||||
- FHS compliance for all tools, now to be found in /bin with compat symlinks to
|
||||
old places.
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 20020927-2
|
||||
- rebuilt
|
||||
|
||||
* Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
|
||||
|
Loading…
Reference in New Issue
Block a user