Comment patches and cleanup
This commit is contained in:
parent
e773cafb78
commit
c6fb3a1af9
@ -1,12 +0,0 @@
|
||||
--- iputils/ping_common.c.countermeasures Tue May 21 10:06:05 2002
|
||||
+++ iputils/ping_common.c Tue May 21 10:12:42 2002
|
||||
@@ -628,7 +628,8 @@
|
||||
tvsub(tv, &tmp_tv);
|
||||
triptime = tv->tv_sec * 1000000 + tv->tv_usec;
|
||||
if (triptime < 0) {
|
||||
- fprintf(stderr, "Warning: time of day goes back (%ldus), taking countermeasures.\n", triptime);
|
||||
+ if (options & F_VERBOSE)
|
||||
+ fprintf(stderr, "Warning: time of day goes back (%ldus), taking countermeasures.\n", triptime);
|
||||
triptime = 0;
|
||||
if (!(options & F_LATENCY)) {
|
||||
gettimeofday(tv, NULL);
|
@ -1,3 +1,8 @@
|
||||
Add warning if trying to bind to a subinterface.
|
||||
|
||||
Author: Johannes Tevessen <j.tevessen@gmx.net>
|
||||
Resolves: #81640
|
||||
|
||||
--- iputils-ss021109-vanilla/ping.c Thu Nov 7 23:53:21 2002
|
||||
+++ iputils/ping.c Sun Jan 12 03:39:24 2003
|
||||
@@ -285,6 +285,9 @@
|
||||
|
@ -1,3 +1,5 @@
|
||||
Fedora-specific makefile patch.
|
||||
|
||||
--- iputils-s20121121/Makefile.orig 2012-11-21 11:32:18.000000000 +0100
|
||||
+++ iputils-s20121121/Makefile 2012-11-22 07:29:27.947670530 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up iputils-s20100418/tracepath6.c.convtoint iputils-s20100418/tracepath6.c
|
||||
--- iputils-s20100418/tracepath6.c.convtoint 2010-04-23 11:28:15.294593391 +0200
|
||||
+++ iputils-s20100418/tracepath6.c 2010-04-23 11:28:23.544605551 +0200
|
||||
@@ -89,7 +89,7 @@ void print_host(const char *a, const cha
|
||||
}
|
||||
if (plen >= HOST_COLUMN_SIZE)
|
||||
plen = HOST_COLUMN_SIZE - 1;
|
||||
- printf("%*s", HOST_COLUMN_SIZE - plen, "");
|
||||
+ printf("%*s", HOST_COLUMN_SIZE - (int)plen, "");
|
||||
}
|
||||
|
||||
int recverr(int fd, int ttl)
|
||||
diff -up iputils-s20100418/tracepath.c.convtoint iputils-s20100418/tracepath.c
|
||||
--- iputils-s20100418/tracepath.c.convtoint 2010-04-23 11:26:20.273555629 +0200
|
||||
+++ iputils-s20100418/tracepath.c 2010-04-23 11:26:20.281562493 +0200
|
||||
@@ -77,7 +77,7 @@ void print_host(const char *a, const cha
|
||||
}
|
||||
if (plen >= HOST_COLUMN_SIZE)
|
||||
plen = HOST_COLUMN_SIZE - 1;
|
||||
- printf("%*s", HOST_COLUMN_SIZE - plen, "");
|
||||
+ printf("%*s", HOST_COLUMN_SIZE - (int)plen, "");
|
||||
}
|
||||
|
||||
int recverr(int fd, int ttl)
|
@ -1,3 +1,5 @@
|
||||
Compile with libidn support.
|
||||
|
||||
--- iputils-s20121125/Makefile.orig 2012-11-26 11:27:31.000000000 +0100
|
||||
+++ iputils-s20121125/Makefile 2012-11-26 11:28:02.128803095 +0100
|
||||
@@ -21,7 +21,7 @@
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: Network monitoring tools including ping
|
||||
Name: iputils
|
||||
Version: 20121125
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# some parts are under the original BSD (ping.c)
|
||||
# some are under GPLv2+ (tracepath.c)
|
||||
License: BSD and GPLv2+
|
||||
@ -15,12 +15,10 @@ Source4: rdisc.service
|
||||
Source5: rdisc.sysconfig
|
||||
|
||||
Patch0: iputils-20020927-rh.patch
|
||||
Patch1: iputils-20020124-countermeasures.patch
|
||||
Patch2: iputils-20020927-ping-subint.patch
|
||||
Patch3: iputils-ifenslave.patch
|
||||
Patch4: iputils-20121112-idn.patch
|
||||
Patch5: iputils-20071127-corr_type.patch
|
||||
Patch6: iputils-20100418-convtoint.patch
|
||||
Patch7: iputils-20121121-ifaddrs.patch
|
||||
|
||||
BuildRequires: docbook-utils perl-SGMLSpm
|
||||
@ -60,12 +58,10 @@ The iputils-sysvinit contains SysV initscritps support.
|
||||
%setup -q -a 1 -n %{name}-s%{version}
|
||||
|
||||
%patch0 -p1 -b .rh
|
||||
%patch1 -p1 -b .countermeasures
|
||||
%patch2 -p1 -b .ping-subint
|
||||
%patch3 -p1 -b .addr
|
||||
%patch4 -p1 -b .idn
|
||||
%patch5 -p1 -b .corr_type
|
||||
%patch6 -p1 -b .convtoint
|
||||
%patch7 -p1 -b .ifaddrs
|
||||
|
||||
%build
|
||||
@ -149,6 +145,9 @@ mv -f RELNOTES.tmp RELNOTES
|
||||
%{_sysconfdir}/rc.d/init.d/rdisc
|
||||
|
||||
%changelog
|
||||
* Mon Nov 26 2012 Jan Synáček <jsynacek@redhat.com> - 20121125-2
|
||||
- Comment patches and cleanup
|
||||
|
||||
* Mon Nov 26 2012 Jan Synáček <jsynacek@redhat.com> - 20121125-1
|
||||
- Update to iputils-s20121125 (#879952)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user