Update to iputils-s20121207 (#890397) and remove unnecessary patches
This commit is contained in:
parent
8ea6bb38d5
commit
c3a39c6229
@ -1,8 +1,26 @@
|
|||||||
Fedora-specific makefile patch.
|
Fedora-specific makefile patch.
|
||||||
|
|
||||||
--- iputils-s20121205/Makefile.orig 2012-12-05 15:46:14.000000000 +0100
|
--- iputils-s20121221-dist/Makefile 2013-01-07 13:37:04.913224305 +0100
|
||||||
+++ iputils-s20121205/Makefile 2012-12-06 11:38:14.752414482 +0100
|
+++ iputils-s20121221-new/Makefile 2013-01-07 13:42:56.542052062 +0100
|
||||||
@@ -46,7 +46,7 @@
|
@@ -27,7 +27,7 @@
|
||||||
|
# sysfs support (with libsysfs - deprecated) [no|yes|static]
|
||||||
|
USE_SYSFS=no
|
||||||
|
# IDN support (experimental) [no|yes|static]
|
||||||
|
-USE_IDN=no
|
||||||
|
+USE_IDN=yes
|
||||||
|
|
||||||
|
# Do not use getifaddrs [no|yes|static]
|
||||||
|
WITHOUT_IFADDRS=no
|
||||||
|
@@ -35,7 +35,7 @@
|
||||||
|
ARPING_DEFAULT_DEVICE=
|
||||||
|
|
||||||
|
# GNU TLS library for ping6 [yes|no|static]
|
||||||
|
-USE_GNUTLS=yes
|
||||||
|
+USE_GNUTLS=no
|
||||||
|
# Crypto library for ping6 [shared|static]
|
||||||
|
USE_CRYPTO=shared
|
||||||
|
# Resolv library for ping6 [yes|static]
|
||||||
|
@@ -49,7 +49,7 @@
|
||||||
# -------------------------------------
|
# -------------------------------------
|
||||||
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
|
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
|
||||||
# CCOPT=-fno-strict-aliasing -Wstrict-prototypes -Wall -Werror -g
|
# CCOPT=-fno-strict-aliasing -Wstrict-prototypes -Wall -Werror -g
|
||||||
@ -11,16 +29,7 @@ Fedora-specific makefile patch.
|
|||||||
CCOPTOPT=-O3
|
CCOPTOPT=-O3
|
||||||
GLIBCFIX=-D_GNU_SOURCE
|
GLIBCFIX=-D_GNU_SOURCE
|
||||||
DEFINES=
|
DEFINES=
|
||||||
@@ -73,7 +73,7 @@
|
@@ -110,7 +110,7 @@
|
||||||
endif
|
|
||||||
|
|
||||||
# USE_IDN: DEF_IDN, LIB_IDN
|
|
||||||
-ifneq ($(USE_IDN),no)
|
|
||||||
+ifneq ($(USE_IDN),yes)
|
|
||||||
DEF_IDN = -DUSE_IDN
|
|
||||||
LIB_IDN = $(call FUNC_LIB,$(USE_IDN),$(LDFLAG_IDN))
|
|
||||||
endif
|
|
||||||
@@ -101,7 +101,7 @@
|
|
||||||
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
||||||
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
||||||
|
|
||||||
@ -29,7 +38,7 @@ Fedora-specific makefile patch.
|
|||||||
LDLIBS=$(LDLIB) $(ADDLIB)
|
LDLIBS=$(LDLIB) $(ADDLIB)
|
||||||
|
|
||||||
UNAME_N:=$(shell uname -n)
|
UNAME_N:=$(shell uname -n)
|
||||||
@@ -178,6 +178,7 @@
|
@@ -187,6 +187,7 @@
|
||||||
|
|
||||||
# -------------------------------------
|
# -------------------------------------
|
||||||
# ninfod
|
# ninfod
|
||||||
|
@ -1,171 +0,0 @@
|
|||||||
From 2d14cdf412c753b9cf778f1c80bf116651e15816 Mon Sep 17 00:00:00 2001
|
|
||||||
From: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
Date: Fri, 7 Dec 2012 01:28:31 +0900
|
|
||||||
Subject: [PATCH 1/5] ninfod: Use unsigned int for digest.
|
|
||||||
|
|
||||||
Fixes following warning:
|
|
||||||
| ninfod_name.c: In function 'nodeinfo_group':
|
|
||||||
| ninfod_name.c:270:2: warning: pointer targets in passing argument 1 of 'MD5_Final' differ in signedness [-Wpointer-sign]
|
|
||||||
| /usr/include/openssl/md5.h:113:5: note: expected 'unsigned char *' but argument is of type 'char *'
|
|
||||||
|
|
||||||
Signed-off-by: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
---
|
|
||||||
ninfod/ninfod_name.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/ninfod/ninfod_name.c b/ninfod/ninfod_name.c
|
|
||||||
index c6e7c4a..967d7f7 100644
|
|
||||||
--- a/ninfod/ninfod_name.c
|
|
||||||
+++ b/ninfod/ninfod_name.c
|
|
||||||
@@ -260,7 +260,7 @@ static int nodeinfo_group(const char *dnsname, int namelen,
|
|
||||||
struct in6_addr *nigroup)
|
|
||||||
{
|
|
||||||
MD5_CTX ctxt;
|
|
||||||
- char digest[16];
|
|
||||||
+ unsigned char digest[16];
|
|
||||||
|
|
||||||
if (!dnsname || !nigroup)
|
|
||||||
return -1;
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
||||||
From a12f8d430e77ac8279d0f55bc81dc9cc2da2c70b Mon Sep 17 00:00:00 2001
|
|
||||||
From: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
Date: Fri, 7 Dec 2012 01:29:55 +0900
|
|
||||||
Subject: [PATCH 2/5] ninfod: nanosleep(3) needs <time.h>.
|
|
||||||
|
|
||||||
| ninfod.c: In function 'ni_send':
|
|
||||||
| ninfod.c:363:4: warning: implicit declaration of function 'nanosleep' [-Wimplicit-function-declaration]
|
|
||||||
|
|
||||||
Patch based on iputils-20121125-ninfod-minor.patch from Fedora.
|
|
||||||
|
|
||||||
Signed-off-by: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
---
|
|
||||||
ninfod/ninfod.c | 11 +++++++++++
|
|
||||||
1 file changed, 11 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/ninfod/ninfod.c b/ninfod/ninfod.c
|
|
||||||
index 51f6e2a..23d88d9 100644
|
|
||||||
--- a/ninfod/ninfod.c
|
|
||||||
+++ b/ninfod/ninfod.c
|
|
||||||
@@ -73,6 +73,17 @@
|
|
||||||
# include <unistd.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifdef TIME_WITH_SYS_TIME
|
|
||||||
+# include <sys/time.h>
|
|
||||||
+# include <time.h>
|
|
||||||
+#else
|
|
||||||
+# ifdef HAVE_SYS_TIME_H
|
|
||||||
+# include <sys/time.h>
|
|
||||||
+# else
|
|
||||||
+# include <time.h>
|
|
||||||
+# endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#if HAVE_SYS_UIO_H
|
|
||||||
#include <sys/uio.h>
|
|
||||||
#endif
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
||||||
From 2f76e615a71f28c31fbef05775aebc80855c743a Mon Sep 17 00:00:00 2001
|
|
||||||
From: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
Date: Fri, 7 Dec 2012 01:35:00 +0900
|
|
||||||
Subject: [PATCH 3/5] ninfod: Too many arguments for syslog(3)/fprintf(3) via
|
|
||||||
DEBUG().
|
|
||||||
|
|
||||||
| ninfod.c: In function 'do_daemonize':
|
|
||||||
| ninfod.c:419:6: warning: too many arguments for format [-Wformat-extra-args]
|
|
||||||
|
|
||||||
Patch based on iputils-20121125-ninfod-minor.patch from Fedora.
|
|
||||||
|
|
||||||
Signed-off-by: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
---
|
|
||||||
ninfod/ninfod.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/ninfod/ninfod.c b/ninfod/ninfod.c
|
|
||||||
index 23d88d9..f7d2654 100644
|
|
||||||
--- a/ninfod/ninfod.c
|
|
||||||
+++ b/ninfod/ninfod.c
|
|
||||||
@@ -417,7 +417,7 @@ static void do_daemonize(void)
|
|
||||||
if ((fp = fopen(opt_p, "r"))) {
|
|
||||||
if (fscanf(fp, "%d", &pid) != 1) {
|
|
||||||
DEBUG(LOG_ERR, "pid file '%s' exists, but read failed.\n",
|
|
||||||
- opt_p, pid);
|
|
||||||
+ opt_p);
|
|
||||||
} else {
|
|
||||||
DEBUG(LOG_ERR, "pid file '%s' exists : %d\n",
|
|
||||||
opt_p, pid);
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
||||||
From 741f4d6a081a6a4a2f8314af1ed9880631c4a854 Mon Sep 17 00:00:00 2001
|
|
||||||
From: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
Date: Fri, 7 Dec 2012 02:04:35 +0900
|
|
||||||
Subject: [PATCH 4/5] ninfod: Fix several warnings on ununsed variables.
|
|
||||||
|
|
||||||
| ninfod_core.c: In function 'pr_nodeinfo_noop':
|
|
||||||
| ninfod_core.c:244:25: warning: unused variable 'replybuf' [-Wunused-variable]
|
|
||||||
| ninfod_core.c: In function 'pr_nodeinfo_suptypes':
|
|
||||||
| ninfod_core.c:273:9: warning: unused variable 'replylen' [-Wunused-variable]
|
|
||||||
| ninfod.c: In function 'init_sock':
|
|
||||||
| ninfod.c:255:6: warning: unused variable 'i' [-Wunused-variable]
|
|
||||||
| ninfod.c: In function 'main':
|
|
||||||
| ninfod.c:636:6: warning: unused variable 'c' [-Wunused-variable]
|
|
||||||
|
|
||||||
Signed-off-by: YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
|
|
||||||
---
|
|
||||||
ninfod/ninfod.c | 3 +--
|
|
||||||
ninfod/ninfod_core.c | 4 ----
|
|
||||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ninfod/ninfod.c b/ninfod/ninfod.c
|
|
||||||
index f7d2654..802d5ed 100644
|
|
||||||
--- a/ninfod/ninfod.c
|
|
||||||
+++ b/ninfod/ninfod.c
|
|
||||||
@@ -252,9 +252,9 @@ static int set_recvpktinfo(int sock)
|
|
||||||
static int __inline__ init_sock(int sock)
|
|
||||||
{
|
|
||||||
struct icmp6_filter filter;
|
|
||||||
+#if NEED_IPV6CHECKSUM
|
|
||||||
int i;
|
|
||||||
|
|
||||||
-#if NEED_IPV6CHECKSUM
|
|
||||||
i = offsetof(struct icmp6_nodeinfo, ni_cksum);
|
|
||||||
if (setsockopt(sock,
|
|
||||||
IPPROTO_IPV6, IPV6_CHECKSUM,
|
|
||||||
@@ -633,7 +633,6 @@ static void print_usage(void) {
|
|
||||||
int main (int argc, char **argv)
|
|
||||||
{
|
|
||||||
int sock_errno = 0;
|
|
||||||
- int c;
|
|
||||||
|
|
||||||
appname = argv[0];
|
|
||||||
|
|
||||||
diff --git a/ninfod/ninfod_core.c b/ninfod/ninfod_core.c
|
|
||||||
index 47e9e7d..f411a7a 100644
|
|
||||||
--- a/ninfod/ninfod_core.c
|
|
||||||
+++ b/ninfod/ninfod_core.c
|
|
||||||
@@ -241,8 +241,6 @@ static __inline__ struct qtypeinfo *qtypeinfo_lookup(int qtype)
|
|
||||||
/* noop */
|
|
||||||
int pr_nodeinfo_noop(CHECKANDFILL_ARGS)
|
|
||||||
{
|
|
||||||
- struct icmp6_nodeinfo *replybuf = NULL;
|
|
||||||
-
|
|
||||||
DEBUG(LOG_DEBUG, "%s()\n", __func__);
|
|
||||||
|
|
||||||
if (subjlen) {
|
|
||||||
@@ -270,8 +268,6 @@ int pr_nodeinfo_noop(CHECKANDFILL_ARGS)
|
|
||||||
/* suptypes */
|
|
||||||
int pr_nodeinfo_suptypes(CHECKANDFILL_ARGS)
|
|
||||||
{
|
|
||||||
- size_t replylen = sizeof(struct icmp6_nodeinfo) + (suptypes_len<<2);
|
|
||||||
-
|
|
||||||
DEBUG(LOG_DEBUG, "%s()\n", __func__);
|
|
||||||
|
|
||||||
if (subjlen) {
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
From e934222cd8e31bbd26d01eb156df543ba4110e7d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Synacek <jsynacek@redhat.com>
|
|
||||||
Date: Fri, 7 Dec 2012 09:14:20 +0100
|
|
||||||
Subject: [PATCH 2/2] ping6: Fix -F switch.
|
|
||||||
|
|
||||||
Even when the flowlabel is set correctly, ping6 exits with a warning. For some
|
|
||||||
reason, the errno is set when it should not be.
|
|
||||||
|
|
||||||
Signed-off-by: Jan Synacek <jsynacek@redhat.com>
|
|
||||||
---
|
|
||||||
ping6.c | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/ping6.c b/ping6.c
|
|
||||||
index 358a035..85d3782 100644
|
|
||||||
--- a/ping6.c
|
|
||||||
+++ b/ping6.c
|
|
||||||
@@ -725,7 +725,8 @@ int main(int argc, char *argv[])
|
|
||||||
switch(ch) {
|
|
||||||
case 'F':
|
|
||||||
flowlabel = hextoui(optarg);
|
|
||||||
- if (errno || (flowlabel & ~IPV6_FLOWINFO_FLOWLABEL)) {
|
|
||||||
+ if ((flowlabel < 0 && errno) ||
|
|
||||||
+ (flowlabel & ~IPV6_FLOWINFO_FLOWLABEL)) {
|
|
||||||
fprintf(stderr, "ping: Invalid flowinfo %s\n", optarg);
|
|
||||||
exit(2);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
11
iputils.spec
11
iputils.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: Network monitoring tools including ping
|
Summary: Network monitoring tools including ping
|
||||||
Name: iputils
|
Name: iputils
|
||||||
Version: 20121207
|
Version: 20121221
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# some parts are under the original BSD (ping.c)
|
# some parts are under the original BSD (ping.c)
|
||||||
# some are under GPLv2+ (tracepath.c)
|
# some are under GPLv2+ (tracepath.c)
|
||||||
@ -17,10 +17,6 @@ Source6: ninfod.service
|
|||||||
|
|
||||||
Patch0: iputils-20020927-rh.patch
|
Patch0: iputils-20020927-rh.patch
|
||||||
Patch1: iputils-ifenslave.patch
|
Patch1: iputils-ifenslave.patch
|
||||||
# upstreamed
|
|
||||||
Patch2: iputils-20121125-ninfod-minor.patch
|
|
||||||
# pending upstream approval
|
|
||||||
Patch3: iputils-20121207-ping6-flowlabel.patch
|
|
||||||
|
|
||||||
BuildRequires: docbook-utils perl-SGMLSpm
|
BuildRequires: docbook-utils perl-SGMLSpm
|
||||||
BuildRequires: glibc-kernheaders >= 2.4-8.19
|
BuildRequires: glibc-kernheaders >= 2.4-8.19
|
||||||
@ -70,8 +66,6 @@ Queries.
|
|||||||
|
|
||||||
%patch0 -p1 -b .rh
|
%patch0 -p1 -b .rh
|
||||||
%patch1 -p1 -b .addr
|
%patch1 -p1 -b .addr
|
||||||
%patch2 -p1 -b .ninfod-minor
|
|
||||||
%patch3 -p1 -b .flowlabel
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%ifarch s390 s390x
|
%ifarch s390 s390x
|
||||||
@ -179,6 +173,9 @@ mv -f RELNOTES.tmp RELNOTES
|
|||||||
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 07 2013 Jan Synáček <jsynacek@redhat.com> - 20121221-1
|
||||||
|
- Update to iputils-s20121207 (#890397) and remove unnecessary patches
|
||||||
|
|
||||||
* Fri Dec 07 2012 Jan Synáček <jsynacek@redhat.com> - 20121207-1
|
* Fri Dec 07 2012 Jan Synáček <jsynacek@redhat.com> - 20121207-1
|
||||||
- Update to iputils-s20121207 (#884983) - fixes a ping segfault introduced
|
- Update to iputils-s20121207 (#884983) - fixes a ping segfault introduced
|
||||||
by the previous update
|
by the previous update
|
||||||
|
Loading…
Reference in New Issue
Block a user