Update to s20190515 (#1710647)
This commit is contained in:
parent
0a36227dc3
commit
5bf4b0a1aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@ ifenslave.tar.gz
|
|||||||
/iputils-s20161105.tar.gz
|
/iputils-s20161105.tar.gz
|
||||||
/iputils-s20180629.tar.gz
|
/iputils-s20180629.tar.gz
|
||||||
/iputils-s20190324.tar.gz
|
/iputils-s20190324.tar.gz
|
||||||
|
/iputils-s20190515.tar.gz
|
||||||
|
77
0001-build-sys-doc-Fix-the-dependency-on-xsltproc.patch
Normal file
77
0001-build-sys-doc-Fix-the-dependency-on-xsltproc.patch
Normal file
@ -0,0 +1,77 @@
|
|||||||
|
From 3b013f271931c3fe771e5a2c591f35d617de90f3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Weiss <dev.primeos@gmail.com>
|
||||||
|
Date: Thu, 16 May 2019 10:08:50 +0000
|
||||||
|
Subject: [PATCH] build-sys/doc: Fix the dependency on xsltproc
|
||||||
|
|
||||||
|
This dependency is only required if either the man pages or the HTML
|
||||||
|
documentation is being build. Both targets require docbook-xsl-ns and
|
||||||
|
not docbook-xsl (the former is preferred and in use since c503834).
|
||||||
|
---
|
||||||
|
.travis.yml | 1 -
|
||||||
|
doc/meson.build | 27 +++++++++++++++++----------
|
||||||
|
2 files changed, 17 insertions(+), 11 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/.travis.yml b/.travis.yml
|
||||||
|
index 54edb61..6a6e8c3 100644
|
||||||
|
--- a/.travis.yml
|
||||||
|
+++ b/.travis.yml
|
||||||
|
@@ -14,7 +14,6 @@ addons:
|
||||||
|
- "libidn2-0-dev"
|
||||||
|
- "nettle-dev"
|
||||||
|
- "xsltproc"
|
||||||
|
- - "docbook-xsl"
|
||||||
|
- "docbook-xsl-ns"
|
||||||
|
matrix:
|
||||||
|
include:
|
||||||
|
diff --git a/doc/meson.build b/doc/meson.build
|
||||||
|
index 369090f..9a007b3 100644
|
||||||
|
--- a/doc/meson.build
|
||||||
|
+++ b/doc/meson.build
|
||||||
|
@@ -38,7 +38,7 @@ if build_ninfod == true
|
||||||
|
manpages += ['ninfod']
|
||||||
|
endif
|
||||||
|
|
||||||
|
-xsltproc = find_program('xsltproc', required : true)
|
||||||
|
+xsltproc = find_program('xsltproc', required : build_mans or build_html_mans)
|
||||||
|
xsltproc_args = [
|
||||||
|
'--nonet',
|
||||||
|
'--stringparam', 'man.output.quietly', '1',
|
||||||
|
@@ -48,19 +48,26 @@ xsltproc_args = [
|
||||||
|
]
|
||||||
|
|
||||||
|
if xsltproc.found()
|
||||||
|
- xsl = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
|
||||||
|
- testrun = run_command([xsltproc, '--nonet', xsl])
|
||||||
|
- xsltproc_works = testrun.returncode() == 0
|
||||||
|
- if xsltproc_works == false
|
||||||
|
- warning('xsltproc: cannot process ' + xsl)
|
||||||
|
+ doc_targets = []
|
||||||
|
+ if build_mans
|
||||||
|
+ doc_targets += ['manpages']
|
||||||
|
endif
|
||||||
|
-else
|
||||||
|
- warning('No docbook stylesheet found for generating man pages')
|
||||||
|
- xsltproc_works = false
|
||||||
|
+ if build_html_mans
|
||||||
|
+ doc_targets += ['html']
|
||||||
|
+ endif
|
||||||
|
+ xsltproc_works = true
|
||||||
|
+ foreach doc_target : doc_targets
|
||||||
|
+ xsl = 'http://docbook.sourceforge.net/release/xsl-ns/current/' + doc_target + '/docbook.xsl'
|
||||||
|
+ testrun = run_command([xsltproc, '--nonet', xsl])
|
||||||
|
+ if testrun.returncode() != 0
|
||||||
|
+ xsltproc_works = false
|
||||||
|
+ warning('xsltproc: cannot process ' + xsl)
|
||||||
|
+ endif
|
||||||
|
+ endforeach
|
||||||
|
endif
|
||||||
|
|
||||||
|
if xsltproc_works == false
|
||||||
|
- error('Man pages cannot be built: xsltproc does not work correctly')
|
||||||
|
+ error('Docs cannot be built: xsltproc does not work correctly')
|
||||||
|
endif
|
||||||
|
|
||||||
|
if build_mans
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
@ -1,27 +0,0 @@
|
|||||||
From 76e526ca9b5f395745778ecc0d2dc4ce7461c7ac Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Synacek <jsynacek@redhat.com>
|
|
||||||
Date: Wed, 27 Mar 2019 12:58:51 +0100
|
|
||||||
Subject: [PATCH 1/2] build-sys: make rdisc.service a regular unit
|
|
||||||
|
|
||||||
There is no need to output it as a template unit, as there is no
|
|
||||||
template specific syntax in the unit file.
|
|
||||||
---
|
|
||||||
meson.build | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 97c4a12..8bb5756 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -288,7 +288,7 @@ if build_rinfod == true
|
|
||||||
subs.set('sbindir', join_paths(get_option('prefix'), get_option('sbindir')))
|
|
||||||
unit_file = configure_file(
|
|
||||||
input: 'systemd/rdisc.service.in',
|
|
||||||
- output: 'rdisc@.service',
|
|
||||||
+ output: 'rdisc.service',
|
|
||||||
configuration: subs
|
|
||||||
)
|
|
||||||
install_data(unit_file, install_dir: systemdunitdir)
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -1,161 +0,0 @@
|
|||||||
From c503834519d21973323980850431101f90e663ef Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Tojnar <jtojnar@gmail.com>
|
|
||||||
Date: Mon, 25 Mar 2019 15:23:59 +0100
|
|
||||||
Subject: [PATCH] doc: Use namespace correctly
|
|
||||||
|
|
||||||
The files declared xmlns:db but did not use the db namespace at all.
|
|
||||||
They did not define the default namespace at all, which coincidentally
|
|
||||||
worked with Docbook 4 stylesheets, making them think the files were
|
|
||||||
written in Docbook 4.
|
|
||||||
|
|
||||||
I fixed the namespaces of the documents and switched to the correct
|
|
||||||
Docbook 5 stylesheets.
|
|
||||||
|
|
||||||
Signed-off-by: Jan Tojnar <jtojnar@gmail.com>
|
|
||||||
---
|
|
||||||
doc/arping.xml | 2 +-
|
|
||||||
doc/clockdiff.xml | 2 +-
|
|
||||||
doc/custom-html.xsl | 2 +-
|
|
||||||
doc/custom-man.xsl | 2 +-
|
|
||||||
doc/meson.build | 2 +-
|
|
||||||
doc/ninfod.xml | 2 +-
|
|
||||||
doc/ping.xml | 2 +-
|
|
||||||
doc/rarpd.xml | 2 +-
|
|
||||||
doc/rdisc.xml | 2 +-
|
|
||||||
doc/tftpd.xml | 2 +-
|
|
||||||
doc/tracepath.xml | 2 +-
|
|
||||||
doc/traceroute6.xml | 2 +-
|
|
||||||
12 files changed, 12 insertions(+), 12 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/doc/arping.xml b/doc/arping.xml
|
|
||||||
index ed00af4..711718f 100644
|
|
||||||
--- a/doc/arping.xml
|
|
||||||
+++ b/doc/arping.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.arping">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/clockdiff.xml b/doc/clockdiff.xml
|
|
||||||
index dea05c8..24d1943 100644
|
|
||||||
--- a/doc/clockdiff.xml
|
|
||||||
+++ b/doc/clockdiff.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.clockdiff">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/custom-html.xsl b/doc/custom-html.xsl
|
|
||||||
index c391535..a952c5f 100644
|
|
||||||
--- a/doc/custom-html.xsl
|
|
||||||
+++ b/doc/custom-html.xsl
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
|
|
||||||
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
|
|
||||||
|
|
||||||
-<xsl:import href="http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl"/>
|
|
||||||
+<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/html/docbook.xsl"/>
|
|
||||||
<!--
|
|
||||||
- The docbook stylesheet injects empty anchor tags into generated HTML, identified by an auto-generated ID.
|
|
||||||
- Ask the docbook stylesheet to generate reproducible output when generating (these) ID values.
|
|
||||||
diff --git a/doc/custom-man.xsl b/doc/custom-man.xsl
|
|
||||||
index 058f495..ba9697d 100644
|
|
||||||
--- a/doc/custom-man.xsl
|
|
||||||
+++ b/doc/custom-man.xsl
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
extension-element-prefixes="exsl"
|
|
||||||
version="1.0">
|
|
||||||
|
|
||||||
-<xsl:import href="http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"/>
|
|
||||||
+<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl"/>
|
|
||||||
|
|
||||||
<xsl:template name="top.comment" />
|
|
||||||
|
|
||||||
diff --git a/doc/meson.build b/doc/meson.build
|
|
||||||
index 50dcb4e..5052857 100644
|
|
||||||
--- a/doc/meson.build
|
|
||||||
+++ b/doc/meson.build
|
|
||||||
@@ -49,7 +49,7 @@ xsltproc_args = [
|
|
||||||
|
|
||||||
if xsltproc.found()
|
|
||||||
testrun = run_command([xsltproc, '--nonet',
|
|
||||||
- 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'])
|
|
||||||
+ 'http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl'])
|
|
||||||
xsltproc_works = testrun.returncode() == 0
|
|
||||||
else
|
|
||||||
warning('No docbook stylesheet found for generating man pages')
|
|
||||||
diff --git a/doc/ninfod.xml b/doc/ninfod.xml
|
|
||||||
index 1177a21..081d470 100644
|
|
||||||
--- a/doc/ninfod.xml
|
|
||||||
+++ b/doc/ninfod.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.ninfod">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/ping.xml b/doc/ping.xml
|
|
||||||
index 691887a..b5cea9c 100644
|
|
||||||
--- a/doc/ping.xml
|
|
||||||
+++ b/doc/ping.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.ping">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/rarpd.xml b/doc/rarpd.xml
|
|
||||||
index 0785d56..65d6367 100644
|
|
||||||
--- a/doc/rarpd.xml
|
|
||||||
+++ b/doc/rarpd.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.rarpd">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/rdisc.xml b/doc/rdisc.xml
|
|
||||||
index 8aa8898..ab1c673 100644
|
|
||||||
--- a/doc/rdisc.xml
|
|
||||||
+++ b/doc/rdisc.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.rdisc">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/tftpd.xml b/doc/tftpd.xml
|
|
||||||
index 8f51c3d..4a1b948 100644
|
|
||||||
--- a/doc/tftpd.xml
|
|
||||||
+++ b/doc/tftpd.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.tftpd">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/tracepath.xml b/doc/tracepath.xml
|
|
||||||
index d0a9a12..d1bdcd8 100644
|
|
||||||
--- a/doc/tracepath.xml
|
|
||||||
+++ b/doc/tracepath.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.tracepath">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
diff --git a/doc/traceroute6.xml b/doc/traceroute6.xml
|
|
||||||
index c52d296..5a72784 100644
|
|
||||||
--- a/doc/traceroute6.xml
|
|
||||||
+++ b/doc/traceroute6.xml
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-<refentry xmlns:db="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
+<refentry xmlns="http://docbook.org/ns/docbook" version="5.0"
|
|
||||||
xml:id="man.traceroute6">
|
|
||||||
|
|
||||||
<refentryinfo>
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
11
iputils.spec
11
iputils.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: Network monitoring tools including ping
|
Summary: Network monitoring tools including ping
|
||||||
Name: iputils
|
Name: iputils
|
||||||
Version: 20190324
|
Version: 20190515
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# some parts are under the original BSD (ping.c)
|
# some parts are under the original BSD (ping.c)
|
||||||
# some are under GPLv2+ (tracepath.c)
|
# some are under GPLv2+ (tracepath.c)
|
||||||
@ -17,10 +17,7 @@ Source3: ninfod.service
|
|||||||
Source4: bsd.txt
|
Source4: bsd.txt
|
||||||
Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
||||||
|
|
||||||
# https://github.com/iputils/iputils/pull/173
|
Patch001: 0001-build-sys-doc-Fix-the-dependency-on-xsltproc.patch
|
||||||
Patch001: 0001-build-sys-make-rdisc.service-a-regular-unit.patch
|
|
||||||
# https://github.com/iputils/iputils/commit/c503834519d21973323980850431101f90e663ef
|
|
||||||
Patch002: 0002-doc-Use-namespace-correctly.patch
|
|
||||||
Patch100: iputils-ifenslave.patch
|
Patch100: iputils-ifenslave.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -58,7 +55,6 @@ Queries.
|
|||||||
cp %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
%patch001 -p1
|
%patch001 -p1
|
||||||
%patch002 -p1
|
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -135,6 +131,9 @@ install -cp ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
|
|||||||
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 22 2019 Jan Synáček <jsynacek@redhat.com> - 20190515-1
|
||||||
|
- Update to s20190515 (#1710647)
|
||||||
|
|
||||||
* Thu Mar 28 2019 Jan Synáček <jsynacek@redhat.com> - 20190324-1
|
* Thu Mar 28 2019 Jan Synáček <jsynacek@redhat.com> - 20190324-1
|
||||||
- Update to s20190324 (#1692136)
|
- Update to s20190324 (#1692136)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (ifenslave.tar.gz) = 117e4552486f07190e606174dea7666ed6ea0e2bd90d4f389d41f1a5bee31fcec785f18c5e9c281a5c7b71307377eca37f9e461e187e1149820cab5c9e07676a
|
SHA512 (ifenslave.tar.gz) = 117e4552486f07190e606174dea7666ed6ea0e2bd90d4f389d41f1a5bee31fcec785f18c5e9c281a5c7b71307377eca37f9e461e187e1149820cab5c9e07676a
|
||||||
SHA512 (iputils-s20190324.tar.gz) = eeb7e34a279be1ff3e1f81446fef5dfc679654be7b9c4a81538355339d452ee69d738c54ac0be744c9264d8adb9eaf9eae13d7104d1c23fa5659f08c4e3089b6
|
SHA512 (iputils-s20190515.tar.gz) = adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250
|
||||||
|
Loading…
Reference in New Issue
Block a user