parent
e0b32f828c
commit
3ff921f230
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ ifenslave.tar.gz
|
||||
/iputils-s20121221.tar.bz2
|
||||
/iputils-s20140519.tar.gz
|
||||
/iputils-s20150815.tar.gz
|
||||
/iputils-s20160308.tar.gz
|
||||
|
@ -1,99 +0,0 @@
|
||||
commit 7c2ecd4129bc0028d2fe6c038bd3f3a54397a002
|
||||
Author: Jan Synacek <jsynacek@redhat.com>
|
||||
Date: Thu Sep 24 10:53:43 2015 +0200
|
||||
|
||||
doc: ping: add missing options and remove ping6
|
||||
|
||||
diff --git a/doc/ping.sgml b/doc/ping.sgml
|
||||
index 54351c9..16cd874 100644
|
||||
--- a/doc/ping.sgml
|
||||
+++ b/doc/ping.sgml
|
||||
@@ -7,14 +7,14 @@
|
||||
</refmeta>
|
||||
|
||||
<refnamediv>
|
||||
-<refname>ping, ping6</refname>
|
||||
+<refname>ping</refname>
|
||||
<refpurpose>send ICMP ECHO_REQUEST to network hosts</refpurpose>
|
||||
</refnamediv>
|
||||
|
||||
<refsynopsisdiv>
|
||||
<cmdsynopsis>
|
||||
<command>ping</command>
|
||||
-<arg choice="opt"><option>-aAbBdDfhLnOqrRUvV6</option></arg>
|
||||
+<arg choice="opt"><option>-aAbBdDfhLnOqrRUvV46</option></arg>
|
||||
<arg choice="opt">-c <replaceable/count/</arg>
|
||||
<arg choice="opt">-F <replaceable/flowlabel/</arg>
|
||||
<arg choice="opt">-i <replaceable/interval/</arg>
|
||||
@@ -45,7 +45,11 @@ header, followed by a <structname/struct timeval/ and then an arbitrary
|
||||
number of ``pad'' bytes used to fill out the packet.
|
||||
</para>
|
||||
<para>
|
||||
-<command/ping6/ is IPv6 version of <command/ping/, and can also send Node Information Queries (RFC4620).
|
||||
+<command/ping/ works with both IPv4 and IPv6. Using only one of them
|
||||
+explicitly can be enforced by specifying <option/-4/ or <option/-6/.
|
||||
+</para>
|
||||
+<para>
|
||||
+<command/ping/ can also send IPv6 Node Information Queries (RFC4620).
|
||||
Intermediate <replaceable/hop/s may not be allowed, because IPv6 source routing was deprecated (RFC5095).
|
||||
</para>
|
||||
</refsect1>
|
||||
@@ -54,6 +58,18 @@ Intermediate <replaceable/hop/s may not be allowed, because IPv6 source routing
|
||||
|
||||
<variablelist>
|
||||
<varlistentry>
|
||||
+ <term><option/-4/</term>
|
||||
+ <listitem><para>
|
||||
+Use IPv4 only.
|
||||
+ </para></listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
+ <term><option/-6/</term>
|
||||
+ <listitem><para>
|
||||
+Use IPv6 only.
|
||||
+ </para></listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
<term><option/-a/</term>
|
||||
<listitem><para>
|
||||
Audible ping.
|
||||
@@ -120,7 +136,7 @@ Only the super-user may use this option with zero interval.
|
||||
<varlistentry>
|
||||
<term><option>-F <replaceable/flow label/</option></term>
|
||||
<listitem><para>
|
||||
-<command/ping6/ only.
|
||||
+IPv6 only.
|
||||
Allocate and set 20 bit flow label (in hex) on echo request packets.
|
||||
If value is zero, kernel allocates random flow label.
|
||||
</para></listitem>
|
||||
@@ -148,7 +164,7 @@ If <replaceable/interface/ is an address, it sets source address
|
||||
to specified interface address.
|
||||
If <replaceable/interface/ in an interface name, it sets
|
||||
source interface to specified interface.
|
||||
-For <command/ping6/, when doing ping to a link-local scope
|
||||
+For IPv6, when doing ping to a link-local scope
|
||||
address, link specification (by the '%'-notation in
|
||||
<replaceable/destination/, or by this option) is required.
|
||||
</para></listitem>
|
||||
@@ -189,7 +205,7 @@ is large), or <replaceable/dont/ (do not set DF flag).
|
||||
<varlistentry>
|
||||
<term><option>-N <replaceable/nodeinfo_option/</option></term>
|
||||
<listitem><para>
|
||||
-<command/ping6/ only.
|
||||
+IPv6 only.
|
||||
Send ICMPv6 Node Information Queries (RFC4620), instead of Echo Request.
|
||||
<constant/CAP_NET_RAW/ capability is required.
|
||||
<variablelist>
|
||||
@@ -625,6 +641,12 @@ The <command/ping/ command appeared in 4.3BSD.
|
||||
<para>
|
||||
The version described here is its descendant specific to Linux.
|
||||
</para>
|
||||
+<para>
|
||||
+As of version s20150815, the <command/ping6/ binary doesn't exist anymore.
|
||||
+It has been merged into <command/ping/. Creating a symlink named
|
||||
+<command/ping6/ pointing to <command/ping/ will result in the same
|
||||
+funcionality as before.
|
||||
+</para>
|
||||
</refsect1>
|
||||
|
||||
<refsect1><title>SECURITY</title>
|
@ -1,34 +0,0 @@
|
||||
From df41e2509f3bbab594a1c2adba4d404135fc3705 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Synacek <jsynacek@redhat.com>
|
||||
Date: Thu, 19 Nov 2015 10:15:06 +0100
|
||||
Subject: [PATCH] ping: always use POSIX locale when parsing -i
|
||||
|
||||
Interpreting floating-point numbers from the command line based on the
|
||||
current locale is a bad idea.
|
||||
|
||||
Original bugreport: https://bugzilla.redhat.com/show_bug.cgi?id=1283277
|
||||
---
|
||||
ping.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/ping.c b/ping.c
|
||||
index 95a10a7..c42d6eb 100644
|
||||
--- a/ping.c
|
||||
+++ b/ping.c
|
||||
@@ -259,7 +259,13 @@ main(int argc, char **argv)
|
||||
char *ep;
|
||||
|
||||
errno = 0;
|
||||
+#ifdef USE_IDN
|
||||
+ setlocale(LC_ALL, "C");
|
||||
+#endif
|
||||
dbl = strtod(optarg, &ep);
|
||||
+#ifdef USE_IDN
|
||||
+ setlocale(LC_ALL, "");
|
||||
+#endif
|
||||
|
||||
if (errno || *ep != '\0' ||
|
||||
!finite(dbl) || dbl < 0.0 || dbl >= (double)INT_MAX / 1000 - 1.0) {
|
||||
--
|
||||
2.5.0
|
||||
|
11
iputils.spec
11
iputils.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Network monitoring tools including ping
|
||||
Name: iputils
|
||||
Version: 20150815
|
||||
Release: 3%{?dist}
|
||||
Version: 20160308
|
||||
Release: 1%{?dist}
|
||||
# some parts are under the original BSD (ping.c)
|
||||
# some are under GPLv2+ (tracepath.c)
|
||||
License: BSD and GPLv2+
|
||||
@ -20,8 +20,6 @@ Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
||||
|
||||
Patch0: iputils-rh.patch
|
||||
Patch1: iputils-ifenslave.patch
|
||||
Patch2: iputils-doc.patch
|
||||
Patch3: iputils-locale-i.patch
|
||||
|
||||
BuildRequires: docbook-utils perl-SGMLSpm
|
||||
BuildRequires: glibc-kernheaders >= 2.4-8.19
|
||||
@ -59,8 +57,6 @@ cp %{SOURCE4} %{SOURCE5} .
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x
|
||||
@ -162,6 +158,9 @@ mv -f RELNOTES.tmp RELNOTES
|
||||
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
||||
|
||||
%changelog
|
||||
* Wed Mar 9 2016 Jan Synáček <jsynacek@redhat.com> - 20160308-1
|
||||
- Update to s20160308 (#1315975)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 20150815-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user