- upgarde to new upstream iputils-s20070202
- Resolves: #229995 - patches revision
This commit is contained in:
parent
02525b9fbc
commit
154cc82ce8
@ -1,3 +1 @@
|
|||||||
iputils-ss020927.tar.gz
|
iputils-s20070202.tar.bz2
|
||||||
rdisc.initd
|
|
||||||
ifenslave.tar.gz
|
|
||||||
|
@ -160,7 +160,7 @@
|
|||||||
unsigned char packet[4096];
|
unsigned char packet[4096];
|
||||||
- struct sockaddr_ll from;
|
- struct sockaddr_ll from;
|
||||||
+ struct sockaddr_ll from[2];
|
+ struct sockaddr_ll from[2];
|
||||||
int alen = sizeof(from);
|
socklen_t alen = sizeof(from);
|
||||||
int cc;
|
int cc;
|
||||||
|
|
||||||
@@ -513,7 +543,7 @@
|
@@ -513,7 +543,7 @@
|
||||||
|
@ -1,25 +1,5 @@
|
|||||||
--- iputils/ping6.c.OLD 2006-02-06 10:34:35.000000000 +0100
|
|
||||||
+++ iputils/ping6.c 2006-02-06 10:35:38.000000000 +0100
|
|
||||||
@@ -353,7 +353,7 @@
|
|
||||||
hostname = target;
|
|
||||||
|
|
||||||
if (ipv6_addr_any(&source.sin6_addr)) {
|
|
||||||
- int alen;
|
|
||||||
+ socklen_t alen;
|
|
||||||
int probe_fd = socket(AF_INET6, SOCK_DGRAM, 0);
|
|
||||||
|
|
||||||
if (probe_fd < 0) {
|
|
||||||
--- iputils/ping.c.OLD 2006-02-06 10:34:35.000000000 +0100
|
--- iputils/ping.c.OLD 2006-02-06 10:34:35.000000000 +0100
|
||||||
+++ iputils/ping.c 2006-02-06 10:34:35.000000000 +0100
|
+++ iputils/ping.c 2006-02-06 10:34:35.000000000 +0100
|
||||||
@@ -253,7 +253,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
if (source.sin_addr.s_addr == 0) {
|
|
||||||
- int alen;
|
|
||||||
+ socklen_t alen;
|
|
||||||
struct sockaddr_in dst = whereto;
|
|
||||||
int probe_fd = socket(AF_INET, SOCK_DGRAM, 0);
|
|
||||||
|
|
||||||
@@ -855,9 +855,36 @@
|
@@ -855,9 +855,36 @@
|
||||||
case ICMP_SR_FAILED:
|
case ICMP_SR_FAILED:
|
||||||
printf("Source Route Failed\n");
|
printf("Source Route Failed\n");
|
||||||
@ -59,33 +39,6 @@
|
|||||||
break;
|
break;
|
||||||
--- iputils/ping_common.c.OLD 2006-02-06 10:34:35.000000000 +0100
|
--- iputils/ping_common.c.OLD 2006-02-06 10:34:35.000000000 +0100
|
||||||
+++ iputils/ping_common.c 2006-02-06 10:34:35.000000000 +0100
|
+++ iputils/ping_common.c 2006-02-06 10:34:35.000000000 +0100
|
||||||
@@ -67,7 +67,7 @@
|
|
||||||
int ii, jj, kk;
|
|
||||||
int pat[16];
|
|
||||||
char *cp;
|
|
||||||
- char *bp = outpack+8;
|
|
||||||
+ unsigned char *bp = outpack+8;
|
|
||||||
|
|
||||||
for (cp = patp; *cp; cp++) {
|
|
||||||
if (!isxdigit(*cp)) {
|
|
||||||
@@ -393,7 +393,7 @@
|
|
||||||
void sock_setbufs(int icmp_sock, int alloc)
|
|
||||||
{
|
|
||||||
int rcvbuf, hold;
|
|
||||||
- int tmplen = sizeof(hold);
|
|
||||||
+ socklen_t tmplen = sizeof(hold);
|
|
||||||
|
|
||||||
if (!sndbuf)
|
|
||||||
sndbuf = alloc;
|
|
||||||
@@ -464,7 +464,7 @@
|
|
||||||
|
|
||||||
if (!(options & F_PINGFILLED)) {
|
|
||||||
int i;
|
|
||||||
- char *p = outpack+8;
|
|
||||||
+ unsigned char *p = outpack+8;
|
|
||||||
|
|
||||||
/* Do not forget about case of small datalen,
|
|
||||||
* fill timestamp area too!
|
|
||||||
@@ -819,7 +819,7 @@
|
@@ -819,7 +819,7 @@
|
||||||
}
|
}
|
||||||
if (pipesize > 1)
|
if (pipesize > 1)
|
||||||
|
46
iputils.spec
46
iputils.spec
@ -1,35 +1,22 @@
|
|||||||
Summary: Network monitoring tools including ping
|
Summary: Network monitoring tools including ping
|
||||||
Name: iputils
|
Name: iputils
|
||||||
Version: 20020927
|
Version: 20070202
|
||||||
Release: 42%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
|
URL: http://www.skbuff.net/iputils
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: http://www.tux.org/pub/net/ip-routing/%{name}-ss020927.tar.gz
|
Source0: http://www.skbuff.net/iputils/%{name}-s%{version}.tar.bz2
|
||||||
Source1: ifenslave.tar.gz
|
Source1: ifenslave.tar.gz
|
||||||
Source3: rdisc.initd
|
Source3: rdisc.initd
|
||||||
Patch0: iputils-20020927-rh.patch
|
#Patch0: iputils-20020927-rh.patch
|
||||||
Patch1: iputils-20020124-ping_sparcfix.patch
|
|
||||||
Patch2: iputils-20020124-rdisc-server.patch
|
|
||||||
Patch3: iputils-20020124-countermeasures.patch
|
Patch3: iputils-20020124-countermeasures.patch
|
||||||
Patch4: iputils-20020927-addrcache.patch
|
Patch4: iputils-20020927-addrcache.patch
|
||||||
Patch5: iputils-20020927-ping-subint.patch
|
Patch5: iputils-20020927-ping-subint.patch
|
||||||
Patch6: iputils-20020927-icmp_seq.patch
|
|
||||||
Patch7: iputils-glibckernheaders.patch
|
|
||||||
Patch8: iputils-20020927-headers.patch
|
|
||||||
Patch9: iputils-20020927-unaligned.patch
|
Patch9: iputils-20020927-unaligned.patch
|
||||||
Patch10: iputils-20020927-inet_pton.patch
|
|
||||||
Patch11: iputils-retvals.patch
|
|
||||||
Patch13: iputils-20020927-ia64_align.patch
|
Patch13: iputils-20020927-ia64_align.patch
|
||||||
Patch15: iputils-20020927-12-arping.patch
|
Patch15: iputils-20020927-12-arping.patch
|
||||||
Patch16: iputils-getaddrinfo.patch
|
|
||||||
Patch17: iputils-flood.patch
|
|
||||||
Patch18: iputils-ping-168166.patch
|
|
||||||
Patch19: iputils-ipv6-hoplimit.patch
|
|
||||||
Patch20: iputils-gcc41.patch
|
|
||||||
Patch21: iputils-ping_cleanup.patch
|
Patch21: iputils-ping_cleanup.patch
|
||||||
Patch22: iputils-ifenslave.patch
|
Patch22: iputils-ifenslave.patch
|
||||||
Patch23: iputils-20020927-trace_stop.patch
|
|
||||||
Patch24: iputils-20020927-ping6-rfc3484.patch
|
|
||||||
Patch25: iputils-20020927-arping-infiniband.patch
|
Patch25: iputils-20020927-arping-infiniband.patch
|
||||||
|
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
@ -46,31 +33,17 @@ ECHO_REQUEST packets to a specified network host to discover whether
|
|||||||
the target machine is alive and receiving network traffic.
|
the target machine is alive and receiving network traffic.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a 1 -n %{name}
|
%setup -q -a 1 -n %{name}-s%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .rh
|
#%patch0 -p1 -b .rh
|
||||||
%patch1 -p1 -b .ping_sparcfix
|
|
||||||
%patch2 -p1 -b .rdisc-server
|
|
||||||
%patch3 -p1 -b .countermeasures
|
%patch3 -p1 -b .countermeasures
|
||||||
%patch4 -p1 -b .addrcache
|
%patch4 -p1 -b .addrcache
|
||||||
%patch5 -p1 -b .ping-subint
|
%patch5 -p1 -b .ping-subint
|
||||||
%patch6 -p1 -b .icmp_seq
|
|
||||||
%patch7 -p1 -b .glibckernheaders
|
|
||||||
%patch8 -p1 -b .headers
|
|
||||||
%patch9 -p1 -b .unaligned
|
%patch9 -p1 -b .unaligned
|
||||||
%patch10 -p1 -b .inet_pton
|
|
||||||
%patch11 -p1 -b .retvals
|
|
||||||
%patch13 -p1 -b .align
|
%patch13 -p1 -b .align
|
||||||
%patch15 -p1 -b .timeout
|
%patch15 -p1 -b .timeout
|
||||||
%patch16 -p1 -b .getaddrinfo
|
|
||||||
%patch17 -p1 -b .flood
|
|
||||||
%patch18 -p1 -b .memset
|
|
||||||
%patch19 -p1 -b .hoplimit
|
|
||||||
%patch20 -p1 -b .gcc41
|
|
||||||
%patch21 -p1 -b .cleanup
|
%patch21 -p1 -b .cleanup
|
||||||
%patch22 -p1 -b .addr
|
%patch22 -p1 -b .addr
|
||||||
%patch23 -p1 -b .trace_stop
|
|
||||||
%patch24 -p1 -b .rfc3484
|
|
||||||
%patch25 -p1 -b .infiniband
|
%patch25 -p1 -b .infiniband
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -166,6 +139,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_sysconfdir}/rc.d/init.d/rdisc
|
%{_sysconfdir}/rc.d/init.d/rdisc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 15 2007 Martin Bacovsky <mbacovsk@redhat.com> - 20070202-1
|
||||||
|
- upgarde to new upstream iputils-s20070202
|
||||||
|
- Resolves: #229995
|
||||||
|
- patches revision
|
||||||
|
|
||||||
* Thu Feb 22 2007 Martin Bacovsky <mbacovsk@redhat.com>- 20020927-42
|
* Thu Feb 22 2007 Martin Bacovsky <mbacovsk@redhat.com>- 20020927-42
|
||||||
- Resolves: #218706 - now defines the destination address along RFC3484
|
- Resolves: #218706 - now defines the destination address along RFC3484
|
||||||
- Resolves: #229630 - ifenslave(8) man page added
|
- Resolves: #229630 - ifenslave(8) man page added
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
b5493f7a2997130a4f86c486c9993b86 iputils-ss020927.tar.gz
|
|
||||||
349c02b907d61a143876f85cbd006c89 rdisc.initd
|
349c02b907d61a143876f85cbd006c89 rdisc.initd
|
||||||
7b1b81338efea21dd5ecac3fd1f89c1b ifenslave.tar.gz
|
7b1b81338efea21dd5ecac3fd1f89c1b ifenslave.tar.gz
|
||||||
|
1d38fb3cfc2b71496e43cf646bfc1d6e iputils-s20070202.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user