- resolves: #236725: ping does not work for subsecond intervals for
ordinary user - resolves: #243197: RFE: Please sync ifenslave with current kernel - resolves: #246954: Initscript Review
This commit is contained in:
parent
2c325dfbbe
commit
10f1992875
@ -1 +1,3 @@
|
|||||||
iputils-s20070202.tar.bz2
|
iputils-s20070202.tar.bz2
|
||||||
|
rdisc.initd
|
||||||
|
ifenslave.tar.gz
|
||||||
|
@ -1,10 +1,5 @@
|
|||||||
Patch by Robert Scheck <redhat@linuxnetz.de> for iputils >= 20070202, which adds
|
--- iputils-s20070202/ping.c.idn 2007-08-06 14:45:36.000000000 +0200
|
||||||
IDN support (umlaut domains) to ping and ping6. For ping this requires the libidn
|
+++ iputils-s20070202/ping.c 2007-08-06 14:45:36.000000000 +0200
|
||||||
package installed. For ping6, glibc >= 2.3.4 or glibc 2.3.3 CVS >= 20031001 is
|
|
||||||
needed.
|
|
||||||
|
|
||||||
--- iputils-s20070202/ping.c 2007-03-11 12:22:08.000000000 +0100
|
|
||||||
+++ iputils-s20070202/ping.c.idn 2007-03-11 14:05:40.000000000 +0100
|
|
||||||
@@ -58,6 +58,12 @@
|
@@ -58,6 +58,12 @@
|
||||||
* This program has to run SUID to ROOT to access the ICMP socket.
|
* This program has to run SUID to ROOT to access the ICMP socket.
|
||||||
*/
|
*/
|
||||||
@ -17,8 +12,8 @@ needed.
|
|||||||
+
|
+
|
||||||
#include "ping_common.h"
|
#include "ping_common.h"
|
||||||
|
|
||||||
#include <linux/icmp.h>
|
#include <netinet/ip.h>
|
||||||
@@ -115,6 +121,12 @@
|
@@ -122,6 +128,12 @@
|
||||||
char *target, hnamebuf[MAXHOSTNAMELEN];
|
char *target, hnamebuf[MAXHOSTNAMELEN];
|
||||||
char rspace[3 + 4 * NROUTES + 1]; /* record route space */
|
char rspace[3 + 4 * NROUTES + 1]; /* record route space */
|
||||||
|
|
||||||
@ -31,7 +26,7 @@ needed.
|
|||||||
icmp_sock = socket(AF_INET, SOCK_RAW, IPPROTO_ICMP);
|
icmp_sock = socket(AF_INET, SOCK_RAW, IPPROTO_ICMP);
|
||||||
socket_errno = errno;
|
socket_errno = errno;
|
||||||
|
|
||||||
@@ -236,13 +248,35 @@
|
@@ -242,13 +254,35 @@
|
||||||
if (argc == 1)
|
if (argc == 1)
|
||||||
options |= F_NUMERIC;
|
options |= F_NUMERIC;
|
||||||
} else {
|
} else {
|
||||||
@ -67,9 +62,9 @@ needed.
|
|||||||
hnamebuf[sizeof(hnamebuf) - 1] = 0;
|
hnamebuf[sizeof(hnamebuf) - 1] = 0;
|
||||||
hostname = hnamebuf;
|
hostname = hnamebuf;
|
||||||
}
|
}
|
||||||
--- iputils-s20070202/Makefile 2007-03-11 12:22:08.000000000 +0100
|
--- iputils-s20070202/Makefile.idn 2007-08-06 14:45:36.000000000 +0200
|
||||||
+++ iputils-s20070202/Makefile.idn 2007-03-11 14:16:56.000000000 +0100
|
+++ iputils-s20070202/Makefile 2007-08-06 14:45:36.000000000 +0200
|
||||||
@@ -35,8 +35,13 @@
|
@@ -27,8 +27,13 @@
|
||||||
|
|
||||||
|
|
||||||
tftpd: tftpd.o tftpsubs.o
|
tftpd: tftpd.o tftpsubs.o
|
||||||
@ -83,8 +78,8 @@ needed.
|
|||||||
ping.o ping6.o ping_common.o: ping_common.h
|
ping.o ping6.o ping_common.o: ping_common.h
|
||||||
tftpd.o tftpsubs.o: tftp.h
|
tftpd.o tftpsubs.o: tftp.h
|
||||||
|
|
||||||
--- iputils-s20070202/ping6.c 2007-03-25 13:21:27.000000000 +0200
|
--- iputils-s20070202/ping6.c.idn 2007-08-06 14:45:36.000000000 +0200
|
||||||
+++ iputils-s20070202/ping6.c.idn 2007-03-25 13:53:16.000000000 +0200
|
+++ iputils-s20070202/ping6.c 2007-08-06 14:45:36.000000000 +0200
|
||||||
@@ -66,6 +66,12 @@
|
@@ -66,6 +66,12 @@
|
||||||
* More statistics could always be gathered.
|
* More statistics could always be gathered.
|
||||||
* This program has to run SUID to ROOT to access the ICMP socket.
|
* This program has to run SUID to ROOT to access the ICMP socket.
|
||||||
@ -129,3 +124,34 @@ needed.
|
|||||||
gai = getaddrinfo(target, NULL, &hints, &ai);
|
gai = getaddrinfo(target, NULL, &hints, &ai);
|
||||||
if (gai) {
|
if (gai) {
|
||||||
fprintf(stderr, "unknown host\n");
|
fprintf(stderr, "unknown host\n");
|
||||||
|
--- iputils-s20070202/ping_common.c.idn 2007-08-06 14:45:36.000000000 +0200
|
||||||
|
+++ iputils-s20070202/ping_common.c 2007-08-06 14:47:41.000000000 +0200
|
||||||
|
@@ -1,3 +1,8 @@
|
||||||
|
+#define LIBIDN
|
||||||
|
+#ifdef LIBIDN
|
||||||
|
+#include <locale.h>
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#include "ping_common.h"
|
||||||
|
#include <ctype.h>
|
||||||
|
#include <sched.h>
|
||||||
|
@@ -97,6 +102,9 @@
|
||||||
|
|
||||||
|
void common_options(int ch)
|
||||||
|
{
|
||||||
|
+#ifdef LIBIDN
|
||||||
|
+ setlocale(LC_ALL, "C");
|
||||||
|
+#endif
|
||||||
|
switch(ch) {
|
||||||
|
case 'a':
|
||||||
|
options |= F_AUDIBLE;
|
||||||
|
@@ -222,6 +230,9 @@
|
||||||
|
default:
|
||||||
|
abort();
|
||||||
|
}
|
||||||
|
+#ifdef LIBIDN
|
||||||
|
+ setlocale(LC_ALL, "");
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Network monitoring tools including ping
|
Summary: Network monitoring tools including ping
|
||||||
Name: iputils
|
Name: iputils
|
||||||
Version: 20070202
|
Version: 20070202
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.skbuff.net/iputils
|
URL: http://www.skbuff.net/iputils
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -145,6 +145,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_sysconfdir}/rc.d/init.d/rdisc
|
%{_sysconfdir}/rc.d/init.d/rdisc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 3 2007 Martin Bacovsky <mbacovsk@redhat.com> - 20070202-4
|
||||||
|
- resolves: #236725: ping does not work for subsecond intervals for ordinary user
|
||||||
|
- resolves: #243197: RFE: Please sync ifenslave with current kernel
|
||||||
|
- resolves: #246954: Initscript Review
|
||||||
|
|
||||||
* Fri Apr 6 2007 Martin Bacovsky <mbacovsk@redhat.com> - 20070202-3
|
* Fri Apr 6 2007 Martin Bacovsky <mbacovsk@redhat.com> - 20070202-3
|
||||||
- resolves: #235374: Update of iputils starts rdisc, breaking connectivity
|
- resolves: #235374: Update of iputils starts rdisc, breaking connectivity
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
349c02b907d61a143876f85cbd006c89 rdisc.initd
|
|
||||||
7b1b81338efea21dd5ecac3fd1f89c1b ifenslave.tar.gz
|
|
||||||
1d38fb3cfc2b71496e43cf646bfc1d6e iputils-s20070202.tar.bz2
|
1d38fb3cfc2b71496e43cf646bfc1d6e iputils-s20070202.tar.bz2
|
||||||
|
3d892612fea39310ee054f59f3931132 rdisc.initd
|
||||||
|
9071449369f52f374faf40811b1669ed ifenslave.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user