Update to s20150815 (#617934)

This commit is contained in:
Jan Synacek 2015-09-24 09:27:52 +02:00
parent 9e31ea3137
commit 07bcb8457c
6 changed files with 114 additions and 58 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@ ifenslave.tar.gz
/iputils-s20121207.tar.bz2
/iputils-s20121221.tar.bz2
/iputils-s20140519.tar.gz
/iputils-s20150815.tar.gz

99
iputils-doc.patch Normal file
View File

@ -0,0 +1,99 @@
commit 7c2ecd4129bc0028d2fe6c038bd3f3a54397a002
Author: Jan Synacek <jsynacek@redhat.com>
Date: Thu Sep 24 10:53:43 2015 +0200
doc: ping: add missing options and remove ping6
diff --git a/doc/ping.sgml b/doc/ping.sgml
index 54351c9..16cd874 100644
--- a/doc/ping.sgml
+++ b/doc/ping.sgml
@@ -7,14 +7,14 @@
</refmeta>
<refnamediv>
-<refname>ping, ping6</refname>
+<refname>ping</refname>
<refpurpose>send ICMP ECHO_REQUEST to network hosts</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
<command>ping</command>
-<arg choice="opt"><option>-aAbBdDfhLnOqrRUvV6</option></arg>
+<arg choice="opt"><option>-aAbBdDfhLnOqrRUvV46</option></arg>
<arg choice="opt">-c <replaceable/count/</arg>
<arg choice="opt">-F <replaceable/flowlabel/</arg>
<arg choice="opt">-i <replaceable/interval/</arg>
@@ -45,7 +45,11 @@ header, followed by a <structname/struct timeval/ and then an arbitrary
number of ``pad'' bytes used to fill out the packet.
</para>
<para>
-<command/ping6/ is IPv6 version of <command/ping/, and can also send Node Information Queries (RFC4620).
+<command/ping/ works with both IPv4 and IPv6. Using only one of them
+explicitly can be enforced by specifying <option/-4/ or <option/-6/.
+</para>
+<para>
+<command/ping/ can also send IPv6 Node Information Queries (RFC4620).
Intermediate <replaceable/hop/s may not be allowed, because IPv6 source routing was deprecated (RFC5095).
</para>
</refsect1>
@@ -54,6 +58,18 @@ Intermediate <replaceable/hop/s may not be allowed, because IPv6 source routing
<variablelist>
<varlistentry>
+ <term><option/-4/</term>
+ <listitem><para>
+Use IPv4 only.
+ </para></listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><option/-6/</term>
+ <listitem><para>
+Use IPv6 only.
+ </para></listitem>
+ </varlistentry>
+ <varlistentry>
<term><option/-a/</term>
<listitem><para>
Audible ping.
@@ -120,7 +136,7 @@ Only the super-user may use this option with zero interval.
<varlistentry>
<term><option>-F <replaceable/flow label/</option></term>
<listitem><para>
-<command/ping6/ only.
+IPv6 only.
Allocate and set 20 bit flow label (in hex) on echo request packets.
If value is zero, kernel allocates random flow label.
</para></listitem>
@@ -148,7 +164,7 @@ If <replaceable/interface/ is an address, it sets source address
to specified interface address.
If <replaceable/interface/ in an interface name, it sets
source interface to specified interface.
-For <command/ping6/, when doing ping to a link-local scope
+For IPv6, when doing ping to a link-local scope
address, link specification (by the '%'-notation in
<replaceable/destination/, or by this option) is required.
</para></listitem>
@@ -189,7 +205,7 @@ is large), or <replaceable/dont/ (do not set DF flag).
<varlistentry>
<term><option>-N <replaceable/nodeinfo_option/</option></term>
<listitem><para>
-<command/ping6/ only.
+IPv6 only.
Send ICMPv6 Node Information Queries (RFC4620), instead of Echo Request.
<constant/CAP_NET_RAW/ capability is required.
<variablelist>
@@ -625,6 +641,12 @@ The <command/ping/ command appeared in 4.3BSD.
<para>
The version described here is its descendant specific to Linux.
</para>
+<para>
+As of version s20150815, the <command/ping6/ binary doesn't exist anymore.
+It has been merged into <command/ping/. Creating a symlink named
+<command/ping6/ pointing to <command/ping/ will result in the same
+funcionality as before.
+</para>
</refsect1>
<refsect1><title>SECURITY</title>

View File

@ -1,37 +1,11 @@
--- iputils-s20140519-dist/Makefile 2014-05-19 23:35:28.000000000 +0200
+++ iputils-s20140519-new/Makefile 2014-05-20 10:51:07.388527442 +0200
@@ -26,7 +26,7 @@ USE_CAP=yes
# sysfs support (with libsysfs - deprecated) [no|yes|static]
USE_SYSFS=no
# IDN support (experimental) [no|yes|static]
-USE_IDN=no
+USE_IDN=yes
# Do not use getifaddrs [no|yes|static]
WITHOUT_IFADDRS=no
@@ -34,7 +34,7 @@ WITHOUT_IFADDRS=no
ARPING_DEFAULT_DEVICE=
# GNU TLS library for ping6 [yes|no|static]
-USE_GNUTLS=yes
+USE_GNUTLS=no
# Crypto library for ping6 [shared|static|no]
USE_CRYPTO=shared
# Resolv library for ping6 [yes|static]
@@ -49,7 +49,7 @@ ENABLE_RDISC_SERVER=no
--- iputils-s20150815/Makefile 2015-08-15 16:07:28.000000000 +0200
+++ iputils-s20150815-new/Makefile 2015-09-24 09:22:09.000000000 +0200
@@ -52,7 +52,7 @@ ENABLE_RDISC_SERVER=no
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
# CFLAGS+=-fno-strict-aliasing -Wstrict-prototypes -Wall -Werror -g
CFLAGS?=-O3 -g
-CFLAGS+=-fno-strict-aliasing -Wstrict-prototypes -Wall
+CFLAGS+=$(RPM_OPT_FLAGS) -fno-strict-aliasing -Wstrict-prototypes -Wall -Werror
+CFLAGS+=$(RPM_OPT_FLAGS) -fno-strict-aliasing -Wstrict-prototypes -Wall
CPPFLAGS+=-D_GNU_SOURCE
LDLIB=
@@ -188,6 +188,7 @@ tftpd.o tftpsubs.o: tftp.h
# -------------------------------------
# ninfod
+ninfod: CFLAGS:=$(filter-out -Werror,$(CFLAGS))
ninfod:
@set -e; \
if [ ! -f ninfod/Makefile ]; then \

View File

@ -1,19 +0,0 @@
commit 51aad205e5e8289b52241cd41b15e0f116c4442a
Author: Jan Synacek <jsynacek@redhat.com>
Date: Tue May 20 11:17:00 2014 +0200
tracepath,doc: fix corrupted tag
diff --git a/doc/tracepath.sgml b/doc/tracepath.sgml
index 8048c80..756572f 100644
--- a/doc/tracepath.sgml
+++ b/doc/tracepath.sgml
@@ -69,7 +69,7 @@ Sets the initial packet length to <replaceable/pktlen/ instead of
</varlistentry>
<varlistentry>
- <term><option/-m</term>
+ <term><option>-m</option></term>
<listitem><para>
Set maximum hops (or maximum TTLs) to <replaceable/max_hops/
instead of 30.

View File

@ -2,8 +2,8 @@
Summary: Network monitoring tools including ping
Name: iputils
Version: 20140519
Release: 6%{?dist}
Version: 20150815
Release: 1%{?dist}
# some parts are under the original BSD (ping.c)
# some are under GPLv2+ (tracepath.c)
License: BSD and GPLv2+
@ -20,8 +20,7 @@ Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
Patch0: iputils-rh.patch
Patch1: iputils-ifenslave.patch
# pending upstream inclusion
Patch2: iputils-tracepath-doc.patch
Patch2: iputils-doc.patch
BuildRequires: docbook-utils perl-SGMLSpm
BuildRequires: glibc-kernheaders >= 2.4-8.19
@ -69,7 +68,7 @@ cp %{SOURCE4} %{SOURCE5} .
%endif
export LDFLAGS="-pie -Wl,-z,relro,-z,now"
make %{?_smp_mflags} arping clockdiff ping ping6 rdisc tracepath tracepath6 \
make %{?_smp_mflags} arping clockdiff ping rdisc tracepath tracepath6 \
ninfod
gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
make -C doc man
@ -84,13 +83,13 @@ install -cp arping ${RPM_BUILD_ROOT}%{_sbindir}/
install -cp ping ${RPM_BUILD_ROOT}%{_bindir}/
install -cp ifenslave ${RPM_BUILD_ROOT}%{_sbindir}/
install -cp rdisc ${RPM_BUILD_ROOT}%{_sbindir}/
install -cp ping6 ${RPM_BUILD_ROOT}%{_bindir}/
install -cp tracepath ${RPM_BUILD_ROOT}%{_bindir}/
install -cp tracepath6 ${RPM_BUILD_ROOT}%{_bindir}/
install -cp ninfod/ninfod ${RPM_BUILD_ROOT}%{_sbindir}/
mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
ln -sf ../bin/ping6 ${RPM_BUILD_ROOT}%{_sbindir}
ln -sf ../bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
ln -sf ../bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
ln -sf ../bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
ln -sf ../bin/tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}
@ -141,7 +140,6 @@ mv -f RELNOTES.tmp RELNOTES
%attr(0755,root,root) %caps(cap_net_raw=ep cap_net_admin=ep) %{_bindir}/ping
%{_sbindir}/ifenslave
%{_sbindir}/rdisc
%attr(0755,root,root) %caps(cap_net_raw=ep cap_net_admin=ep) %{_bindir}/ping6
%{_bindir}/tracepath
%{_bindir}/tracepath6
%{_sbindir}/ping6
@ -162,6 +160,9 @@ mv -f RELNOTES.tmp RELNOTES
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
%changelog
* Thu Sep 24 2015 Jan Synáček <jsynacek@redhat.com> - 20150815-1
- Update to s20150815 (#617934)
* Sun Aug 23 2015 Peter Robinson <pbrobinson@fedoraproject.org> 20140519-6
- Don't depend on chkconfig, uses systemctl now

View File

@ -1,2 +1,2 @@
72943b0b6406c514f19de38218426afa iputils-s20140519.tar.gz
df73d2afa5350e53ffa3a11530172c87 iputils-s20150815.tar.gz
6702c58e970e6a73fc8d9b7c9b63af35 ifenslave.tar.gz