Update to 20200821 release. Fixes bug #1871310
This commit is contained in:
parent
d25aa1e7d9
commit
04aeef4719
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ ifenslave.tar.gz
|
|||||||
/iputils-s20180629.tar.gz
|
/iputils-s20180629.tar.gz
|
||||||
/iputils-s20190324.tar.gz
|
/iputils-s20190324.tar.gz
|
||||||
/iputils-s20190515.tar.gz
|
/iputils-s20190515.tar.gz
|
||||||
|
/iputils-s20200821.tar.gz
|
||||||
|
@ -1,77 +0,0 @@
|
|||||||
From 3b013f271931c3fe771e5a2c591f35d617de90f3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Weiss <dev.primeos@gmail.com>
|
|
||||||
Date: Thu, 16 May 2019 10:08:50 +0000
|
|
||||||
Subject: [PATCH] build-sys/doc: Fix the dependency on xsltproc
|
|
||||||
|
|
||||||
This dependency is only required if either the man pages or the HTML
|
|
||||||
documentation is being build. Both targets require docbook-xsl-ns and
|
|
||||||
not docbook-xsl (the former is preferred and in use since c503834).
|
|
||||||
---
|
|
||||||
.travis.yml | 1 -
|
|
||||||
doc/meson.build | 27 +++++++++++++++++----------
|
|
||||||
2 files changed, 17 insertions(+), 11 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/.travis.yml b/.travis.yml
|
|
||||||
index 54edb61..6a6e8c3 100644
|
|
||||||
--- a/.travis.yml
|
|
||||||
+++ b/.travis.yml
|
|
||||||
@@ -14,7 +14,6 @@ addons:
|
|
||||||
- "libidn2-0-dev"
|
|
||||||
- "nettle-dev"
|
|
||||||
- "xsltproc"
|
|
||||||
- - "docbook-xsl"
|
|
||||||
- "docbook-xsl-ns"
|
|
||||||
matrix:
|
|
||||||
include:
|
|
||||||
diff --git a/doc/meson.build b/doc/meson.build
|
|
||||||
index 369090f..9a007b3 100644
|
|
||||||
--- a/doc/meson.build
|
|
||||||
+++ b/doc/meson.build
|
|
||||||
@@ -38,7 +38,7 @@ if build_ninfod == true
|
|
||||||
manpages += ['ninfod']
|
|
||||||
endif
|
|
||||||
|
|
||||||
-xsltproc = find_program('xsltproc', required : true)
|
|
||||||
+xsltproc = find_program('xsltproc', required : build_mans or build_html_mans)
|
|
||||||
xsltproc_args = [
|
|
||||||
'--nonet',
|
|
||||||
'--stringparam', 'man.output.quietly', '1',
|
|
||||||
@@ -48,19 +48,26 @@ xsltproc_args = [
|
|
||||||
]
|
|
||||||
|
|
||||||
if xsltproc.found()
|
|
||||||
- xsl = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
|
|
||||||
- testrun = run_command([xsltproc, '--nonet', xsl])
|
|
||||||
- xsltproc_works = testrun.returncode() == 0
|
|
||||||
- if xsltproc_works == false
|
|
||||||
- warning('xsltproc: cannot process ' + xsl)
|
|
||||||
+ doc_targets = []
|
|
||||||
+ if build_mans
|
|
||||||
+ doc_targets += ['manpages']
|
|
||||||
endif
|
|
||||||
-else
|
|
||||||
- warning('No docbook stylesheet found for generating man pages')
|
|
||||||
- xsltproc_works = false
|
|
||||||
+ if build_html_mans
|
|
||||||
+ doc_targets += ['html']
|
|
||||||
+ endif
|
|
||||||
+ xsltproc_works = true
|
|
||||||
+ foreach doc_target : doc_targets
|
|
||||||
+ xsl = 'http://docbook.sourceforge.net/release/xsl-ns/current/' + doc_target + '/docbook.xsl'
|
|
||||||
+ testrun = run_command([xsltproc, '--nonet', xsl])
|
|
||||||
+ if testrun.returncode() != 0
|
|
||||||
+ xsltproc_works = false
|
|
||||||
+ warning('xsltproc: cannot process ' + xsl)
|
|
||||||
+ endif
|
|
||||||
+ endforeach
|
|
||||||
endif
|
|
||||||
|
|
||||||
if xsltproc_works == false
|
|
||||||
- error('Man pages cannot be built: xsltproc does not work correctly')
|
|
||||||
+ error('Docs cannot be built: xsltproc does not work correctly')
|
|
||||||
endif
|
|
||||||
|
|
||||||
if build_mans
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -1,35 +0,0 @@
|
|||||||
From 84ca65ca980315c73f929fed8b6f16bbd698c3a0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sami Kerola <kerolasa@iki.fi>
|
|
||||||
Date: Fri, 5 Jul 2019 21:01:53 +0100
|
|
||||||
Subject: arping: fix sent vs received packages return value
|
|
||||||
|
|
||||||
My earlier signalfd() and timerfd() work really messed up sent vs received
|
|
||||||
package counter comparison, and related command return value. Basically
|
|
||||||
everything always mismatched, and that was expected with corner case of one
|
|
||||||
package only that did match and caused none-zero return. Oh my, that is
|
|
||||||
pretty much as wrong the code could have been.
|
|
||||||
|
|
||||||
Reported-by: MarcusRoeckrath
|
|
||||||
Addresses: https://github.com/iputils/iputils/issues/190
|
|
||||||
Broken-since: 67e070d08dcbec990e1178360f82b3e2ca4f6d5f
|
|
||||||
Signed-off-by: Sami Kerola <kerolasa@iki.fi>
|
|
||||||
---
|
|
||||||
arping.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/arping.c b/arping.c
|
|
||||||
index a1ec231..77c9c56 100644
|
|
||||||
--- a/arping.c
|
|
||||||
+++ b/arping.c
|
|
||||||
@@ -792,7 +792,7 @@ static int event_loop(struct run_state *ctl)
|
|
||||||
close(tfd);
|
|
||||||
freeifaddrs(ctl->ifa0);
|
|
||||||
rc |= finish(ctl);
|
|
||||||
- rc |= !(ctl->brd_sent != ctl->received);
|
|
||||||
+ rc |= (ctl->sent != ctl->received);
|
|
||||||
return rc;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
10
iputils.spec
10
iputils.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Network monitoring tools including ping
|
Summary: Network monitoring tools including ping
|
||||||
Name: iputils
|
Name: iputils
|
||||||
Version: 20190515
|
Version: 20200821
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
# some parts are under the original BSD (ping.c)
|
# some parts are under the original BSD (ping.c)
|
||||||
# some are under GPLv2+ (tracepath.c)
|
# some are under GPLv2+ (tracepath.c)
|
||||||
License: BSD and GPLv2+
|
License: BSD and GPLv2+
|
||||||
@ -17,8 +17,6 @@ Source3: ninfod.service
|
|||||||
Source4: bsd.txt
|
Source4: bsd.txt
|
||||||
Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
Source5: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
|
||||||
|
|
||||||
Patch001: 0001-build-sys-doc-Fix-the-dependency-on-xsltproc.patch
|
|
||||||
Patch002: 0002-arping-fix-sent-vs-received-packages-return-value.patch
|
|
||||||
Patch100: iputils-ifenslave.patch
|
Patch100: iputils-ifenslave.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -55,7 +53,6 @@ Queries.
|
|||||||
%setup -q -a 1 -n %{name}-s%{version}
|
%setup -q -a 1 -n %{name}-s%{version}
|
||||||
cp %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
%patch001 -p1
|
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -134,6 +131,9 @@ install -cp ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
|
|||||||
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
%attr(644,root,root) %{_mandir}/man8/ninfod.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 31 2020 Kevin Fenzi <kevin@scrye.com> - 20200821-1
|
||||||
|
- Update to 20200821 release. Fixes bug #1871310
|
||||||
|
|
||||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 20190515-8
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 20190515-8
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
|||||||
SHA512 (ifenslave.tar.gz) = 117e4552486f07190e606174dea7666ed6ea0e2bd90d4f389d41f1a5bee31fcec785f18c5e9c281a5c7b71307377eca37f9e461e187e1149820cab5c9e07676a
|
SHA512 (iputils-s20200821.tar.gz) = 4a57c3637cdd9aab2600682774e27370716cbdf1c7ac8ae61bf86c21c08701a5b697792df4aa95309b196eaa74f3cb6b2836a40f04da0e602156e982ac99d8c9
|
||||||
SHA512 (iputils-s20190515.tar.gz) = adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250
|
|
||||||
|
Loading…
Reference in New Issue
Block a user