[tw] added patches
This commit is contained in:
parent
32bdef74b2
commit
d7580e1c28
49
iptables-1.3.8-headers.patch
Normal file
49
iptables-1.3.8-headers.patch
Normal file
@ -0,0 +1,49 @@
|
||||
diff -up iptables-1.3.8/extensions/.frag-test6.headers iptables-1.3.8/extensions/.frag-test6
|
||||
--- iptables-1.3.8/extensions/.frag-test6.headers 2007-08-23 14:05:44.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.frag-test6 2007-08-23 15:51:17.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_frag.c -a -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_frag.h ] && echo frag
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_frag.h ] && echo frag
|
||||
diff -up iptables-1.3.8/extensions/.CLUSTERIP-test.headers iptables-1.3.8/extensions/.CLUSTERIP-test
|
||||
--- iptables-1.3.8/extensions/.CLUSTERIP-test.headers 2007-08-23 15:43:36.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.CLUSTERIP-test 2007-08-23 15:45:32.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#! /bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv4/netfilter/ipt_CLUSTERIP.c ] && echo CLUSTERIP
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv4/ipt_CLUSTERIP.h ] && echo CLUSTERIP
|
||||
diff -up iptables-1.3.8/extensions/.statistic-test.headers iptables-1.3.8/extensions/.statistic-test
|
||||
--- iptables-1.3.8/extensions/.statistic-test.headers 2007-08-23 15:46:20.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.statistic-test 2007-08-23 15:46:22.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/netfilter/xt_statistic.c -a -f $KERNEL_DIR/include/linux/netfilter/xt_statistic.h ] && echo statistic
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter/xt_statistic.h ] && echo statistic
|
||||
diff -up iptables-1.3.8/extensions/.ah-test6.headers iptables-1.3.8/extensions/.ah-test6
|
||||
--- iptables-1.3.8/extensions/.ah-test6.headers 2007-08-23 15:52:48.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.ah-test6 2007-08-23 15:52:49.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_ah.c -a -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_ah.h ] && echo ah
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_ah.h ] && echo ah
|
||||
diff -up iptables-1.3.8/extensions/.opts-test6.headers iptables-1.3.8/extensions/.opts-test6
|
||||
--- iptables-1.3.8/extensions/.opts-test6.headers 2007-08-23 15:49:16.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.opts-test6 2007-08-23 15:49:19.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_hbh.c -a -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_dst.c -a -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_opts.h ] && echo hbh dst
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_opts.h ] && echo hbh dst
|
||||
diff -up iptables-1.3.8/extensions/.ipv6header-test6.headers iptables-1.3.8/extensions/.ipv6header-test6
|
||||
--- iptables-1.3.8/extensions/.ipv6header-test6.headers 2007-08-23 14:05:45.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.ipv6header-test6 2007-08-23 15:50:26.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_ipv6header.c -a -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_ipv6header.h ] && echo ipv6header
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_ipv6header.h ] && echo ipv6header
|
||||
diff -up iptables-1.3.8/extensions/.rt-test6.headers iptables-1.3.8/extensions/.rt-test6
|
||||
--- iptables-1.3.8/extensions/.rt-test6.headers 2007-08-23 15:47:21.000000000 +0200
|
||||
+++ iptables-1.3.8/extensions/.rt-test6 2007-08-23 15:47:23.000000000 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-[ -f $KERNEL_DIR/net/ipv6/netfilter/ip6t_rt.c -a -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_rt.h ] && echo rt
|
||||
+[ -f $KERNEL_DIR/include/linux/netfilter_ipv6/ip6t_rt.h ] && echo rt
|
12
iptables-1.3.8-iptc.patch
Normal file
12
iptables-1.3.8-iptc.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up iptables-1.3.8/libiptc/Makefile.iptc iptables-1.3.8/libiptc/Makefile
|
||||
--- iptables-1.3.8/libiptc/Makefile.iptc 2007-08-23 13:52:17.000000000 +0200
|
||||
+++ iptables-1.3.8/libiptc/Makefile 2007-08-23 13:54:28.000000000 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
EXTRAS+=libiptc/libiptc.a
|
||||
|
||||
# libiptc is not a public interface and therefore not installed
|
||||
-# DEVEL_LIBS+=libiptc/libiptc.a
|
||||
+DEVEL_LIBS+=libiptc/libiptc.a
|
||||
|
||||
ifndef TOPLEVEL_INCLUDED
|
||||
local:
|
Loading…
Reference in New Issue
Block a user