initial import
This commit is contained in:
parent
1261c76d32
commit
bae54c1e2d
@ -0,0 +1 @@
|
|||||||
|
ipmitool-1.8.10.tar.gz
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
|||||||
|
ipmitool-1_8_10-2_fc9:HEAD:ipmitool-1.8.10-2.fc9.src.rpm:1224239134
|
23
ipmitool-1.8.10-ipmievd-init.patch
Normal file
23
ipmitool-1.8.10-ipmievd-init.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up ipmitool-1.8.10/contrib/ipmievd.init.redhat.ipmievd-init ipmitool-1.8.10/contrib/ipmievd.init.redhat
|
||||||
|
--- ipmitool-1.8.10/contrib/ipmievd.init.redhat.ipmievd-init 2006-03-20 00:05:48.000000000 +0100
|
||||||
|
+++ ipmitool-1.8.10/contrib/ipmievd.init.redhat 2008-10-14 13:46:35.000000000 +0200
|
||||||
|
@@ -5,7 +5,7 @@
|
||||||
|
# Based on example sysvinitfiles script
|
||||||
|
# Copyright (c) 2000 Red Hat Software, Inc.
|
||||||
|
#
|
||||||
|
-# chkconfig: 345 99 00
|
||||||
|
+# chkconfig: - 99 00
|
||||||
|
# description: ipmievd daemon to send events to syslog
|
||||||
|
# processname: ipmievd
|
||||||
|
# config: /etc/sysconfig/ipmievd
|
||||||
|
@@ -16,8 +16,8 @@
|
||||||
|
# Should-Start: $time
|
||||||
|
# Required-Stop: $syslog ipmi
|
||||||
|
# Should-Stop: $time
|
||||||
|
-# Default-Start: 3 4 5
|
||||||
|
-# Default-Stop: 0 1 2 6
|
||||||
|
+# Default-Start:
|
||||||
|
+# Default-Stop:
|
||||||
|
# Short-Description: ipmievd daemon to send events to syslog
|
||||||
|
# Description: Start ipmievd to read events from BMC and
|
||||||
|
# log them to syslog. Events correspond to hardware faults,
|
100
ipmitool.spec
Normal file
100
ipmitool.spec
Normal file
@ -0,0 +1,100 @@
|
|||||||
|
Name: ipmitool
|
||||||
|
Summary: Utility for IPMI control
|
||||||
|
Version: 1.8.10
|
||||||
|
Release: 2%{?dist}
|
||||||
|
License: BSD
|
||||||
|
Group: System Environment/Base
|
||||||
|
URL: http://ipmitool.sourceforge.net/
|
||||||
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
Source1: openipmi-ipmievd.sysconf
|
||||||
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
BuildRequires: openssl-devel readline-devel ncurses-devel
|
||||||
|
Requires(post): chkconfig
|
||||||
|
Requires(preun): chkconfig
|
||||||
|
Obsoletes: OpenIPMI-tools < 2.0.14-3
|
||||||
|
Provides: OpenIPMI-tools = 2.0.14-3
|
||||||
|
|
||||||
|
Patch1: ipmitool-1.8.10-ipmievd-init.patch
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package contains a utility for interfacing with devices that support
|
||||||
|
the Intelligent Platform Management Interface specification. IPMI is
|
||||||
|
an open standard for machine health, inventory, and remote power control.
|
||||||
|
|
||||||
|
This utility can communicate with IPMI-enabled devices through either a
|
||||||
|
kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
|
||||||
|
the IPMI specification. IPMIv2 adds support for encrypted LAN
|
||||||
|
communications and remote Serial-over-LAN functionality.
|
||||||
|
|
||||||
|
It provides commands for reading the Sensor Data Repository (SDR) and
|
||||||
|
displaying sensor values, displaying the contents of the System Event
|
||||||
|
Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
|
||||||
|
setting LAN configuration, and chassis power control.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1 -b .ipmievd-init
|
||||||
|
|
||||||
|
for f in AUTHORS ChangeLog; do
|
||||||
|
iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
|
||||||
|
mv ${f}.utf8 ${f}
|
||||||
|
done
|
||||||
|
|
||||||
|
%build
|
||||||
|
# --disable-dependency-tracking speeds up the build
|
||||||
|
# --enable-file-security adds some security checks
|
||||||
|
# --disable-intf-free disables FreeIPMI support - we don't want to depend on
|
||||||
|
# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
|
||||||
|
%configure --disable-dependency-tracking --enable-file-security --disable-intf-free
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make DESTDIR=%{buildroot} install
|
||||||
|
|
||||||
|
install -Dpm 755 contrib/ipmievd.init.redhat %{buildroot}%{_initrddir}/ipmievd
|
||||||
|
install -Dpm 644 %SOURCE1 %{buildroot}%{_sysconfdir}/sysconfig/ipmievd
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/chkconfig --add ipmievd
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 = 0 ]; then
|
||||||
|
service ipmievd stop >/dev/null 2>&1
|
||||||
|
/sbin/chkconfig --del ipmievd
|
||||||
|
fi
|
||||||
|
|
||||||
|
%postun
|
||||||
|
if [ "$1" -ge "1" ]; then
|
||||||
|
service ipmievd condrestart >/dev/null 2>&1 || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%config(noreplace) %{_sysconfdir}/sysconfig/ipmievd
|
||||||
|
%{_initrddir}/ipmievd
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_sbindir}/*
|
||||||
|
%{_mandir}/man*/*
|
||||||
|
%doc %{_datadir}/doc/ipmitool
|
||||||
|
%{_datadir}/ipmitool
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 14 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-2
|
||||||
|
- fix issues found during package review:
|
||||||
|
- clear Default-Start: line in the init script, the service should be
|
||||||
|
disabled by default
|
||||||
|
- added Obsoletes: OpenIPMI-tools
|
||||||
|
- compile with --disable-dependency-tracking to speed things up
|
||||||
|
- compile with --enable-file-security
|
||||||
|
- compile with --disable-intf-free, don't depend on FreeIPMI libraries
|
||||||
|
(FreeIPMI has its own ipmitool-like utility)
|
||||||
|
|
||||||
|
* Mon Oct 13 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-1
|
||||||
|
- package created, based on upstream .spec file
|
||||||
|
|
1
openipmi-ipmievd.sysconf
Normal file
1
openipmi-ipmievd.sysconf
Normal file
@ -0,0 +1 @@
|
|||||||
|
IPMIEVD_OPTIONS="sel"
|
Loading…
Reference in New Issue
Block a user