51 lines
2.0 KiB
Diff
51 lines
2.0 KiB
Diff
From f8b444c563094173c17c3327d72ce9b70da254af Mon Sep 17 00:00:00 2001
|
|
From: Alexander Bokovoy <abokovoy@redhat.com>
|
|
Date: Tue, 30 Jan 2024 19:58:05 +0200
|
|
Subject: [PATCH] ipa-kdb: support Samba 4.20 private libraries
|
|
|
|
Samba 4.20 will change name extension of the private libraries from
|
|
'samba4' to 'private-samba'. Detect private extension through configure
|
|
step and make sure to use the right library name in Makefile.
|
|
|
|
Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
|
|
---
|
|
daemons/ipa-kdb/Makefile.am | 2 +-
|
|
server.m4 | 8 ++++++++
|
|
2 files changed, 9 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/daemons/ipa-kdb/Makefile.am b/daemons/ipa-kdb/Makefile.am
|
|
index 777c6b4bd..ca1593bc8 100644
|
|
--- a/daemons/ipa-kdb/Makefile.am
|
|
+++ b/daemons/ipa-kdb/Makefile.am
|
|
@@ -116,7 +116,7 @@ ipa_kdb_tests_LDADD = \
|
|
$(top_builddir)/util/libutil.la \
|
|
-lkdb5 \
|
|
-lsss_idmap \
|
|
- -lsamba-security-samba4 \
|
|
+ -l$(SAMBA_SECURITY_LIBS)\
|
|
-lsamba-errors \
|
|
$(NULL)
|
|
|
|
diff --git a/server.m4 b/server.m4
|
|
index 2ee2cf519..f97ceddea 100644
|
|
--- a/server.m4
|
|
+++ b/server.m4
|
|
@@ -182,6 +182,14 @@ AC_CHECK_LIB([smbldap],[smbldap_set_bind_callback],
|
|
[AC_DEFINE([HAVE_SMBLDAP_SET_BIND_CALLBACK], [1], [struct smbldap_state is opaque])],
|
|
[AC_MSG_WARN([libsmbldap is not opaque, not using smbldap_set_bind_callback])],
|
|
[$SAMBA40EXTRA_LIBPATH])
|
|
+AC_CHECK_LIB([samba-security-private-samba],[dom_sid_string],
|
|
+ [SAMBA_SECURITY_LIBS=samba-security-private-samba],
|
|
+ [AC_CHECK_LIB([samba-security-samba4],[dom_sid_string],
|
|
+ [SAMBA_SECURITY_LIBS=samba-security-samba4],
|
|
+ [AC_MSG_ERROR([Cannot find private samba-security library])],
|
|
+ [$SAMBA40EXTRA_LIBPATH])],
|
|
+ [$SAMBA40EXTRA_LIBPATH])
|
|
+AC_SUBST(SAMBA_SECURITY_LIBS)
|
|
|
|
dnl ---------------------------------------------------------------------------
|
|
dnl Check for libunistring
|
|
--
|
|
2.43.0
|
|
|