89 lines
3.8 KiB
Diff
89 lines
3.8 KiB
Diff
From 2a98701ea1745394b717c3f4be4e0e376ab1d658 Mon Sep 17 00:00:00 2001
|
|
From: Tomas Babej <tomasbabej@gmail.com>
|
|
Date: Mon, 11 Nov 2013 13:02:40 +0100
|
|
Subject: [PATCH 1/9] platform: Add Fedora 19 platform file
|
|
|
|
Part of: https://fedorahosted.org/freeipa/ticket/3504
|
|
---
|
|
ipapython/platform/fedora19/__init__.py | 55 +++++++++++++++++++++++++++++++++
|
|
ipapython/setup.py.in | 1 +
|
|
3 files changed, 70 insertions(+), 1 deletion(-)
|
|
create mode 100644 ipapython/platform/fedora19/__init__.py
|
|
|
|
diff --git a/ipapython/platform/fedora19/__init__.py b/ipapython/platform/fedora19/__init__.py
|
|
new file mode 100644
|
|
index 0000000000000000000000000000000000000000..80356d65f4d07483000d57e16b193a857d0988ca
|
|
--- /dev/null
|
|
+++ b/ipapython/platform/fedora19/__init__.py
|
|
@@ -0,0 +1,55 @@
|
|
+# Author: Tomas Babej <tbabej@redhat.com>
|
|
+#
|
|
+# Copyright (C) 2013 Red Hat
|
|
+# see file 'COPYING' for use and warranty information
|
|
+#
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation, either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+#
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+#
|
|
+
|
|
+from ipapython.platform import fedora18, base
|
|
+
|
|
+# All what we allow exporting directly from this module
|
|
+
|
|
+# Everything else is made available through these symbols when they are
|
|
+# directly imported into ipapython.services:
|
|
+
|
|
+# authconfig -- class reference for platform-specific implementation of
|
|
+# authconfig(8)
|
|
+# service -- class reference for platform-specific implementation of a
|
|
+# PlatformService class
|
|
+# knownservices -- factory instance to access named services IPA cares about,
|
|
+# names are ipapython.services.wellknownservices
|
|
+# backup_and_replace_hostname -- platform-specific way to set hostname and
|
|
+# make it persistent over reboots
|
|
+# restore_network_configuration -- platform-specific way of restoring network
|
|
+# configuration (e.g. static hostname)
|
|
+# restore_context -- platform-sepcific way to restore security context, if
|
|
+# applicable
|
|
+# check_selinux_status -- platform-specific way to see if SELinux is enabled
|
|
+# and restorecon is installed.
|
|
+
|
|
+__all__ = ['authconfig', 'service', 'knownservices',
|
|
+ 'backup_and_replace_hostname', 'restore_context', 'check_selinux_status',
|
|
+ 'restore_network_configuration', 'timedate_services']
|
|
+
|
|
+# Just copy a referential list of timedate services
|
|
+timedate_services = list(base.timedate_services)
|
|
+
|
|
+backup_and_replace_hostname = fedora18.backup_and_replace_hostname
|
|
+restore_network_configuration = fedora18.restore_network_configuration
|
|
+authconfig = fedora18.authconfig
|
|
+service = fedora18.service
|
|
+knownservices = fedora18.knownservices
|
|
+restore_context = fedora18.restore_context
|
|
+check_selinux_status = fedora18.check_selinux_status
|
|
diff --git a/ipapython/setup.py.in b/ipapython/setup.py.in
|
|
index d3bbcaf1e46528d50731ca18a96a3384f6b49548..108c95d0ccb74e1cec5167759243f428f4ecf21a 100644
|
|
--- a/ipapython/setup.py.in
|
|
+++ b/ipapython/setup.py.in
|
|
@@ -70,6 +70,7 @@ def setup_package():
|
|
"ipapython.platform.base",
|
|
"ipapython.platform.fedora16",
|
|
"ipapython.platform.fedora18",
|
|
+ "ipapython.platform.fedora19",
|
|
"ipapython.platform.redhat" ],
|
|
)
|
|
finally:
|
|
--
|
|
1.8.5.3
|
|
|