6c2a5fa538
- Resolves: RHEL-49452 Include latest fixes in python3-ipatests packages - Resolves: RHEL-49433 Adjust "ipa config-mod --addattr ipaconfigstring=EnforceLDAPOTP" to allow for non OTP users in some cases - Resolves: RHEL-49432 ipa-migrate stage-mode is failing with error: Modifying a mapped attribute in a managed entry is not allowed - Resolves: RHEL-49413 ipa-migrate with -Z option fails with ValueError: option error - Resolves: RHEL-47157 ipa-migrate -V options fails to display version - Resolves: RHEL-47148 Pagure #9629: Syntax error uninstalling the selinux-luna subpackage - Resolves: RHEL-40892 ipa-server-install: token_password_file read in kra.install_check after calling hsm_validator in ca.install_check Signed-off-by: Florence Blanc-Renaud <flo@redhat.com>
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
From 1b278de4ab9c5e00fb48dc2de1ea31d9bdfc94bc Mon Sep 17 00:00:00 2001
|
|
From: Rob Crittenden <rcritten@redhat.com>
|
|
Date: Tue, 9 Jul 2024 14:35:25 -0400
|
|
Subject: [PATCH] Fix syntax error in the selinux-luna %postun script
|
|
|
|
It was missing a trailing fi.
|
|
|
|
This bad syntax was preventing cleanup of the
|
|
{free}ipa-selinux-luna SELinux module:
|
|
|
|
Running scriptlet: freeipa-selinux-luna-4.12.0.dev202402211727+git0ee 34/44
|
|
/var/tmp/rpm-tmp.qoCDFi: line 16: syntax error: unexpected end of file
|
|
warning: %postun(freeipa-selinux-luna-4.12.0.dev202402211727+git0eeecdcec-0.fc37.noarch) scriptlet failed, exit status
|
|
|
|
Fixes: https://pagure.io/freeipa/issue/9629
|
|
|
|
Signed-off-by: Rob Crittenden <rcritten@redhat.com>
|
|
Reviewed-By: Florence Blanc-Renaud <flo@redhat.com>
|
|
---
|
|
freeipa.spec.in | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/freeipa.spec.in b/freeipa.spec.in
|
|
index 1e1a0c04728972c6c53beb47dafb25d7898ab0ea..b3b19cf8881db97307836513ff2263dc4fe4ca03 100755
|
|
--- a/freeipa.spec.in
|
|
+++ b/freeipa.spec.in
|
|
@@ -1367,6 +1367,7 @@ fi
|
|
%postun selinux-luna
|
|
if [ $1 -eq 0 ]; then
|
|
%selinux_modules_uninstall -s %{selinuxtype} %{modulename}-luna
|
|
+fi
|
|
|
|
%posttrans selinux
|
|
%selinux_relabel_post -s %{selinuxtype}
|
|
--
|
|
2.45.2
|
|
|