ipa/freeipa-3.0.0.pre1-029-fixed-display-of-attributes_widget-in-ie9.patch
2012-08-06 18:17:49 +02:00

142 lines
4.3 KiB
Diff

From a14d243fcdd18bb7bd5409d1a8804bf06929824d Mon Sep 17 00:00:00 2001
From: Petr Vobornik <pvoborni@redhat.com>
Date: Fri, 13 Jul 2012 17:49:13 +0200
Subject: [PATCH 29/79] Fixed display of attributes_widget in IE9
Attributes widget is using overflow css rule in tbody element. IE9 doesn't handle it well.
To fix the issue, attributes widget was slightly modified and conditional css stylesheet was added just for fixing IE problems.
https://fedorahosted.org/freeipa/ticket/2822
---
install/ui/Makefile.am | 1 +
install/ui/aci.js | 6 +++++-
install/ui/ie.css | 23 +++++++++++++++++++++++
install/ui/index.html | 12 +++++++++---
install/ui/ipa.css | 7 ++++++-
5 files changed, 44 insertions(+), 5 deletions(-)
create mode 100644 install/ui/ie.css
diff --git a/install/ui/Makefile.am b/install/ui/Makefile.am
index 7eb9b04ceb73288efa169080b05994fb781b8c5e..73f746a39de974b0e94e81d562f88ea87767bcc9 100644
--- a/install/ui/Makefile.am
+++ b/install/ui/Makefile.am
@@ -30,6 +30,7 @@ app_DATA = \
host.js \
hostgroup.js \
index.html \
+ ie.css \
ipa.css \
ipa.js \
jquery-ui.css \
diff --git a/install/ui/aci.js b/install/ui/aci.js
index 953116c3f1e6f8450c0f8b308f1f2851b704e203..b2e5e19e54fe083093171d29fe894df321bb4c88 100644
--- a/install/ui/aci.js
+++ b/install/ui/aci.js
@@ -473,13 +473,17 @@ IPA.attributes_widget = function(spec) {
that.create = function(container) {
that.container = container;
+ var attr_container = $('<div/>', {
+ 'class': 'aci-attribute-table-container'
+ }).appendTo(container);
+
that.table = $('<table/>', {
id:id,
'class':'search-table aci-attribute-table scrollable'
}).
append('<thead/>').
append('<tbody/>').
- appendTo(container);
+ appendTo(attr_container);
var tr = $('<tr></tr>').appendTo($('thead', that.table));
diff --git a/install/ui/ie.css b/install/ui/ie.css
new file mode 100644
index 0000000000000000000000000000000000000000..00e573ba516358d247b725256f3098d80f1c1162
--- /dev/null
+++ b/install/ui/ie.css
@@ -0,0 +1,23 @@
+/* Authors:
+* Petr Vobornik <pvobornik@redhat.com>
+*
+* Copyright (C) 2012 Red Hat
+*
+* Styles for IE only
+*/
+
+.aci-attribute-table-container {
+ overflow: auto !important;
+ overflow-x: hidden !important;
+ width: 348px !important;
+}
+
+.aci-attribute-table {
+ float: left;
+ margin: 0;
+ width: 332px !important;
+}
+
+.aci-attribute-table tbody {
+ height: auto !important;
+}
\ No newline at end of file
diff --git a/install/ui/index.html b/install/ui/index.html
index cfa7a4c8136639e05f4345352a9bf4188ed2af89..24e8cac3668cd81fb064f6a8ad2b1685c847f5c8 100644
--- a/install/ui/index.html
+++ b/install/ui/index.html
@@ -4,6 +4,15 @@
<meta charset="utf-8">
<title>IPA: Identity Policy Audit</title>
+
+ <link rel="stylesheet" type="text/css" href="jquery-ui.css" />
+ <link rel="stylesheet" type="text/css" href="ipa.css" />
+ <!--ie only stylesheet -->
+ <!--[if IE]>
+ <link rel="stylesheet" type="text/css" href="ie.css" />
+ <![endif]-->
+ <link rel="icon" type="image/ico" href="favicon.ico">
+
<script type="text/javascript" src="json2.js"></script>
<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="jquery-ui.js"></script>
@@ -48,9 +57,6 @@
<script type="text/javascript" src="ext/extension.js"></script>
<script type="text/javascript" src="webui.js"></script>
- <link rel="stylesheet" type="text/css" href="jquery-ui.css" />
- <link rel="stylesheet" type="text/css" href="ipa.css" />
- <link rel="icon" type="image/ico" href="favicon.ico">
</head>
<body>
diff --git a/install/ui/ipa.css b/install/ui/ipa.css
index d6ad5806038f47919404615f224f5ed75a917563..a3b93078b64fc057ba81271abbe093717d766149 100644
--- a/install/ui/ipa.css
+++ b/install/ui/ipa.css
@@ -1082,13 +1082,18 @@ span.main-separator{
.aci-attribute-table tbody {
border-bottom: 1px solid #8a8a8a;
- height:10em;
+ height: 10em;
}
.aci-attribute-table .aci-attribute-column {
width: 200em; /* it will fit actual width */
}
+.aci-attribute-table-container {
+ height: 13.5em;
+ overflow: hidden;
+}
+
.entity-views{
list-style-type:none;
}
--
1.7.11.2