64 lines
2.7 KiB
Diff
64 lines
2.7 KiB
Diff
From 61b2f0a5d066a14e22033ff9815a712716f12a96 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Bokovoy <abokovoy@redhat.com>
|
|
Date: Wed, 18 Jul 2012 15:52:33 +0300
|
|
Subject: [PATCH 33/79] Follow change in samba4 beta4 for sid_check_is_domain
|
|
to sid_check_is_our_sam
|
|
|
|
With c43505b621725c9a754f0ee98318d451b093f2ed in samba git master
|
|
the function sid_check_is_domain() was renamed to sid_check_is_our_sam().
|
|
|
|
https://fedorahosted.org/freeipa/ticket/2929
|
|
---
|
|
daemons/ipa-sam/ipa_sam.c | 4 +++-
|
|
freeipa.spec.in | 5 ++++-
|
|
2 files changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/daemons/ipa-sam/ipa_sam.c b/daemons/ipa-sam/ipa_sam.c
|
|
index 86ed3fbd3e6d1894fd398c3c1c94d34c2b7ec273..ab4b116c5f2b3b8dae6e8309403afba5fdf86708 100644
|
|
--- a/daemons/ipa-sam/ipa_sam.c
|
|
+++ b/daemons/ipa-sam/ipa_sam.c
|
|
@@ -83,6 +83,8 @@ enum ndr_err_code ndr_pull_trustAuthInOutBlob(struct ndr_pull *ndr, int ndr_flag
|
|
bool fetch_ldap_pw(char **dn, char** pw); /* available in libpdb.so */
|
|
void nt_lm_owf_gen(const char *pwd, uint8_t nt_p16[16], uint8_t p16[16]); /* available in libcliauth.so */
|
|
bool sid_check_is_builtin(const struct dom_sid *sid); /* available in libpdb.so */
|
|
+/* available in libpdb.so, renamed from sid_check_is_domain() in c43505b621725c9a754f0ee98318d451b093f2ed */
|
|
+bool sid_check_is_our_sam(const struct dom_sid *sid);
|
|
void strlower_m(char *s); /* available in libutil_str.so */
|
|
char *talloc_asprintf_strupper_m(TALLOC_CTX *t, const char *fmt, ...); /* available in libutil_str.so */
|
|
void sid_copy(struct dom_sid *dst, const struct dom_sid *src); /* available in libsecurity.so */
|
|
@@ -300,7 +302,7 @@ static NTSTATUS ldapsam_lookup_rids(struct pdb_methods *methods,
|
|
}
|
|
|
|
if (!sid_check_is_builtin(domain_sid) &&
|
|
- !sid_check_is_domain(domain_sid)) {
|
|
+ !sid_check_is_our_sam(domain_sid)) {
|
|
result = NT_STATUS_INVALID_PARAMETER;
|
|
goto done;
|
|
}
|
|
diff --git a/freeipa.spec.in b/freeipa.spec.in
|
|
index 7106310915c8a4e52a009036f7152a38a4c5f18d..f4903c01354764f0c6b8755824512edbc1ff930b 100644
|
|
--- a/freeipa.spec.in
|
|
+++ b/freeipa.spec.in
|
|
@@ -31,7 +31,7 @@ BuildRequires: policycoreutils >= %{POLICYCOREUTILSVER}
|
|
%if 0%{?fedora} >= 16
|
|
BuildRequires: systemd-units
|
|
%endif
|
|
-BuildRequires: samba4-devel
|
|
+BuildRequires: samba4-devel >= 4.0.0-128
|
|
BuildRequires: samba4-python
|
|
%endif
|
|
BuildRequires: nspr-devel
|
|
@@ -743,6 +743,9 @@ fi
|
|
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/ca.crt
|
|
|
|
%changelog
|
|
+* Wed Jul 18 2012 Alexander Bokovoy <abokovoy@redhat.com> - 2.99.0-38
|
|
+- Require samba4-devel >= 4.0.0-128 due to passdb API change in beta4
|
|
+
|
|
* Fri Jun 29 2012 Rob Crittenden <rcritten@redhat.com> - 2.99.0-37
|
|
- Add Requires on openssl
|
|
- Set minimum tomcat6 to 6.0.35-4 in F-18
|
|
--
|
|
1.7.11.2
|
|
|