import ipa-4.9.0-0.5.rc3.module+el8.4.0+9124+ced20601

This commit is contained in:
CentOS Sources 2020-12-16 16:47:12 +00:00 committed by Andrew Lukoshko
commit f263b12bd0
7 changed files with 10683 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/freeipa-4.9.0rc3.tar.gz

1
.ipa.metadata Normal file
View File

@ -0,0 +1 @@
71c0691597296f321e093d9acb36677c26593a1f SOURCES/freeipa-4.9.0rc3.tar.gz

File diff suppressed because one or more lines are too long

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,134 @@
From 2f8e87ce9ccaab51b32a395c6cf6c764434ed0e2 Mon Sep 17 00:00:00 2001
From: Thomas Woerner <twoerner@redhat.com>
Date: Thu, 11 Jun 2020 10:40:57 +0200
Subject: [PATCH] Revert "WebUI: use python3-rjsmin to minify JavaScript files"
This reverts commit d986e844bbd37ccc7a532175631a55acd315cda3.
---
.lgtm.yml | 4 ++--
freeipa.spec.in | 2 +-
install/ui/build/freeipa/Makefile.am | 2 +-
install/ui/src/webui.profile.js | 4 ++--
install/ui/util/build/README | 4 ++--
install/ui/util/compile.sh | 8 ++++----
6 files changed, 12 insertions(+), 12 deletions(-)
#diff --git a/.lgtm.yml b/.lgtm.yml
#index b3898116e..e63615918 100644
#--- a/.lgtm.yml
#+++ b/.lgtm.yml
#@@ -39,7 +39,7 @@ extraction:
# - python3-setuptools
# - python3-wheel
# - nodejs
#- - python3-rjsmin
#+ - uglifyjs
# - systemd
# - 389-ds-base-dev
# - libssl-dev
#@@ -79,7 +79,7 @@ extraction:
# - python3-setuptools
# - python3-wheel
# - nodejs
#- - python3-rjsmin
#+ - uglifyjs
# - systemd
# - 389-ds-base-dev
# - libssl-dev
#diff --git a/freeipa.spec.in b/freeipa.spec.in
#index b6eb79593..a4682497a 100755
#--- a/freeipa.spec.in
#+++ b/freeipa.spec.in
#@@ -191,7 +191,7 @@ BuildRequires: libsss_idmap-devel
# BuildRequires: libsss_certmap-devel
# BuildRequires: libsss_nss_idmap-devel >= %{sssd_version}
# BuildRequires: nodejs(abi)
#-BuildRequires: python3-rjsmin
#+BuildRequires: uglify-js
# BuildRequires: libverto-devel
# BuildRequires: libunistring-devel
# # 0.13.0: https://bugzilla.redhat.com/show_bug.cgi?id=1584773
diff --git a/install/ui/build/freeipa/Makefile.am b/install/ui/build/freeipa/Makefile.am
index f4d97819e..05e82f4da 100644
--- a/install/ui/build/freeipa/Makefile.am
+++ b/install/ui/build/freeipa/Makefile.am
@@ -18,6 +18,6 @@ widgets := $(wildcard ../../src/freeipa/widgets/*.js)
nav := $(wildcard ../../src/freeipa/navigation/*.js)
app.js: $(core) $(base) $(widgets) $(nav)
- PYTHON=$(PYTHON) $(srcdir)/../../util/make-ui.sh
+ $(srcdir)/../../util/make-ui.sh
core.js: app.js
diff --git a/install/ui/src/webui.profile.js b/install/ui/src/webui.profile.js
index 2d4d691dc..1d7a6cc84 100644
--- a/install/ui/src/webui.profile.js
+++ b/install/ui/src/webui.profile.js
@@ -9,7 +9,7 @@ var profile = (function(){
releaseName: "lib",
action: "release",
- // optimization done separately by python3-rjsmin
+ // optimization done separately by uglify.js
layerOptimize: false,
optimize: false,
cssOptimize: false,
@@ -123,4 +123,4 @@ var profile = (function(){
}
}
};
-})();
+})();
\ No newline at end of file
diff --git a/install/ui/util/build/README b/install/ui/util/build/README
index 2c4e0ecac..0772532d4 100644
--- a/install/ui/util/build/README
+++ b/install/ui/util/build/README
@@ -1,5 +1,5 @@
build.js is builded dojo builder, with applied patches from 'patches' folder, by
-itself and compiled using python3-rjsmin
+itself and compiled using uglify.js
_base/configRhino.js is unmodifed file from dojo/dojo. Required for a build to work.
@@ -9,4 +9,4 @@ Available via Academic Free License >= 2.1 OR the modified BSD license.
see: http://dojotoolkit.org/license for details
= License =
-Full Dojo license is in LICENSE file.
+Full Dojo license is in LICENSE file.
\ No newline at end of file
#diff --git a/install/ui/util/compile.sh b/install/ui/util/compile.sh
#index 1516b815f..d14f90ab0 100755
#--- a/install/ui/util/compile.sh
#+++ b/install/ui/util/compile.sh
#@@ -26,14 +26,14 @@ RDIR=$DIR/../release
# usage() {
# cat <<-__EOF__;
# NAME
#- compile.sh - Compiles layer file of Dojo build using Python rjsmin.
#+ compile.sh - Compiles layer file of Dojo build using uglify.js.
# Deletes all other files.
#
# SYNOPSIS
# path/to/compile.sh [--help] --release RELEASE --layer NAME/NAME
#
# DESCRIPTION
#- Compiles layer file of Dojo build output using Python rjsmin.
#+ Compiles layer file of Dojo build output using uglify.js.
# Deletes all other files.
#
# OPTIONS
#@@ -105,7 +105,7 @@ if [[ ! $OUTPUT_FILE ]] ; then
# OUTPUT_FILE=$RDIR/$RELEASE/$LAYER.js
# fi
#
#-# compile using python rjsmin
#+# compile using uglifyjs
# echo "Minimizing: $RDIR/$RELEASE/$LAYER.js"
# echo "Target file: $OUTPUT_FILE"
#-${PYTHON:-python3} -m rjsmin < $RDIR/$RELEASE/$LAYER.js > $OUTPUT_FILE
#+uglifyjs $RDIR/$RELEASE/$LAYER.js > $OUTPUT_FILE
#--
#2.26.2

View File

@ -0,0 +1,16 @@
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEhAodHH8+xLL+UwQ1RxniuKu/YhoFAl/SSecACgkQRxniuKu/
YhrlPQ//a+dJrg29AsJIYlLbFqcR3IEtCtt7H2Mr6TJ2xWWg1oLTJhQslrf82YeN
WznHHj09cHV1Ga0kGJmg+KhudpC7OFviUvxrz69+N3j6/+39OeWvOAEUQgCphZ7G
/UnBTxW2Fhf8zklFf+vT7phcE0YemY4GNjyYJqni4/9uua0Q8pJJQTy30Yw6UrDL
pXHjTVXgQv7Ryf/LWEMOaHKUGiZCsL59Chrp5uaefzIat8pHG2xnf1Ah6tUwG4Fs
rf4QfgUW7Q2nwrAmZKzPvp3wQVFZZ5CiklSO9hfRwZ9De1wIdlUD66cmcE2TeJla
7DpsfQPSCrghwmvPYpeJcwG2DrPoz3i1j14BQ//LqhAmsvJy5iFg3+tF1YcNYqnP
neGK3/6QeUvKKe5H7VGMAA4N4YDMri8a8/QKgqG1lWf+X7x8d2lwlib2JNpNnN7N
TlVTRWhKRvQyBn23uSdcLXdaVdU4Z++7yhHcveyGGDVtElFWeSV83d3ekVZ4rsoq
stv7S2Ay8D6pH7fVd2aXA9i+r12BCF3Lmrikc+g+aAuJV5K3GwoCBwgWLCs0WXru
Q67j99HZ4R+A4cNMZ8+VAUIzZT7S62aHX75lGgw/e3CvGoiIEosa01YdXiP+DT6V
JFH5PnuKStu8LqrFpICgHFrFKQAHopKO9JVINGHwQB426xycwaM=
=0OcN
-----END PGP SIGNATURE-----

4933
SPECS/ipa.spec Normal file

File diff suppressed because it is too large Load Diff