- Update to upstream GA release
- Automatically apply updates when the package is upgraded
This commit is contained in:
parent
2af185004b
commit
f2186254fd
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/freeipa-2.0.0.pre2.tar.gz
|
/freeipa-2.0.0.pre2.tar.gz
|
||||||
/freeipa-2.0.0.rc1.tar.gz
|
/freeipa-2.0.0.rc1.tar.gz
|
||||||
/freeipa-2.0.0.rc2.tar.gz
|
/freeipa-2.0.0.rc2.tar.gz
|
||||||
|
/freeipa-2.0.0.tar.gz
|
||||||
|
@ -1,60 +0,0 @@
|
|||||||
From 8b8c7367ce965aeaa3f3051cb1da16ad9ee7310f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rob Crittenden <rcritten@redhat.com>
|
|
||||||
Date: Thu, 24 Feb 2011 14:45:46 -0500
|
|
||||||
Subject: [PATCH] Set SuiteSpotGroup when setting up our 389-ds instances.
|
|
||||||
|
|
||||||
The group is now required because 389-ds has tightened the permissions
|
|
||||||
on /var/run/dirsrv. We use the same group for both our LDAP instances
|
|
||||||
and /var/run/dirsrv ends up as root:dirsrv mode 0770.
|
|
||||||
|
|
||||||
ticket 1010
|
|
||||||
---
|
|
||||||
ipaserver/install/cainstance.py | 4 +++-
|
|
||||||
ipaserver/install/dsinstance.py | 2 ++
|
|
||||||
2 files changed, 5 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ipaserver/install/cainstance.py b/ipaserver/install/cainstance.py
|
|
||||||
index 7cdd28d..74d78dc 100644
|
|
||||||
--- a/ipaserver/install/cainstance.py
|
|
||||||
+++ b/ipaserver/install/cainstance.py
|
|
||||||
@@ -72,6 +72,7 @@ INF_TEMPLATE = """
|
|
||||||
[General]
|
|
||||||
FullMachineName= $FQHN
|
|
||||||
SuiteSpotUserID= $USER
|
|
||||||
+SuiteSpotGroup= $GROUP
|
|
||||||
ServerRoot= $SERVER_ROOT
|
|
||||||
[slapd]
|
|
||||||
ServerPort= $DSPORT
|
|
||||||
@@ -255,7 +256,8 @@ class CADSInstance(service.Service):
|
|
||||||
PASSWORD=self.dm_password, SUFFIX=self.suffix.lower(),
|
|
||||||
REALM=self.realm_name, USER=PKI_DS_USER,
|
|
||||||
SERVER_ROOT=server_root, DOMAIN=self.domain,
|
|
||||||
- TIME=int(time.time()), DSPORT=self.ds_port)
|
|
||||||
+ TIME=int(time.time()), DSPORT=self.ds_port,
|
|
||||||
+ GROUP=dsinstance.DS_GROUP)
|
|
||||||
|
|
||||||
def __create_ds_user(self):
|
|
||||||
user_exists = True
|
|
||||||
diff --git a/ipaserver/install/dsinstance.py b/ipaserver/install/dsinstance.py
|
|
||||||
index bf631a6..2bb083f 100644
|
|
||||||
--- a/ipaserver/install/dsinstance.py
|
|
||||||
+++ b/ipaserver/install/dsinstance.py
|
|
||||||
@@ -149,6 +149,7 @@ INF_TEMPLATE = """
|
|
||||||
[General]
|
|
||||||
FullMachineName= $FQHN
|
|
||||||
SuiteSpotUserID= $USER
|
|
||||||
+SuiteSpotGroup= $GROUP
|
|
||||||
ServerRoot= $SERVER_ROOT
|
|
||||||
[slapd]
|
|
||||||
ServerPort= 389
|
|
||||||
@@ -319,6 +320,7 @@ class DsInstance(service.Service):
|
|
||||||
TIME=int(time.time()), IDSTART=self.idstart,
|
|
||||||
IDMAX=self.idmax, HOST=self.fqdn,
|
|
||||||
ESCAPED_SUFFIX= escape_dn_chars(self.suffix.lower()),
|
|
||||||
+ GROUP=DS_GROUP,
|
|
||||||
)
|
|
||||||
|
|
||||||
def __create_ds_user(self):
|
|
||||||
--
|
|
||||||
1.7.3.4
|
|
||||||
|
|
20
freeipa.spec
20
freeipa.spec
@ -12,20 +12,16 @@ distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
|||||||
%global POLICYCOREUTILSVER 1.33.12-1
|
%global POLICYCOREUTILSVER 1.33.12-1
|
||||||
%global gettext_domain ipa
|
%global gettext_domain ipa
|
||||||
|
|
||||||
%global git_commit .rc2
|
|
||||||
|
|
||||||
Name: freeipa
|
Name: freeipa
|
||||||
Version: 2.0.0
|
Version: 2.0.0
|
||||||
Release: 0.4.rc2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Identity, Policy and Audit system
|
Summary: The Identity, Policy and Audit system
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.freeipa.org/
|
URL: http://www.freeipa.org/
|
||||||
# This source is temporary until the final release of FreeIPA
|
Source0: http://www.freeipa.org/downloads/src/freeipa-%{version}.tar.gz
|
||||||
Source0: freeipa-%{version}%{git_commit}.tar.gz
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Patch1: freeipa-rcrit-743-dsgroup.patch
|
|
||||||
|
|
||||||
%if ! %{ONLY_CLIENT}
|
%if ! %{ONLY_CLIENT}
|
||||||
BuildRequires: 389-ds-base-devel >= 1.2.8
|
BuildRequires: 389-ds-base-devel >= 1.2.8
|
||||||
@ -197,8 +193,7 @@ package.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -n freeipa-%{version}%{git_commit} -q
|
%setup -n freeipa-%{version} -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$CFLAGS %{optflags}"
|
export CFLAGS="$CFLAGS %{optflags}"
|
||||||
@ -284,7 +279,10 @@ if [ $1 = 1 ]; then
|
|||||||
/sbin/chkconfig --add ipa
|
/sbin/chkconfig --add ipa
|
||||||
/sbin/chkconfig --add ipa_kpasswd
|
/sbin/chkconfig --add ipa_kpasswd
|
||||||
fi
|
fi
|
||||||
/usr/sbin/ipa-upgradeconfig || :
|
if [ $1 -gt 1 ] ; then
|
||||||
|
/usr/sbin/ipa-upgradeconfig || :
|
||||||
|
/usr/sbin/ipa-ldap-updater --upgrade >/dev/null 2>&1 || :
|
||||||
|
fi
|
||||||
|
|
||||||
%preun server
|
%preun server
|
||||||
if [ $1 = 0 ]; then
|
if [ $1 = 0 ]; then
|
||||||
@ -487,6 +485,10 @@ fi
|
|||||||
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/default.conf
|
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/default.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 24 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-1
|
||||||
|
- Update to upstream GA release
|
||||||
|
- Automatically apply updates when the package is upgraded
|
||||||
|
|
||||||
* Fri Feb 25 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.4.rc2
|
* Fri Feb 25 2011 Rob Crittenden <rcritten@redhat.com> - 2.0.0-0.4.rc2
|
||||||
- Update to upstream freeipa-2.0.0.rc2
|
- Update to upstream freeipa-2.0.0.rc2
|
||||||
- Set minimum version of python-nss to 0.11 to make sure IPv6 support is in
|
- Set minimum version of python-nss to 0.11 to make sure IPv6 support is in
|
||||||
|
Loading…
Reference in New Issue
Block a user