Fix armv7 build failure, external CA install
This commit is contained in:
parent
7ccb103e8e
commit
c8a68dfb66
@ -0,0 +1,52 @@
|
||||
>From 1a42a07cfa02753053298c75d3a76cb1cb3bf839 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Cholasta <jcholast@redhat.com>
|
||||
Date: Wed, 22 Oct 2014 11:18:35 +0200
|
||||
Subject: [PATCH] Do not check if port 8443 is available in step 2 of external
|
||||
CA install
|
||||
|
||||
The port is never available in step 2 of external CA install, as Dogtag is
|
||||
already running.
|
||||
|
||||
https://fedorahosted.org/freeipa/ticket/4660
|
||||
---
|
||||
install/tools/ipa-ca-install | 3 ++-
|
||||
install/tools/ipa-server-install | 9 +++++----
|
||||
2 files changed, 7 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/install/tools/ipa-ca-install b/install/tools/ipa-ca-install
|
||||
index cb072e6..1bda22d 100755
|
||||
--- a/install/tools/ipa-ca-install
|
||||
+++ b/install/tools/ipa-ca-install
|
||||
@@ -301,7 +301,8 @@ def install_master(safe_options, options):
|
||||
domain_name = api.env.domain
|
||||
host_name = api.env.host
|
||||
|
||||
- check_ca()
|
||||
+ if external != 2:
|
||||
+ check_ca()
|
||||
|
||||
dirname = dsinstance.config_dirname(
|
||||
dsinstance.realm_to_serverid(realm_name))
|
||||
diff --git a/install/tools/ipa-server-install b/install/tools/ipa-server-install
|
||||
index 0394314..67dd21f 100755
|
||||
--- a/install/tools/ipa-server-install
|
||||
+++ b/install/tools/ipa-server-install
|
||||
@@ -869,10 +869,11 @@ def main():
|
||||
# Make sure the 389-ds ports are available
|
||||
check_dirsrv(options.unattended)
|
||||
|
||||
- if setup_ca:
|
||||
- if not cainstance.check_port():
|
||||
- print "IPA requires port 8443 for PKI but it is currently in use."
|
||||
- sys.exit("Aborting installation")
|
||||
+ if setup_ca:
|
||||
+ if not cainstance.check_port():
|
||||
+ print ("IPA requires port 8443 for PKI but it is currently in "
|
||||
+ "use.")
|
||||
+ sys.exit("Aborting installation")
|
||||
|
||||
if options.conf_ntp:
|
||||
try:
|
||||
--
|
||||
1.9.3
|
||||
|
11
freeipa.spec
11
freeipa.spec
@ -25,7 +25,7 @@
|
||||
|
||||
Name: freeipa
|
||||
Version: %{VERSION}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Identity, Policy and Audit system
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -34,6 +34,8 @@ URL: http://www.freeipa.org/
|
||||
Source0: http://www.freeipa.org/downloads/src/freeipa-%{VERSION}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch0001: 0001-Do-not-check-if-port-8443-is-available-in-step-2-of.patch
|
||||
|
||||
%if ! %{ONLY_CLIENT}
|
||||
BuildRequires: 389-ds-base-devel >= 1.3.3.5
|
||||
BuildRequires: svrcore-devel
|
||||
@ -345,10 +347,9 @@ done
|
||||
# Fedora spec file only: END
|
||||
|
||||
%build
|
||||
%ifarch ppc %{power64} s390 s390x aarch64
|
||||
# UI compilation segfaulted on some arches when the stack was lower (#1040576)
|
||||
export JAVA_STACK_SIZE="8m"
|
||||
%endif
|
||||
|
||||
export CFLAGS="%{optflags} $CFLAGS"
|
||||
export LDFLAGS="%{__global_ldflags} $LDFLAGS"
|
||||
export SUPPORTED_PLATFORM=%{platform_module}
|
||||
@ -917,6 +918,10 @@ fi
|
||||
%endif # ONLY_CLIENT
|
||||
|
||||
%changelog
|
||||
* Wed Oct 22 2014 Petr Vobornik <pvoborni@redhat.com> - 4.1.0-2
|
||||
- fix armv7hl stack oversize build failure
|
||||
- fix https://fedorahosted.org/freeipa/ticket/4660
|
||||
|
||||
* Tue Oct 21 2014 Petr Vobornik <pvoborni@redhat.com> - 4.1.0-1
|
||||
- Update to upstream 4.1.0 - see http://www.freeipa.org/page/Releases/4.1.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user