Update to 2.1.0
This commit is contained in:
parent
e3b0a5690f
commit
92a3878415
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/freeipa-2.0.0.rc2.tar.gz
|
||||
/freeipa-2.0.0.tar.gz
|
||||
/freeipa-2.0.1.tar.gz
|
||||
/freeipa-2.1.0.tar.gz
|
||||
|
@ -1,69 +0,0 @@
|
||||
From 76e279ce07c660a9a524b9cbdb21f4e7fd33862e Mon Sep 17 00:00:00 2001
|
||||
From: Simo Sorce <ssorce@redhat.com>
|
||||
Date: Wed, 4 May 2011 10:21:27 -0400
|
||||
Subject: [PATCH] install-scripts: avoid using --list with chkconfig
|
||||
|
||||
This option does not behave properly in F15 as chkconfig does not list services
|
||||
moved to use systemd service files.
|
||||
|
||||
Plus there are more direct ways than parsing its output, which are more
|
||||
reliable.
|
||||
|
||||
Also just testing for the availability of the service calling 'chkconfig name'
|
||||
is enough.
|
||||
---
|
||||
ipa-client/ipa-install/ipa-client-install | 6 ------
|
||||
ipaserver/install/service.py | 20 ++------------------
|
||||
2 files changed, 2 insertions(+), 24 deletions(-)
|
||||
|
||||
diff --git a/ipa-client/ipa-install/ipa-client-install b/ipa-client/ipa-install/ipa-client-install
|
||||
index 5533b9ab2ea35c0d216f9cd8339570da19c66623..6265a7c2e943338103d36962a5a5d0b810c7e3d7 100755
|
||||
--- a/ipa-client/ipa-install/ipa-client-install
|
||||
+++ b/ipa-client/ipa-install/ipa-client-install
|
||||
@@ -169,12 +169,6 @@ def chkconfig(name, status):
|
||||
|
||||
chkconfig returns 1 if the service is unknown, 0 otherwise
|
||||
"""
|
||||
- (sout, serr, returncode) = run(['/sbin/chkconfig', name, '--list'], raiseonerr=False)
|
||||
-
|
||||
- # If the service isn't installed return with no error
|
||||
- if returncode == 1:
|
||||
- return
|
||||
-
|
||||
args = ['/sbin/chkconfig', name, status]
|
||||
(sout, serr, returncode) = run(args, raiseonerr=False)
|
||||
|
||||
diff --git a/ipaserver/install/service.py b/ipaserver/install/service.py
|
||||
index 1ebd96d7b48a8d8d1df41950da517e18383f2d9c..0d31927009df084049c36a1e3c9d0b7d3c6511da 100644
|
||||
--- a/ipaserver/install/service.py
|
||||
+++ b/ipaserver/install/service.py
|
||||
@@ -73,24 +73,8 @@ def chkconfig_del(service_name):
|
||||
ipautil.run(["/sbin/chkconfig", "--del", service_name])
|
||||
|
||||
def is_enabled(service_name):
|
||||
- (stdout, stderr, returncode) = ipautil.run(["/sbin/chkconfig", "--list", service_name])
|
||||
-
|
||||
- runlevels = {}
|
||||
- for runlevel in range(0, 7):
|
||||
- runlevels[runlevel] = False
|
||||
-
|
||||
- for line in stdout.split("\n"):
|
||||
- parts = line.split()
|
||||
- if parts[0] == service_name:
|
||||
- for s in parts[1:]:
|
||||
- (runlevel, status) = s.split(":")[0:2]
|
||||
- try:
|
||||
- runlevels[int(runlevel)] = status == "on"
|
||||
- except ValueError:
|
||||
- pass
|
||||
- break
|
||||
-
|
||||
- return (runlevels[3] and runlevels[4] and runlevels[5])
|
||||
+ (stdout, stderr, returncode) = ipautil.run(["/sbin/chkconfig", service_name], raiseonerr=False)
|
||||
+ return (returncode == 0)
|
||||
|
||||
def print_msg(message, output_fd=sys.stdout):
|
||||
logging.debug(message)
|
||||
--
|
||||
1.7.4.4
|
||||
|
61
freeipa.spec
61
freeipa.spec
@ -13,8 +13,8 @@ distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
||||
%global gettext_domain ipa
|
||||
|
||||
Name: freeipa
|
||||
Version: 2.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: The Identity, Policy and Audit system
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -23,10 +23,9 @@ URL: http://www.freeipa.org/
|
||||
Source0: http://www.freeipa.org/downloads/src/freeipa-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch0: 0001-install-scripts-avoid-using-list-with-chkconfig.patch
|
||||
|
||||
%if ! %{ONLY_CLIENT}
|
||||
BuildRequires: 389-ds-base-devel >= 1.2.8
|
||||
BuildRequires: 389-ds-base-devel >= 1.2.9
|
||||
BuildRequires: svrcore-devel
|
||||
BuildRequires: /usr/share/selinux/devel/Makefile
|
||||
BuildRequires: policycoreutils >= %{POLICYCOREUTILSVER}
|
||||
@ -38,8 +37,8 @@ BuildRequires: openldap-devel
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: krb5-workstation
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: xmlrpc-c-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libcurl-devel >= 7.21.3-9
|
||||
BuildRequires: xmlrpc-c-devel >= 1.25.4
|
||||
BuildRequires: popt-devel
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -52,9 +51,12 @@ BuildRequires: python-ldap
|
||||
BuildRequires: python-setuptools
|
||||
BuildRequires: python-krbV
|
||||
BuildRequires: python-nss
|
||||
BuildRequires: python-netaddr
|
||||
BuildRequires: python-netaddr >= 0.7.5-3
|
||||
BuildRequires: python-kerberos
|
||||
BuildRequires: python-rhsm
|
||||
BuildRequires: pyOpenSSL
|
||||
BuildRequires: pylint
|
||||
BuildRequires: libipa_hbac-python
|
||||
|
||||
%description
|
||||
IPA is an integrated solution to provide centrally managed Identity (machine,
|
||||
@ -70,14 +72,14 @@ Requires: %{name}-python = %{version}-%{release}
|
||||
Requires: %{name}-client = %{version}-%{release}
|
||||
Requires: %{name}-admintools = %{version}-%{release}
|
||||
Requires(post): %{name}-server-selinux = %{version}-%{release}
|
||||
Requires(pre): 389-ds-base >= 1.2.8.0-1
|
||||
Requires(pre): 389-ds-base >= 1.2.9.6-1
|
||||
Requires: openldap-clients
|
||||
Requires: nss
|
||||
Requires: nss-tools
|
||||
Requires: krb5-server
|
||||
Requires: krb5-server-ldap
|
||||
Requires: krb5-pkinit-openssl
|
||||
Requires: cyrus-sasl-gssapi
|
||||
Requires: cyrus-sasl-gssapi%{?_isa}
|
||||
Requires: ntp
|
||||
Requires: httpd
|
||||
Requires: mod_wsgi
|
||||
@ -90,8 +92,8 @@ Requires: python-pyasn1 >= 0.0.9a
|
||||
Requires: selinux-policy >= 3.9.16-18
|
||||
Requires(post): selinux-policy-base
|
||||
Requires: slapi-nis >= 0.21
|
||||
Requires: pki-ca >= 9.0.7
|
||||
Requires: pki-silent >= 9.0.7
|
||||
Requires: pki-ca >= 9.0.11
|
||||
Requires: pki-silent >= 9.0.11
|
||||
Requires: dogtag-pki-common-theme
|
||||
Requires: dogtag-pki-ca-theme
|
||||
Requires(preun): python initscripts chkconfig
|
||||
@ -130,13 +132,14 @@ Summary: IPA authentication for use on clients
|
||||
Group: System Environment/Base
|
||||
Requires: %{name}-python = %{version}-%{release}
|
||||
Requires: python-ldap
|
||||
Requires: cyrus-sasl-gssapi
|
||||
Requires: cyrus-sasl-gssapi%{?_isa}
|
||||
Requires: ntp
|
||||
Requires: krb5-workstation
|
||||
Requires: authconfig
|
||||
Requires: pam_krb5
|
||||
Requires: wget
|
||||
Requires: xmlrpc-c
|
||||
Requires: libcurl >= 7.21.3-9
|
||||
Requires: xmlrpc-c >= 1.25.4
|
||||
Requires: sssd >= 1.5.1
|
||||
Requires: certmonger >= 0.26
|
||||
Requires: nss-tools
|
||||
@ -179,10 +182,12 @@ Requires: python-kerberos >= 1.1-3
|
||||
%endif
|
||||
Requires: authconfig
|
||||
Requires: gnupg
|
||||
Requires: iproute
|
||||
Requires: pyOpenSSL
|
||||
Requires: python-nss >= 0.11
|
||||
Requires: python-lxml
|
||||
Requires: python-netaddr
|
||||
Requires: python-netaddr >= 0.7.5-3
|
||||
Requires: libipa_hbac-python
|
||||
|
||||
Obsoletes: ipa-python >= 1.0
|
||||
|
||||
@ -197,8 +202,6 @@ package.
|
||||
%prep
|
||||
%setup -n freeipa-%{version} -q
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export CFLAGS="$CFLAGS %{optflags}"
|
||||
export CPPFLAGS="$CPPFLAGS %{optflags}"
|
||||
@ -210,12 +213,12 @@ cd install; ../autogen.sh --prefix=%{_usr} --sysconfdir=%{_sysconfdir} --localst
|
||||
%endif
|
||||
|
||||
%if ! %{ONLY_CLIENT}
|
||||
make IPA_VERSION_IS_GIT_SNAPSHOT=no %{?_smp_mflags} version-update all
|
||||
make IPA_VERSION_IS_GIT_SNAPSHOT=no %{?_smp_mflags} all
|
||||
cd selinux
|
||||
# This isn't multi-process make capable yet
|
||||
make all
|
||||
%else
|
||||
make IPA_VERSION_IS_GIT_SNAPSHOT=no %{?_smp_mflags} version-update client
|
||||
make IPA_VERSION_IS_GIT_SNAPSHOT=no %{?_smp_mflags} client
|
||||
%endif
|
||||
|
||||
%install
|
||||
@ -253,6 +256,8 @@ ln -s ../../../..%{_sysconfdir}/ipa/html/unauthorized.html \
|
||||
%{buildroot}%{_usr}/share/ipa/html/unauthorized.html
|
||||
ln -s ../../../..%{_sysconfdir}/ipa/html/browserconfig.html \
|
||||
%{buildroot}%{_usr}/share/ipa/html/browserconfig.html
|
||||
ln -s ../../../..%{_sysconfdir}/ipa/html/hbac-deny-remove.html \
|
||||
%{buildroot}%{_usr}/share/ipa/html/hbac-deny-remove.html
|
||||
ln -s ../../../..%{_sysconfdir}/ipa/html/ipa_error.css \
|
||||
%{buildroot}%{_usr}/share/ipa/html/ipa_error.css
|
||||
|
||||
@ -352,11 +357,14 @@ fi
|
||||
%files server
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README Contributors.txt
|
||||
%{_sbindir}/ipa-ca-install
|
||||
%{_sbindir}/ipa-dns-install
|
||||
%{_sbindir}/ipa-server-install
|
||||
%{_sbindir}/ipa-replica-conncheck
|
||||
%{_sbindir}/ipa-replica-install
|
||||
%{_sbindir}/ipa-replica-prepare
|
||||
%{_sbindir}/ipa-replica-manage
|
||||
%{_sbindir}/ipa-csreplica-manage
|
||||
%{_sbindir}/ipa-server-certinstall
|
||||
%{_sbindir}/ipa-ldap-updater
|
||||
%{_sbindir}/ipa-compat-manage
|
||||
@ -380,6 +388,7 @@ fi
|
||||
%{_usr}/share/ipa/html/ssbrowser.html
|
||||
%{_usr}/share/ipa/html/browserconfig.html
|
||||
%{_usr}/share/ipa/html/unauthorized.html
|
||||
%{_usr}/share/ipa/html/hbac-deny-remove.html
|
||||
%{_usr}/share/ipa/html/ipa_error.css
|
||||
%dir %{_usr}/share/ipa/migration
|
||||
%{_usr}/share/ipa/migration/error.html
|
||||
@ -391,18 +400,20 @@ fi
|
||||
%{_usr}/share/ipa/ui/index.html
|
||||
%{_usr}/share/ipa/ui/*.png
|
||||
%{_usr}/share/ipa/ui/*.gif
|
||||
%{_usr}/share/ipa/ui/*.ico
|
||||
%{_usr}/share/ipa/ui/*.css
|
||||
%{_usr}/share/ipa/ui/*.js
|
||||
%{_usr}/share/ipa/ui/*.otf
|
||||
%dir %{_usr}/share/ipa/ui/layouts
|
||||
%dir %{_usr}/share/ipa/ui/layouts/default
|
||||
%{_usr}/share/ipa/ui/layouts/default/*.html
|
||||
%{_usr}/share/ipa/ui/*.eot
|
||||
%{_usr}/share/ipa/ui/*.svg
|
||||
%{_usr}/share/ipa/ui/*.ttf
|
||||
%{_usr}/share/ipa/ui/*.woff
|
||||
%dir %{_sysconfdir}/ipa
|
||||
%dir %{_sysconfdir}/ipa/html
|
||||
%config(noreplace) %{_sysconfdir}/ipa/html/ssbrowser.html
|
||||
%config(noreplace) %{_sysconfdir}/ipa/html/ipa_error.css
|
||||
%config(noreplace) %{_sysconfdir}/ipa/html/unauthorized.html
|
||||
%config(noreplace) %{_sysconfdir}/ipa/html/browserconfig.html
|
||||
%config(noreplace) %{_sysconfdir}/ipa/html/hbac-deny-remove.html
|
||||
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/httpd/conf.d/ipa-rewrite.conf
|
||||
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/httpd/conf.d/ipa.conf
|
||||
%{_usr}/share/ipa/ipa.conf
|
||||
@ -421,12 +432,15 @@ fi
|
||||
%dir %{_localstatedir}/cache/ipa
|
||||
%attr(700,apache,apache) %dir %{_localstatedir}/cache/ipa/sessions
|
||||
%attr(700,root,root) %dir %{_localstatedir}/cache/ipa/kpasswd
|
||||
%{_mandir}/man1/ipa-replica-conncheck.1.gz
|
||||
%{_mandir}/man1/ipa-replica-install.1.gz
|
||||
%{_mandir}/man1/ipa-replica-manage.1.gz
|
||||
%{_mandir}/man1/ipa-csreplica-manage.1.gz
|
||||
%{_mandir}/man1/ipa-replica-prepare.1.gz
|
||||
%{_mandir}/man1/ipa-server-certinstall.1.gz
|
||||
%{_mandir}/man1/ipa-server-install.1.gz
|
||||
%{_mandir}/man1/ipa-dns-install.1.gz
|
||||
%{_mandir}/man1/ipa-ca-install.1.gz
|
||||
%{_mandir}/man1/ipa-compat-manage.1.gz
|
||||
%{_mandir}/man1/ipa-nis-manage.1.gz
|
||||
%{_mandir}/man1/ipa-host-net-manage.1.gz
|
||||
@ -489,6 +503,9 @@ fi
|
||||
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/default.conf
|
||||
|
||||
%changelog
|
||||
* Thu Aug 16 2011 Rob Crittenden <rcritten@redhat.com> - 2.1.0-1
|
||||
- Update to upstream 2.1.0
|
||||
|
||||
* Fri May 6 2011 Simo Sorce <ssorce@redhat.com> - 2.0.1-2
|
||||
- Fix bug #702633
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user