diff --git a/0002-Make-sure-template-dictionary-has-WSGI_PREFIX_DIR-wh.patch b/0002-Make-sure-template-dictionary-has-WSGI_PREFIX_DIR-wh.patch
index 2eef556..af3d72f 100644
--- a/0002-Make-sure-template-dictionary-has-WSGI_PREFIX_DIR-wh.patch
+++ b/0002-Make-sure-template-dictionary-has-WSGI_PREFIX_DIR-wh.patch
@@ -14,11 +14,15 @@ diff --git a/ipaserver/install/server/upgrade.py b/ipaserver/install/server/upgr
 index a38f4115c..807d674d7 100644
 --- a/ipaserver/install/server/upgrade.py
 +++ b/ipaserver/install/server/upgrade.py
-@@ -1651,6 +1651,7 @@ def upgrade_configuration():
+@@ -1651,6 +1651,11 @@ def upgrade_configuration():
  
          ds_dirname = dsinstance.config_dirname(ds_serverid)
  
 +        sub_dict['WSGI_PREFIX_DIR'] = paths.WSGI_PREFIX_DIR
++        sub_dict['GSSAPI_SESSION_KEY'] = paths.GSSAPI_SESSION_KEY
++        sub_dict['FONTS_DIR'] = paths.FONTS_DIR
++        sub_dict['IPA_CCACHES'] = paths.IPA_CCACHES
++        sub_dict['IPA_CUSTODIA_SOCKET'] = paths.IPA_CUSTODIA_SOCKET
          upgrade_file(sub_dict, paths.HTTPD_IPA_CONF,
                       os.path.join(paths.USR_SHARE_IPA_DIR,
                                    "ipa.conf.template"))
diff --git a/freeipa.spec b/freeipa.spec
index 09ec5fa..801d5b6 100644
--- a/freeipa.spec
+++ b/freeipa.spec
@@ -100,7 +100,7 @@
 
 Name:           freeipa
 Version:        %{VERSION}
-Release:        3%{?dist}
+Release:        4%{?dist}
 Summary:        The Identity, Policy and Audit system
 
 Group:          System Environment/Base
@@ -1718,6 +1718,9 @@ fi
 %endif # with_ipatests
 
 %changelog
+* Tue Mar 20 2018 Adam Williamson <awilliam@redhat.com> - 4.6.90.pre1-4
+- Fix upgrades harder (extension of -3 patch) (#1558354)
+
 * Tue Mar 20 2018 Alexander Bokovoy <abokovoy@redhat.com> - 4.6.90.pre1-3
 - Fix upgrade from F27 to F28 (#1558354)