Backport fix for #1488640, BuildRequires diffstat
This commit is contained in:
parent
c32989f9b1
commit
6f0885e4fd
84
1044.patch
Normal file
84
1044.patch
Normal file
@ -0,0 +1,84 @@
|
|||||||
|
From 8c242fd2cf2bbe14a4aae5d31d1f945901c72afb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pavel Vomacka <pvomacka@redhat.com>
|
||||||
|
Date: Wed, 6 Sep 2017 15:19:58 +0200
|
||||||
|
Subject: [PATCH 1/2] WebUI: remove unused parameter from get_whoami_command
|
||||||
|
|
||||||
|
The batch param is not used anywhere therefore we can remove it.
|
||||||
|
|
||||||
|
https://pagure.io/freeipa/issue/7143
|
||||||
|
---
|
||||||
|
install/ui/src/freeipa/ipa.js | 6 ++----
|
||||||
|
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/install/ui/src/freeipa/ipa.js b/install/ui/src/freeipa/ipa.js
|
||||||
|
index 2538001c94..3920b8eb0a 100644
|
||||||
|
--- a/install/ui/src/freeipa/ipa.js
|
||||||
|
+++ b/install/ui/src/freeipa/ipa.js
|
||||||
|
@@ -191,7 +191,7 @@ var IPA = function () {
|
||||||
|
}
|
||||||
|
}));
|
||||||
|
|
||||||
|
- batch.add_command(that.get_whoami_command(true));
|
||||||
|
+ batch.add_command(that.get_whoami_command());
|
||||||
|
|
||||||
|
batch.add_command(rpc.command({
|
||||||
|
method: 'env',
|
||||||
|
@@ -259,10 +259,8 @@ var IPA = function () {
|
||||||
|
/**
|
||||||
|
* Prepares `user-find --whoami` command
|
||||||
|
* @protected
|
||||||
|
- * @param {boolean} batch - Specifies if it will be used as single command or
|
||||||
|
- * in a batch.
|
||||||
|
*/
|
||||||
|
- that.get_whoami_command = function(batch) {
|
||||||
|
+ that.get_whoami_command = function() {
|
||||||
|
return rpc.command({
|
||||||
|
method: 'whoami',
|
||||||
|
on_success: function(data, text_status, xhr) {
|
||||||
|
|
||||||
|
From df34476d8bd7ac2de93588b4169e996605c85fe3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pavel Vomacka <pvomacka@redhat.com>
|
||||||
|
Date: Wed, 6 Sep 2017 15:20:07 +0200
|
||||||
|
Subject: [PATCH 2/2] WebUI: Fix calling undefined method during reset
|
||||||
|
passwords
|
||||||
|
|
||||||
|
When calling reset password the whoami command is not called in batch
|
||||||
|
command, therefore the result is different then in calling
|
||||||
|
during reset password operation. That needs to be handled to properly
|
||||||
|
set entity_show method which needs to be called after to gather
|
||||||
|
data about logged in entity.
|
||||||
|
|
||||||
|
https://pagure.io/freeipa/issue/7143
|
||||||
|
---
|
||||||
|
install/ui/src/freeipa/ipa.js | 11 ++++++-----
|
||||||
|
1 file changed, 6 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/install/ui/src/freeipa/ipa.js b/install/ui/src/freeipa/ipa.js
|
||||||
|
index 3920b8eb0a..138ca031b8 100644
|
||||||
|
--- a/install/ui/src/freeipa/ipa.js
|
||||||
|
+++ b/install/ui/src/freeipa/ipa.js
|
||||||
|
@@ -264,18 +264,19 @@ var IPA = function () {
|
||||||
|
return rpc.command({
|
||||||
|
method: 'whoami',
|
||||||
|
on_success: function(data, text_status, xhr) {
|
||||||
|
- that.whoami.metadata = data;
|
||||||
|
+ that.whoami.metadata = data.result || data;
|
||||||
|
+ var wa_data = that.whoami.metadata;
|
||||||
|
|
||||||
|
rpc.command({
|
||||||
|
- method: data.details || data.command,
|
||||||
|
- args: data.arguments,
|
||||||
|
+ method: wa_data.details || wa_data.command,
|
||||||
|
+ args: wa_data.arguments,
|
||||||
|
options: function() {
|
||||||
|
- var options = data.options || [];
|
||||||
|
+ var options = wa_data.options || [];
|
||||||
|
$.extend(options, {all: true});
|
||||||
|
return options;
|
||||||
|
}(),
|
||||||
|
on_success: function(data, text_status, xhr) {
|
||||||
|
- that.whoami.data = false ? data.result[0] : data.result.result;
|
||||||
|
+ that.whoami.data = data.result.result;
|
||||||
|
var entity = that.whoami.metadata.object;
|
||||||
|
|
||||||
|
if (entity === 'user') {
|
13
freeipa.spec
13
freeipa.spec
@ -68,7 +68,7 @@
|
|||||||
|
|
||||||
Name: freeipa
|
Name: freeipa
|
||||||
Version: %{VERSION}
|
Version: %{VERSION}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Identity, Policy and Audit system
|
Summary: The Identity, Policy and Audit system
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -79,6 +79,13 @@ Source1: https://releases.pagure.org/freeipa/freeipa-%{VERSION}.tar.gz.as
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch0001: 0001-Workarounds-for-SELinux-execmem-violations-in-crypto.patch
|
Patch0001: 0001-Workarounds-for-SELinux-execmem-violations-in-crypto.patch
|
||||||
|
# Fix issue with password change in web UI:
|
||||||
|
# https://github.com/freeipa/freeipa/pull/1044
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1488640
|
||||||
|
Patch0002: 1044.patch
|
||||||
|
|
||||||
|
# For the timestamp trick in patch application
|
||||||
|
BuildRequires: diffstat
|
||||||
|
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
# For KDB DAL version, make explicit dependency so that increase of version
|
# For KDB DAL version, make explicit dependency so that increase of version
|
||||||
@ -1710,6 +1717,10 @@ fi
|
|||||||
%endif # with_ipatests
|
%endif # with_ipatests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 06 2017 Adam Williamson <awilliam@redhat.com> - 4.6.0-2
|
||||||
|
- Fixes #1488640 "unknown command 'undefined'" error when changing password in web UI
|
||||||
|
- BuildRequires diffstat (for the use in patch application)
|
||||||
|
|
||||||
* Mon Sep 04 2017 Tomas Krizek <tkrizek@redhat.com> - 4.6.0-1
|
* Mon Sep 04 2017 Tomas Krizek <tkrizek@redhat.com> - 4.6.0-1
|
||||||
- Rebase to upstream 4.6.0
|
- Rebase to upstream 4.6.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user