ipa release 4.9.13-6
- ipatests: fix tasks.wait_for_replication() method Resolves: RHEL-25708 Signed-off-by: Rafael Guterres Jeffman <rjeffman@redhat.com>
This commit is contained in:
parent
8d7c3802f3
commit
535e08e118
@ -0,0 +1,34 @@
|
|||||||
|
From 44a762413c83f9637399afeb61b1e4b1ac111260 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florence Blanc-Renaud <flo@redhat.com>
|
||||||
|
Date: Feb 14 2024 12:24:48 +0000
|
||||||
|
Subject: ipatests: fix tasks.wait_for_replication method
|
||||||
|
|
||||||
|
|
||||||
|
With the fix for https://pagure.io/freeipa/issue/9171, the
|
||||||
|
method entry.single_value['nsds5replicaupdateinprogress'] now
|
||||||
|
returns a Boolean instead of a string "TRUE"/"FALSE".
|
||||||
|
|
||||||
|
The method tasks.wait_for_replication needs to be fixed so that
|
||||||
|
it properly detects when replication is not done.
|
||||||
|
|
||||||
|
Fixes: https://pagure.io/freeipa/issue/9530
|
||||||
|
|
||||||
|
Signed-off-by: Florence Blanc-Renaud <flo@redhat.com>
|
||||||
|
Reviewed-By: Rob Crittenden <rcritten@redhat.com>
|
||||||
|
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/ipatests/pytest_ipa/integration/tasks.py b/ipatests/pytest_ipa/integration/tasks.py
|
||||||
|
index 9068ba6..952c9e6 100755
|
||||||
|
--- a/ipatests/pytest_ipa/integration/tasks.py
|
||||||
|
+++ b/ipatests/pytest_ipa/integration/tasks.py
|
||||||
|
@@ -1510,7 +1510,7 @@ def wait_for_replication(ldap, timeout=30,
|
||||||
|
statuses = [entry.single_value[status_attr] for entry in entries]
|
||||||
|
wrong_statuses = [s for s in statuses
|
||||||
|
if not re.match(target_status_re, s)]
|
||||||
|
- if any(e.single_value[progress_attr] == 'TRUE' for e in entries):
|
||||||
|
+ if any(e.single_value[progress_attr] for e in entries):
|
||||||
|
msg = 'Replication not finished'
|
||||||
|
logger.debug(msg)
|
||||||
|
elif wrong_statuses:
|
||||||
|
|
5
ipa.spec
5
ipa.spec
@ -225,6 +225,7 @@ Patch0014: 0014-krb5kdc-Fix-start-when-pkinit-and-otp-auth-type-are-enabled
|
|||||||
Patch0015: 0015-hbactest-was-not-collecting-or-returning-messages_rhel#12780.patch
|
Patch0015: 0015-hbactest-was-not-collecting-or-returning-messages_rhel#12780.patch
|
||||||
Patch0016: 0016-ipatests-wait-for-replica-update-in-test_dns_locatio.patch
|
Patch0016: 0016-ipatests-wait-for-replica-update-in-test_dns_locatio.patch
|
||||||
Patch0017: 0017-ipa-kdb-Rework-ipadb_reinit_mspac.patch
|
Patch0017: 0017-ipa-kdb-Rework-ipadb_reinit_mspac.patch
|
||||||
|
Patch0018: 0018-ipatests-fix-tasks-wait_for_replication-method_rhel#25708.patch
|
||||||
%if 0%{?rhel} >= 8
|
%if 0%{?rhel} >= 8
|
||||||
Patch1001: 1001-Change-branding-to-IPA-and-Identity-Management.patch
|
Patch1001: 1001-Change-branding-to-IPA-and-Identity-Management.patch
|
||||||
Patch1002: 1002-Revert-freeipa.spec-depend-on-bind-dnssec-utils.patch
|
Patch1002: 1002-Revert-freeipa.spec-depend-on-bind-dnssec-utils.patch
|
||||||
@ -1740,11 +1741,13 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Feb 15 2024 Julien Rische <jrische@redhat.com> - 4.9.13-6
|
* Fri Feb 16 2024 Julien Rische <jrische@redhat.com> - 4.9.13-6
|
||||||
- ipa-kdb: Rework ipadb_reinit_mspac()
|
- ipa-kdb: Rework ipadb_reinit_mspac()
|
||||||
Resolves: RHEL-25742
|
Resolves: RHEL-25742
|
||||||
- ipatests: wait for replica update in test_dns_locations
|
- ipatests: wait for replica update in test_dns_locations
|
||||||
Resolves: RHEL-22373
|
Resolves: RHEL-22373
|
||||||
|
- ipatests: fix tasks.wait_for_replication() method
|
||||||
|
Resolves: RHEL-25708
|
||||||
|
|
||||||
* Tue Feb 13 2024 Rafael Jeffman <rjeffman@redhat.com> - 4.9.13-5
|
* Tue Feb 13 2024 Rafael Jeffman <rjeffman@redhat.com> - 4.9.13-5
|
||||||
- kdb: PAC generator: do not fail if canonical principal is missing
|
- kdb: PAC generator: do not fail if canonical principal is missing
|
||||||
|
Loading…
Reference in New Issue
Block a user