Rebase 0001-Workarounds-for-SELinux-execmem-violations-in-crypto.patch
This commit is contained in:
parent
ffe6f461b2
commit
1e163887b2
@ -1,8 +1,7 @@
|
||||
From 5ac052f085c74f058703c5da29d59849c11e571f Mon Sep 17 00:00:00 2001
|
||||
From 7d34dd15aa0365b1cd9d4bac9646aa4fa883f876 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Heimes <cheimes@redhat.com>
|
||||
Date: Thu, 3 Dec 2015 14:26:19 +0100
|
||||
Subject: [PATCH 26/26] Workarounds for SELinux execmem violations in
|
||||
cryptography
|
||||
Subject: [PATCH] Workarounds for SELinux execmem violations in cryptography
|
||||
|
||||
ipaserver.dcerpc uses M2Crypto again on Python 2.7 and Dogtag's
|
||||
pki.client no longer tries to use PyOpenSSL instead of Python's ssl
|
||||
@ -24,27 +23,27 @@ A hack in wsgi.py prevents the import by raising an ImportError.
|
||||
3 files changed, 39 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/freeipa.spec.in b/freeipa.spec.in
|
||||
index a60d9b63f363773b6ca1b0969fa56b369a94092f..4fe8a911f0ae08882287bfea262064f5a2386ec1 100644
|
||||
index 542dc28..cd05709 100644
|
||||
--- a/freeipa.spec.in
|
||||
+++ b/freeipa.spec.in
|
||||
@@ -66,6 +66,7 @@ BuildRequires: python-ldap
|
||||
@@ -72,6 +72,7 @@ BuildRequires: python-ldap
|
||||
BuildRequires: python-setuptools
|
||||
BuildRequires: python-nss
|
||||
BuildRequires: python-cryptography
|
||||
BuildRequires: python-cryptography >= 0.9
|
||||
+BuildRequires: m2crypto
|
||||
BuildRequires: python-netaddr
|
||||
BuildRequires: python-gssapi >= 1.1.2
|
||||
BuildRequires: python-rhsm
|
||||
@@ -322,6 +323,7 @@ Requires: keyutils
|
||||
@@ -483,6 +484,7 @@ Requires: keyutils
|
||||
Requires: pyOpenSSL
|
||||
Requires: python-nss >= 0.16
|
||||
Requires: python-cryptography
|
||||
Requires: python-cryptography >= 0.9
|
||||
+Requires: m2crypto
|
||||
Requires: python-lxml
|
||||
Requires: python-netaddr
|
||||
Requires: python-libipa_hbac
|
||||
diff --git a/install/share/wsgi.py b/install/share/wsgi.py
|
||||
index ee9311e4eab8b95b5143170469cac7dc0b8b8e5e..ba42c343228da21f8e2ae9ea717450bada93359d 100644
|
||||
index ee9311e..ba42c34 100644
|
||||
--- a/install/share/wsgi.py
|
||||
+++ b/install/share/wsgi.py
|
||||
@@ -23,6 +23,20 @@
|
||||
@ -69,7 +68,7 @@ index ee9311e4eab8b95b5143170469cac7dc0b8b8e5e..ba42c343228da21f8e2ae9ea717450ba
|
||||
from ipalib.config import Env
|
||||
from ipalib.constants import DEFAULT_CONFIG
|
||||
diff --git a/ipaserver/dcerpc.py b/ipaserver/dcerpc.py
|
||||
index 2e412861ebc265a9b07c8634068151181a3e9b9e..15d8e192e397868a0bf623d8a23c4a2489126bcb 100644
|
||||
index bb58945..63df946 100644
|
||||
--- a/ipaserver/dcerpc.py
|
||||
+++ b/ipaserver/dcerpc.py
|
||||
@@ -42,8 +42,6 @@ from samba.ndr import ndr_pack, ndr_print
|
||||
@ -126,5 +125,5 @@ index 2e412861ebc265a9b07c8634068151181a3e9b9e..15d8e192e397868a0bf623d8a23c4a24
|
||||
# This class attempts to implement LDAP control that would work
|
||||
# with both python-ldap 2.4.x and 2.3.x, thus there is mix of properties
|
||||
--
|
||||
2.4.3
|
||||
2.5.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user