Rebuild against samba4 beta4
This commit is contained in:
parent
a0ca5be798
commit
10af3ccf36
33
freeipa-2.9.90-samba4-beta4.patch
Normal file
33
freeipa-2.9.90-samba4-beta4.patch
Normal file
@ -0,0 +1,33 @@
|
||||
commit 61b2f0a5d066a14e22033ff9815a712716f12a96
|
||||
Author: Alexander Bokovoy <abokovoy@redhat.com>
|
||||
Date: Wed Jul 18 15:52:33 2012 +0300
|
||||
|
||||
Follow change in samba4 beta4 for sid_check_is_domain to sid_check_is_our_sam
|
||||
|
||||
With c43505b621725c9a754f0ee98318d451b093f2ed in samba git master
|
||||
the function sid_check_is_domain() was renamed to sid_check_is_our_sam().
|
||||
|
||||
https://fedorahosted.org/freeipa/ticket/2929
|
||||
|
||||
diff --git a/daemons/ipa-sam/ipa_sam.c b/daemons/ipa-sam/ipa_sam.c
|
||||
index 86ed3fb..ab4b116 100644
|
||||
--- a/daemons/ipa-sam/ipa_sam.c
|
||||
+++ b/daemons/ipa-sam/ipa_sam.c
|
||||
@@ -83,6 +83,8 @@ enum ndr_err_code ndr_pull_trustAuthInOutBlob(struct ndr_pull *ndr, int ndr_flag
|
||||
bool fetch_ldap_pw(char **dn, char** pw); /* available in libpdb.so */
|
||||
void nt_lm_owf_gen(const char *pwd, uint8_t nt_p16[16], uint8_t p16[16]); /* available in libcliauth.so */
|
||||
bool sid_check_is_builtin(const struct dom_sid *sid); /* available in libpdb.so */
|
||||
+/* available in libpdb.so, renamed from sid_check_is_domain() in c43505b621725c9a754f0ee98318d451b093f2ed */
|
||||
+bool sid_check_is_our_sam(const struct dom_sid *sid);
|
||||
void strlower_m(char *s); /* available in libutil_str.so */
|
||||
char *talloc_asprintf_strupper_m(TALLOC_CTX *t, const char *fmt, ...); /* available in libutil_str.so */
|
||||
void sid_copy(struct dom_sid *dst, const struct dom_sid *src); /* available in libsecurity.so */
|
||||
@@ -300,7 +302,7 @@ static NTSTATUS ldapsam_lookup_rids(struct pdb_methods *methods,
|
||||
}
|
||||
|
||||
if (!sid_check_is_builtin(domain_sid) &&
|
||||
- !sid_check_is_domain(domain_sid)) {
|
||||
+ !sid_check_is_our_sam(domain_sid)) {
|
||||
result = NT_STATUS_INVALID_PARAMETER;
|
||||
goto done;
|
||||
}
|
@ -15,13 +15,14 @@ distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
||||
|
||||
Name: freeipa
|
||||
Version: 3.0.0
|
||||
Release: 0.1%{?dist}
|
||||
Release: 0.2%{?dist}
|
||||
Summary: The Identity, Policy and Audit system
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPLv3+
|
||||
URL: http://www.freeipa.org/
|
||||
Source0: http://www.freeipa.org/downloads/src/freeipa-%{VERSION}.tar.gz
|
||||
Patch0: freeipa-2.9.90-samba4-beta4.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%if ! %{ONLY_CLIENT}
|
||||
@ -30,7 +31,7 @@ BuildRequires: svrcore-devel
|
||||
BuildRequires: /usr/share/selinux/devel/Makefile
|
||||
BuildRequires: policycoreutils >= %{POLICYCOREUTILSVER}
|
||||
BuildRequires: systemd-units
|
||||
BuildRequires: samba4-devel
|
||||
BuildRequires: samba4-devel >= 4.0.0-128
|
||||
BuildRequires: samba4-python
|
||||
%endif
|
||||
BuildRequires: nspr-devel
|
||||
@ -253,6 +254,7 @@ package.
|
||||
|
||||
%prep
|
||||
%setup -n freeipa-%{VERSION} -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export CFLAGS="$CFLAGS %{optflags}"
|
||||
@ -637,6 +639,9 @@ fi
|
||||
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/ca.crt
|
||||
|
||||
%changelog
|
||||
* Mon Jul 23 2012 Alexander Bokovoy <abokovy@redhat.com> - 3.0.0-0.2
|
||||
- Rebuild against samba4 beta4
|
||||
|
||||
* Mon Jul 2 2012 Rob Crittenden <rcritten@redhat.com> - 3.0.0-0.1
|
||||
- Updated to upstream 3.0.0 beta 1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user