34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
diff -up iotop-0.6/setup.cfg.usesetuptools iotop-0.6/setup.cfg
|
|
--- iotop-0.6/setup.cfg.usesetuptools 2021-10-08 04:27:30.000000000 +0200
|
|
+++ iotop-0.6/setup.cfg 2022-12-20 23:17:11.242082371 +0100
|
|
@@ -1,3 +1,6 @@
|
|
[bdist_rpm]
|
|
doc_files = ChangeLog COPYING NEWS README THANKS
|
|
install_script = .install-rpm.sh
|
|
+
|
|
+[install]
|
|
+install_scripts=/usr/sbin
|
|
diff -up iotop-0.6/setup.py.usesetuptools iotop-0.6/setup.py
|
|
--- iotop-0.6/setup.py.usesetuptools 2021-10-08 04:27:30.000000000 +0200
|
|
+++ iotop-0.6/setup.py 2022-12-20 23:18:52.703691554 +0100
|
|
@@ -1,18 +1,10 @@
|
|
#!/usr/bin/env python3
|
|
|
|
-from distutils.core import setup, Extension
|
|
-from distutils.command import install as distutils_install
|
|
+from setuptools import setup, Extension
|
|
from iotop.version import VERSION
|
|
|
|
_ioprio = Extension('iotop._ioprio', sources = ['iotop/_ioprio.c'])
|
|
|
|
-# Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
|
|
-# while still honoring the choice of installing into local/ or not.
|
|
-if hasattr(distutils_install, 'INSTALL_SCHEMES'):
|
|
- for d in distutils_install.INSTALL_SCHEMES.values():
|
|
- if d.get('scripts', '').endswith('/bin'):
|
|
- d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
|
|
-
|
|
setup(name='iotop',
|
|
version=VERSION,
|
|
description='Per process I/O bandwidth monitor',
|