Fix python3 patch

This commit is contained in:
Adel Gadllah 2015-11-15 22:49:47 +01:00
parent cc5b472367
commit a332a85b59
2 changed files with 14 additions and 2 deletions

View File

@ -1,9 +1,18 @@
diff -ru iotop-0.6.orign/sbin/iotop iotop-0.6/sbin/iotop
--- iotop-0.6.orign/sbin/iotop 2013-05-27 00:44:18.000000000 +0200
+++ iotop-0.6/sbin/iotop 2015-11-15 22:31:39.978094119 +0100
+++ iotop-0.6/sbin/iotop 2015-11-15 22:47:24.468058681 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
# iotop: Display I/O usage of processes in a top like UI
# Copyright (c) 2007, 2008 Guillaume Chazarain <guichaz@gmail.com>, GPLv2
# See iotop --help for some help
diff -ru iotop-0.6.orign/setup.py iotop-0.6/setup.py
--- iotop-0.6.orign/setup.py 2013-05-27 00:44:18.000000000 +0200
+++ iotop-0.6/setup.py 2015-11-15 22:47:19.431004659 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
from distutils.core import setup
from distutils.command import install as distutils_install

View File

@ -1,7 +1,7 @@
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: iotop
Version: 0.6
Release: 7%{?dist}
Release: 8%{?dist}
Summary: Top like utility for I/O
Group: Applications/System
@ -51,6 +51,9 @@ rm -rf $RPM_BUILD_ROOT
%{python_sitelib}/*
%changelog
* Sun Nov 15 2015 Adel Gadllah <adel.gadllah@gmail.com> - 0.6-8
- Fix python3 patch
* Sun Nov 15 2015 Adel Gadllah <adel.gadllah@gmail.com> - 0.6-7
- Rebuilt with python3 - RH#1282262