use setuptools instead of distutils (#2155049)
This commit is contained in:
parent
5cbe38d3a9
commit
6a34894058
33
iotop-0.6-usesetuptools.patch
Normal file
33
iotop-0.6-usesetuptools.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up iotop-0.6/setup.cfg.usesetuptools iotop-0.6/setup.cfg
|
||||
--- iotop-0.6/setup.cfg.usesetuptools 2021-10-08 04:27:30.000000000 +0200
|
||||
+++ iotop-0.6/setup.cfg 2022-12-20 23:17:11.242082371 +0100
|
||||
@@ -1,3 +1,6 @@
|
||||
[bdist_rpm]
|
||||
doc_files = ChangeLog COPYING NEWS README THANKS
|
||||
install_script = .install-rpm.sh
|
||||
+
|
||||
+[install]
|
||||
+install_scripts=/usr/sbin
|
||||
diff -up iotop-0.6/setup.py.usesetuptools iotop-0.6/setup.py
|
||||
--- iotop-0.6/setup.py.usesetuptools 2021-10-08 04:27:30.000000000 +0200
|
||||
+++ iotop-0.6/setup.py 2022-12-20 23:18:52.703691554 +0100
|
||||
@@ -1,18 +1,10 @@
|
||||
#!/usr/bin/env python3
|
||||
|
||||
-from distutils.core import setup, Extension
|
||||
-from distutils.command import install as distutils_install
|
||||
+from setuptools import setup, Extension
|
||||
from iotop.version import VERSION
|
||||
|
||||
_ioprio = Extension('iotop._ioprio', sources = ['iotop/_ioprio.c'])
|
||||
|
||||
-# Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
|
||||
-# while still honoring the choice of installing into local/ or not.
|
||||
-if hasattr(distutils_install, 'INSTALL_SCHEMES'):
|
||||
- for d in distutils_install.INSTALL_SCHEMES.values():
|
||||
- if d.get('scripts', '').endswith('/bin'):
|
||||
- d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
|
||||
-
|
||||
setup(name='iotop',
|
||||
version=VERSION,
|
||||
description='Per process I/O bandwidth monitor',
|
@ -1,6 +1,6 @@
|
||||
Name: iotop
|
||||
Version: 0.6
|
||||
Release: 33%{?dist}
|
||||
Release: 34%{?dist}
|
||||
Summary: Top like utility for I/O
|
||||
License: GPLv2+
|
||||
URL: http://guichaz.free.fr/iotop/
|
||||
@ -21,9 +21,11 @@ Patch3: iotop-0.3.2-batchprintutf8.patch
|
||||
Patch4: iotop-0.6-git9c49d59.patch
|
||||
# rhbz#1679201
|
||||
Patch5: iotop-0.6-delayacctmsg.patch
|
||||
Patch6: iotop-0.6-usesetuptools.patch
|
||||
|
||||
#BuildArch: noarch
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: gcc
|
||||
|
||||
%description
|
||||
@ -37,6 +39,7 @@ show of behalf of which process is the I/O going on.
|
||||
%patch3 -p1 -b .batchprintutf8
|
||||
%patch4 -p1 -b .git9c49d59
|
||||
%patch5 -p1 -b .delayacctmsg
|
||||
%patch6 -p1 -b .usesetuptools
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
@ -52,6 +55,9 @@ show of behalf of which process is the I/O going on.
|
||||
%{_mandir}/man8/iotop.*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 20 2022 Michal Hlavinka <mhlavink@redhat.com> - 0.6-34
|
||||
- use setuptools instead of distutils (#2155049)
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-33
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user