iotop updated to 0.4.4
This commit is contained in:
parent
1304c5ea5f
commit
51cdebdf0f
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
iotop-0.4.tar.bz2
|
iotop-0.4.tar.bz2
|
||||||
/iotop-0.4.3.tar.bz2
|
/iotop-0.4.3.tar.bz2
|
||||||
|
/iotop-0.4.4.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up iotop-0.4.3/iotop/ui.py.rootpriv iotop-0.4.3/iotop/ui.py
|
|
||||||
--- iotop-0.4.3/iotop/ui.py.rootpriv 2011-10-11 16:59:48.204722984 +0200
|
|
||||||
+++ iotop-0.4.3/iotop/ui.py 2011-10-11 16:59:55.833780660 +0200
|
|
||||||
@@ -511,6 +511,10 @@ def main():
|
|
||||||
locale.setlocale(locale.LC_ALL, '')
|
|
||||||
except locale.Error:
|
|
||||||
print 'unable to set locale, falling back to the default locale'
|
|
||||||
+ if os.getuid() != 0:
|
|
||||||
+ print 'root privileges required'
|
|
||||||
+ exit(1)
|
|
||||||
+
|
|
||||||
parser = optparse.OptionParser(usage=USAGE, version='iotop ' + VERSION)
|
|
||||||
parser.add_option('-o', '--only', action='store_true',
|
|
||||||
dest='only', default=False,
|
|
11
iotop.spec
11
iotop.spec
@ -1,7 +1,7 @@
|
|||||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
Name: iotop
|
Name: iotop
|
||||||
Version: 0.4.3
|
Version: 0.4.4
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Top like utility for I/O
|
Summary: Top like utility for I/O
|
||||||
|
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -9,9 +9,6 @@ License: GPLv2
|
|||||||
URL: http://guichaz.free.fr/iotop/
|
URL: http://guichaz.free.fr/iotop/
|
||||||
Source0: http://guichaz.free.fr/iotop/files/%{name}-%{version}.tar.bz2
|
Source0: http://guichaz.free.fr/iotop/files/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
# after CVE-2011-2494 fix, iotop needs root privileges
|
|
||||||
Patch1: iotop-0.4.3-rootpriv.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -20,7 +17,6 @@ Requires: python
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup
|
%setup
|
||||||
%patch1 -p1 -b .rootpriv
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python} setup.py build
|
%{__python} setup.py build
|
||||||
@ -49,6 +45,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{python_sitelib}/*
|
%{python_sitelib}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 16 2011 Michal Hlavinka <mhlavink@redhat.com> - 0.4.4-1
|
||||||
|
- iotop updated to 0.4.4
|
||||||
|
|
||||||
* Fri Oct 14 2011 Michal Hlavinka <mhlavink@redhat.com> 0.4.3-3
|
* Fri Oct 14 2011 Michal Hlavinka <mhlavink@redhat.com> 0.4.3-3
|
||||||
- fix typo in last patch
|
- fix typo in last patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user