3d4d49f7e8
* .gitignore: Add /intel-cmt-cat-23.11.tar.gz. * 0001-allow-debian-flags-to-be-added.patch: New file. * intel-cmt-cat.spec (%githubver): Change from 4.1.0 to 23.11. (Release): Reset to 1. (License): Change from BSD to BSD-3-Clause to adhere to Fedora policy's rules. (Source): Change the "01org" user URL part to "intel". (URL): Likewise. (%description): Likewise. (Patch0001): New patch. (%prep): Add -p1 option to %autosetup. (%build): Override HAS_AVX512 HAS_CLWB to 0 in %make. (%install): Use relative softlinks for pqos-os.8 and pqos-msr.8; exclude package version from the license install directory; install membw; change libpqos sover from 4 to 5; update list of example files to install. (%files): Add membw and the associated man page; update the path in %license; change README to README.md in %doc; change libpqos.so.4 to libpqos.so.5; update the list of example files to package. (%changelog): Mention the change. * sources: Replace v4.1.0.tar.gz entry with intel-cmt-cat-23.11.tar.gz. Resolves: RHEL-25780 Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
65 lines
2.8 KiB
Diff
65 lines
2.8 KiB
Diff
Description: Hard code in hardening options
|
|
Forwarded: not-needed
|
|
Author: Colin Ian King <colin.i.king@gmail.com>
|
|
|
|
Index: intel-cmt-cat-23.11/lib/Makefile
|
|
===================================================================
|
|
--- intel-cmt-cat-23.11.orig/lib/Makefile 2023-11-01 14:00:13.000000000 +0100
|
|
+++ intel-cmt-cat-23.11/lib/Makefile 2024-02-21 08:55:18.864718246 +0100
|
|
@@ -37,8 +37,8 @@
|
|
VERSION = 5.0.0
|
|
SO_VERSION = 5
|
|
SHARED ?= y
|
|
-LDFLAGS = -L. -lpthread -z noexecstack -z relro -z now
|
|
-CFLAGS = -pthread -I./ -D_GNU_SOURCE \
|
|
+LDFLAGS += -L. -lpthread -z noexecstack -z relro -z now
|
|
+CFLAGS += -pthread -I./ -D_GNU_SOURCE \
|
|
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
|
|
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
|
|
-Wcast-qual -Wundef -Wwrite-strings \
|
|
Index: intel-cmt-cat-23.11/pqos/Makefile
|
|
===================================================================
|
|
--- intel-cmt-cat-23.11.orig/pqos/Makefile 2023-11-01 14:00:13.000000000 +0100
|
|
+++ intel-cmt-cat-23.11/pqos/Makefile 2024-02-21 08:55:18.865718244 +0100
|
|
@@ -36,9 +36,9 @@
|
|
|
|
OBJDIR = obj
|
|
LIBDIR ?= ../lib
|
|
-LDFLAGS = -L$(LIBDIR) -pie -z noexecstack -z relro -z now
|
|
+LDFLAGS += -L$(LIBDIR) -pie -z noexecstack -z relro -z now
|
|
LDLIBS = -lpqos -lpthread
|
|
-CFLAGS = -I$(LIBDIR) \
|
|
+CFLAGS += -I$(LIBDIR) \
|
|
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
|
|
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
|
|
-Wcast-qual -Wundef -Wwrite-strings \
|
|
Index: intel-cmt-cat-23.11/rdtset/Makefile
|
|
===================================================================
|
|
--- intel-cmt-cat-23.11.orig/rdtset/Makefile 2023-11-01 14:00:13.000000000 +0100
|
|
+++ intel-cmt-cat-23.11/rdtset/Makefile 2024-02-21 08:55:18.866718241 +0100
|
|
@@ -35,9 +35,9 @@
|
|
###############################################################################
|
|
|
|
LIBDIR ?= ../lib
|
|
-LDFLAGS = -L$(LIBDIR) -pie -z noexecstack -z relro -z now
|
|
+LDFLAGS += -L$(LIBDIR) -pie -z noexecstack -z relro -z now
|
|
LDLIBS = -lpqos -lpthread
|
|
-CFLAGS = -I$(LIBDIR) \
|
|
+CFLAGS += -I$(LIBDIR) \
|
|
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
|
|
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
|
|
-Wcast-qual -Wundef -Wwrite-strings \
|
|
Index: intel-cmt-cat-23.11/tools/membw/Makefile
|
|
===================================================================
|
|
--- intel-cmt-cat-23.11.orig/tools/membw/Makefile 2023-11-01 14:00:13.000000000 +0100
|
|
+++ intel-cmt-cat-23.11/tools/membw/Makefile 2024-02-21 08:55:18.866718241 +0100
|
|
@@ -42,7 +42,7 @@
|
|
BIN_DIR = $(PREFIX)/bin
|
|
MAN_DIR = $(PREFIX)/man/man8
|
|
|
|
-CFLAGS=-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
|
|
+CFLAGS += -W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
|
|
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
|
|
-Wcast-qual -Wundef -Wwrite-strings \
|
|
-Wformat -Wformat-security -fstack-protector -fPIE \
|