29 lines
825 B
Diff
29 lines
825 B
Diff
From 072dc9ab42bff067bd9dc0f256c3abd7b1cc7341 Mon Sep 17 00:00:00 2001
|
|
From: Jiri Olsa <jolsa@kernel.org>
|
|
Date: Thu, 4 Oct 2018 14:27:47 +0200
|
|
Subject: [PATCH 1/2] make: Adding LDFLAGS to the libpqos build command
|
|
|
|
So it's taken into account.
|
|
|
|
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
|
|
---
|
|
lib/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/lib/Makefile b/lib/Makefile
|
|
index fe07dfb81da6..a2dba5939931 100644
|
|
--- a/lib/Makefile
|
|
+++ b/lib/Makefile
|
|
@@ -104,7 +104,7 @@ all: $(LIBNAME)
|
|
|
|
$(LIBNAME): $(OBJS)
|
|
ifeq ($(SHARED),y)
|
|
- $(CC) -shared -Wl,-soname,$(LIB).so.$(SO_VERSION) -o $(LIBNAME) $^ -lc
|
|
+ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB).so.$(SO_VERSION) -o $(LIBNAME) $^ -lc
|
|
ln -f -s $(LIBNAME) $(LIB).so.$(SO_VERSION)
|
|
ln -f -s $(LIB).so.$(SO_VERSION) $(LIB).so
|
|
else
|
|
--
|
|
2.17.1
|
|
|