Update to 23.11

This commit is contained in:
Ali Erdinc Koroglu 2023-11-13 14:33:36 +02:00
parent 4655de62f8
commit 979237b85b
5 changed files with 115 additions and 26 deletions

View File

@ -3,11 +3,11 @@ Description: Workaround environment variable settings
Forwarded: not-needed
Author: Colin Ian King <colin.i.king@gmail.com>
Index: intel-cmt-cat-4.5.0/lib/Makefile
Index: intel-cmt-cat-23.11/lib/Makefile
===================================================================
--- intel-cmt-cat-4.5.0.orig/lib/Makefile
+++ intel-cmt-cat-4.5.0/lib/Makefile
@@ -124,10 +124,10 @@ endif
--- intel-cmt-cat-23.11.orig/lib/Makefile
+++ intel-cmt-cat-23.11/lib/Makefile
@@ -119,10 +119,10 @@ endif
HDR = pqos.h
PREFIX ?= /usr/local
@ -21,40 +21,40 @@ Index: intel-cmt-cat-4.5.0/lib/Makefile
all: $(LIBNAME)
Index: intel-cmt-cat-4.5.0/pqos/Makefile
Index: intel-cmt-cat-23.11/pqos/Makefile
===================================================================
--- intel-cmt-cat-4.5.0.orig/pqos/Makefile
+++ intel-cmt-cat-4.5.0/pqos/Makefile
@@ -98,8 +98,8 @@ MAN = pqos.8
--- intel-cmt-cat-23.11.orig/pqos/Makefile
+++ intel-cmt-cat-23.11/pqos/Makefile
@@ -94,8 +94,8 @@ MAN = pqos.8
# XXX: modify as desired
PREFIX ?= /usr/local
-BIN_DIR = $(PREFIX)/bin
-MAN_DIR = $(PREFIX)/man/man8
+BIN_DIR = $(DESTDIR)/usr/bin
+BIN_DIR = $(DESTDIR)/usr/sbin
+MAN_DIR = $(DESTDIR)/usr/share/man/man8
SRCS = $(sort $(wildcard *.c))
OBJS = $(addprefix $(OBJDIR)/,$(SRCS:.c=.o))
Index: intel-cmt-cat-4.5.0/rdtset/Makefile
Index: intel-cmt-cat-23.11/rdtset/Makefile
===================================================================
--- intel-cmt-cat-4.5.0.orig/rdtset/Makefile
+++ intel-cmt-cat-4.5.0/rdtset/Makefile
@@ -99,8 +99,8 @@ MAN = rdtset.8
--- intel-cmt-cat-23.11.orig/rdtset/Makefile
+++ intel-cmt-cat-23.11/rdtset/Makefile
@@ -95,8 +95,8 @@ MAN = rdtset.8
# XXX: modify as desired
PREFIX ?= /usr/local
-BIN_DIR = $(PREFIX)/bin
-MAN_DIR = $(PREFIX)/man/man8
+BIN_DIR = $(DESTDIR)/usr/bin
+BIN_DIR = $(DESTDIR)/usr/sbin
+MAN_DIR = $(DESTDIR)/usr/share/man/man8
SRCS = $(sort $(wildcard *.c))
OBJS = $(SRCS:.c=.o)
Index: intel-cmt-cat-4.5.0/tools/membw/Makefile
Index: intel-cmt-cat-23.11/tools/membw/Makefile
===================================================================
--- intel-cmt-cat-4.5.0.orig/tools/membw/Makefile
+++ intel-cmt-cat-4.5.0/tools/membw/Makefile
--- intel-cmt-cat-23.11.orig/tools/membw/Makefile
+++ intel-cmt-cat-23.11/tools/membw/Makefile
@@ -39,8 +39,8 @@ MAN = membw.8
# XXX: modify as desired

View File

@ -0,0 +1,20 @@
Description: Remove examples
No need to install these, developers are encouraged to look
at the code in the repository
Forwarded: not-needed
Author: Colin Ian King <colin.i.king@gmail.com>
Index: intel-cmt-cat-4.5.0/Makefile
===================================================================
--- intel-cmt-cat-4.5.0.orig/Makefile
+++ intel-cmt-cat-4.5.0/Makefile
@@ -53,9 +53,6 @@ all:
$(MAKE) -C pqos
$(MAKE) -C rdtset
$(MAKE) -C tools/membw
- $(MAKE) -C examples/c/CAT_MBA
- $(MAKE) -C examples/c/CMT_MBM
- $(MAKE) -C examples/c/PSEUDO_LOCK
setup-dev:
$(MAKE) -C appqos setup-dev

View File

@ -0,0 +1,64 @@
Description: Hard code in hardening options
Forwarded: not-needed
Author: Colin Ian King <colin.i.king@gmail.com>
Index: intel-cmt-cat-23.11/lib/Makefile
===================================================================
--- intel-cmt-cat-23.11.orig/lib/Makefile
+++ intel-cmt-cat-23.11/lib/Makefile
@@ -37,8 +37,8 @@ LIB = libpqos
VERSION = 5.0.0
SO_VERSION = 5
SHARED ?= y
-LDFLAGS = -L. -lpthread -z noexecstack -z relro -z now
-CFLAGS = -pthread -I./ -D_GNU_SOURCE \
+LDFLAGS += -L. -lpthread -z noexecstack -z relro -z now
+CFLAGS += -pthread -I./ -D_GNU_SOURCE \
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
-Wcast-qual -Wundef -Wwrite-strings \
Index: intel-cmt-cat-23.11/pqos/Makefile
===================================================================
--- intel-cmt-cat-23.11.orig/pqos/Makefile
+++ intel-cmt-cat-23.11/pqos/Makefile
@@ -36,9 +36,9 @@
OBJDIR = obj
LIBDIR ?= ../lib
-LDFLAGS = -L$(LIBDIR) -pie -z noexecstack -z relro -z now
+LDFLAGS += -L$(LIBDIR) -pie -z noexecstack -z relro -z now
LDLIBS = -lpqos -lpthread
-CFLAGS = -I$(LIBDIR) \
+CFLAGS += -I$(LIBDIR) \
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
-Wcast-qual -Wundef -Wwrite-strings \
Index: intel-cmt-cat-23.11/rdtset/Makefile
===================================================================
--- intel-cmt-cat-23.11.orig/rdtset/Makefile
+++ intel-cmt-cat-23.11/rdtset/Makefile
@@ -35,9 +35,9 @@
###############################################################################
LIBDIR ?= ../lib
-LDFLAGS = -L$(LIBDIR) -pie -z noexecstack -z relro -z now
+LDFLAGS += -L$(LIBDIR) -pie -z noexecstack -z relro -z now
LDLIBS = -lpqos -lpthread
-CFLAGS = -I$(LIBDIR) \
+CFLAGS += -I$(LIBDIR) \
-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
-Wcast-qual -Wundef -Wwrite-strings \
Index: intel-cmt-cat-23.11/tools/membw/Makefile
===================================================================
--- intel-cmt-cat-23.11.orig/tools/membw/Makefile
+++ intel-cmt-cat-23.11/tools/membw/Makefile
@@ -42,7 +42,7 @@ PREFIX ?= /usr/local
BIN_DIR = $(DESTDIR)/usr/bin
MAN_DIR = $(DESTDIR)/usr/share/man/man8
-CFLAGS=-W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
+CFLAGS += -W -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wold-style-definition -Wpointer-arith \
-Wcast-qual -Wundef -Wwrite-strings \
-Wformat -Wformat-security -fstack-protector -fPIE \

View File

@ -1,4 +1,4 @@
%global libpqos_ver 4.6.1
%global libpqos_ver 5.0.0
%global desc %{expand: \
This package provides basic support for Intel Resource Director Technology
including, Cache Monitoring Technology (CMT), Memory Bandwidth Monitoring
@ -6,7 +6,7 @@ including, Cache Monitoring Technology (CMT), Memory Bandwidth Monitoring
(CDP) and Memory Bandwidth Allocation (MBA).}
Name: intel-cmt-cat
Version: 23.08
Version: 23.11
Release: 1%{?dist}
Summary: Intel cache monitoring and allocation technology config tool
@ -14,7 +14,9 @@ License: BSD-3-Clause
URL: https://github.com/intel/intel-cmt-cat
Source: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch: 0001-alter-install-paths.patch
Patch0: 0001-alter-install-paths.patch
Patch1: 0002-remove-build-and-install-of-examples.patch
Patch2: 0003-allow-debian-flags-to-be-added.patch
ExclusiveArch: x86_64
@ -47,11 +49,11 @@ Development files.
%license LICENSE
%doc ChangeLog README.md
%{_bindir}/membw
%{_bindir}/pqos
%{_bindir}/pqos-msr
%{_bindir}/pqos-os
%{_bindir}/rdtset
%{_libdir}/libpqos.so.4
%{_sbindir}/pqos
%{_sbindir}/pqos-msr
%{_sbindir}/pqos-os
%{_sbindir}/rdtset
%{_libdir}/libpqos.so.5
%{_libdir}/libpqos.so.%{libpqos_ver}
%{_mandir}/man8/membw.8*
%{_mandir}/man8/pqos.8*
@ -64,6 +66,9 @@ Development files.
%{_libdir}/libpqos.so
%changelog
* Mon Nov 13 2023 Ali Erdinc Koroglu <aekoroglu@fedoraproject.org> - 23.11-1
- Update to 23.11
* Thu Aug 31 2023 Ali Erdinc Koroglu <aekoroglu@fedoraproject.org> - 23.08-1
- Update to 23.08

View File

@ -1 +1 @@
SHA512 (intel-cmt-cat-23.08.tar.gz) = a9f702bb9b9e997a78ddb847b95fa6b89b6d47bf211b50e353f0af378757fcae89a58fb7536dc810e58a9e479f838ad9b34b4bbc6f5ec49fbdb0cdb97bd78175
SHA512 (intel-cmt-cat-23.11.tar.gz) = 049fddab412a117b485c7dc41675ce27f4b77df3118e9783688ee59deae4ac087f373def0cace09e515f3ee4cc695fc974dfcaa6c20022fa455eb3a8d45c4f2e