import intel-cmt-cat-4.0.0-0.el8
This commit is contained in:
parent
5387cbe9ac
commit
1c361f1c96
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/v2.0.0.tar.gz
|
SOURCES/v4.0.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
ace5783bf51f746ad3e2b79a31a5cb99c5689ab6 SOURCES/v2.0.0.tar.gz
|
429fa1c3fe32bb33030c98135fc259f57a4566e2 SOURCES/v4.0.0.tar.gz
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From 072dc9ab42bff067bd9dc0f256c3abd7b1cc7341 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
Date: Thu, 4 Oct 2018 14:27:47 +0200
|
|
||||||
Subject: [PATCH 1/2] make: Adding LDFLAGS to the libpqos build command
|
|
||||||
|
|
||||||
So it's taken into account.
|
|
||||||
|
|
||||||
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
---
|
|
||||||
lib/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/Makefile b/lib/Makefile
|
|
||||||
index fe07dfb81da6..a2dba5939931 100644
|
|
||||||
--- a/lib/Makefile
|
|
||||||
+++ b/lib/Makefile
|
|
||||||
@@ -104,7 +104,7 @@ all: $(LIBNAME)
|
|
||||||
|
|
||||||
$(LIBNAME): $(OBJS)
|
|
||||||
ifeq ($(SHARED),y)
|
|
||||||
- $(CC) -shared -Wl,-soname,$(LIB).so.$(SO_VERSION) -o $(LIBNAME) $^ -lc
|
|
||||||
+ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB).so.$(SO_VERSION) -o $(LIBNAME) $^ -lc
|
|
||||||
ln -f -s $(LIBNAME) $(LIB).so.$(SO_VERSION)
|
|
||||||
ln -f -s $(LIB).so.$(SO_VERSION) $(LIB).so
|
|
||||||
else
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,62 +0,0 @@
|
|||||||
From 0f1020bc83b3d047a6226326d79798e1c7f4e0ee Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
Date: Thu, 4 Oct 2018 14:25:16 +0200
|
|
||||||
Subject: [PATCH 2/2] make: Add support to add flags to LDFLAGS via
|
|
||||||
EXTRA_LDFLAGS
|
|
||||||
|
|
||||||
We need to pass extra flags to LDFLAGS, so adding
|
|
||||||
the EXTRA_LDFLAGS to allow that. It mirrors the
|
|
||||||
EXTRA_CFLAGS variable usage.
|
|
||||||
|
|
||||||
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
|
|
||||||
---
|
|
||||||
lib/Makefile | 3 +++
|
|
||||||
pqos/Makefile | 3 +++
|
|
||||||
rdtset/Makefile | 3 +++
|
|
||||||
3 files changed, 9 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/lib/Makefile b/lib/Makefile
|
|
||||||
index a2dba5939931..8dfa308cc45e 100644
|
|
||||||
--- a/lib/Makefile
|
|
||||||
+++ b/lib/Makefile
|
|
||||||
@@ -48,6 +48,9 @@ CFLAGS = -pthread -I./ -D_GNU_SOURCE \
|
|
||||||
ifneq ($(EXTRA_CFLAGS),)
|
|
||||||
CFLAGS += $(EXTRA_CFLAGS)
|
|
||||||
endif
|
|
||||||
+ifneq ($(EXTRA_LDFLAGS),)
|
|
||||||
+LDFLAGS += $(EXTRA_LDFLAGS)
|
|
||||||
+endif
|
|
||||||
|
|
||||||
DOXY_DIRS = doc_api doc_lib
|
|
||||||
|
|
||||||
diff --git a/pqos/Makefile b/pqos/Makefile
|
|
||||||
index dc5cc1a1744e..0f1a26f5a0f7 100644
|
|
||||||
--- a/pqos/Makefile
|
|
||||||
+++ b/pqos/Makefile
|
|
||||||
@@ -47,6 +47,9 @@ CFLAGS = -I$(LIBDIR) \
|
|
||||||
ifneq ($(EXTRA_CFLAGS),)
|
|
||||||
CFLAGS += $(EXTRA_CFLAGS)
|
|
||||||
endif
|
|
||||||
+ifneq ($(EXTRA_LDFLAGS),)
|
|
||||||
+LDFLAGS += $(EXTRA_LDFLAGS)
|
|
||||||
+endif
|
|
||||||
|
|
||||||
# ICC and GCC options
|
|
||||||
ifeq ($(CC),icc)
|
|
||||||
diff --git a/rdtset/Makefile b/rdtset/Makefile
|
|
||||||
index d1f283093c4f..2e9939af8b20 100644
|
|
||||||
--- a/rdtset/Makefile
|
|
||||||
+++ b/rdtset/Makefile
|
|
||||||
@@ -48,6 +48,9 @@ CFLAGS = -I$(LIBDIR) \
|
|
||||||
ifneq ($(EXTRA_CFLAGS),)
|
|
||||||
CFLAGS += $(EXTRA_CFLAGS)
|
|
||||||
endif
|
|
||||||
+ifneq ($(EXTRA_LDFLAGS),)
|
|
||||||
+LDFLAGS += $(EXTRA_LDFLAGS)
|
|
||||||
+endif
|
|
||||||
|
|
||||||
# ICC and GCC options
|
|
||||||
ifeq ($(CC),icc)
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,4 +1,4 @@
|
|||||||
# Copyright (c) 2016-2018, Intel Corporation
|
# Copyright (c) 2016-2020, Intel Corporation
|
||||||
#
|
#
|
||||||
# Redistribution and use in source and binary forms, with or without
|
# Redistribution and use in source and binary forms, with or without
|
||||||
# modification, are permitted provided that the following conditions are met:
|
# modification, are permitted provided that the following conditions are met:
|
||||||
@ -24,7 +24,7 @@
|
|||||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
%global githubname intel-cmt-cat
|
%global githubname intel-cmt-cat
|
||||||
%global githubver 2.0.0
|
%global githubver 4.0.0
|
||||||
|
|
||||||
%if %{defined githubsubver}
|
%if %{defined githubsubver}
|
||||||
%global githubfull %{githubname}-%{githubver}.%{githubsubver}
|
%global githubfull %{githubname}-%{githubver}.%{githubsubver}
|
||||||
@ -38,10 +38,9 @@
|
|||||||
|
|
||||||
Summary: Provides command line interface to CMT, MBM, CAT, CDP and MBA technologies
|
Summary: Provides command line interface to CMT, MBM, CAT, CDP and MBA technologies
|
||||||
Name: %{githubname}
|
Name: %{githubname}
|
||||||
Release: 2%{?dist}
|
Release: 0%{?dist}
|
||||||
Version: %{githubver}
|
Version: %{githubver}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/Tools
|
|
||||||
ExclusiveArch: x86_64 i686 i586
|
ExclusiveArch: x86_64 i686 i586
|
||||||
%if %{defined githubsubver}
|
%if %{defined githubsubver}
|
||||||
Source: https://github.com/01org/%{githubname}/archive/v%{githubver}.%{githubsubver}.tar.gz
|
Source: https://github.com/01org/%{githubname}/archive/v%{githubver}.%{githubsubver}.tar.gz
|
||||||
@ -50,9 +49,6 @@ Source: https://github.com/01org/%{githubname}/archive/v%{githubver}
|
|||||||
%endif
|
%endif
|
||||||
URL: https://github.com/01org/%{githubname}
|
URL: https://github.com/01org/%{githubname}
|
||||||
BuildRequires: gcc, make
|
BuildRequires: gcc, make
|
||||||
Patch1: 0001-make-Adding-LDFLAGS-to-the-libpqos-build-command.patch
|
|
||||||
Patch2: 0002-make-Add-support-to-add-flags-to-LDFLAGS-via-EXTRA_L.patch
|
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This software package provides basic support for
|
This software package provides basic support for
|
||||||
@ -72,7 +68,6 @@ it requires root privileges.
|
|||||||
Summary: Library and sample code to use CMT, MBM, CAT, CDP and MBA technologies
|
Summary: Library and sample code to use CMT, MBM, CAT, CDP and MBA technologies
|
||||||
License: BSD
|
License: BSD
|
||||||
Requires: intel-cmt-cat == %{version}
|
Requires: intel-cmt-cat == %{version}
|
||||||
Group: Development/Tools
|
|
||||||
ExclusiveArch: x86_64 i686 i586
|
ExclusiveArch: x86_64 i686 i586
|
||||||
|
|
||||||
%description -n intel-cmt-cat-devel
|
%description -n intel-cmt-cat-devel
|
||||||
@ -86,14 +81,12 @@ For additional information please refer to:
|
|||||||
https://github.com/01org/%{githubname}
|
https://github.com/01org/%{githubname}
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -n %{githubfull} -p1
|
%autosetup -n %{githubfull}
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" EXTRA_LDFLAGS="%{__global_ldflags}"
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
# Not doing make install as it strips the symbols.
|
# Not doing make install as it strips the symbols.
|
||||||
@ -122,7 +115,7 @@ install -m 0644 %{_builddir}/%{githubfull}/LICENSE %{buildroot}/%{_licensedir}/%
|
|||||||
install -d %{buildroot}/%{_libdir}
|
install -d %{buildroot}/%{_libdir}
|
||||||
install -s %{_builddir}/%{githubfull}/lib/libpqos.so.* %{buildroot}/%{_libdir}
|
install -s %{_builddir}/%{githubfull}/lib/libpqos.so.* %{buildroot}/%{_libdir}
|
||||||
cp -a %{_builddir}/%{githubfull}/lib/libpqos.so %{buildroot}/%{_libdir}
|
cp -a %{_builddir}/%{githubfull}/lib/libpqos.so %{buildroot}/%{_libdir}
|
||||||
cp -a %{_builddir}/%{githubfull}/lib/libpqos.so.2 %{buildroot}/%{_libdir}
|
cp -a %{_builddir}/%{githubfull}/lib/libpqos.so.4 %{buildroot}/%{_libdir}
|
||||||
|
|
||||||
# Install the header file
|
# Install the header file
|
||||||
install -d %{buildroot}/%{_includedir}
|
install -d %{buildroot}/%{_includedir}
|
||||||
@ -134,11 +127,13 @@ install -m 0644 %{_builddir}/%{githubfull}/LICENSE %{buildroot}/%{_usrsrc}/%{git
|
|||||||
|
|
||||||
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c
|
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c
|
||||||
|
|
||||||
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT
|
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT/Makefile %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/Makefile %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT/reset_app.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/reset_app.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT/allocation_app.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/allocation_app_l2cat.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT/association_app.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/allocation_app_l3cat.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/allocation_app_mba.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CAT_MBA/association_app.c %{buildroot}/%{_usrsrc}/%{githubfull}/c/CAT_MBA
|
||||||
|
|
||||||
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c/CMT_MBM
|
install -d %{buildroot}/%{_usrsrc}/%{githubfull}/c/CMT_MBM
|
||||||
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CMT_MBM/Makefile %{buildroot}/%{_usrsrc}/%{githubfull}/c/CMT_MBM
|
install -m 0644 %{_builddir}/%{githubfull}/examples/c/CMT_MBM/Makefile %{buildroot}/%{_usrsrc}/%{githubfull}/c/CMT_MBM
|
||||||
@ -161,17 +156,26 @@ install -m 0644 %{_builddir}/%{githubfull}/examples/c/CMT_MBM/monitor_app.c %{bu
|
|||||||
|
|
||||||
%files -n intel-cmt-cat-devel
|
%files -n intel-cmt-cat-devel
|
||||||
%{_libdir}/libpqos.so
|
%{_libdir}/libpqos.so
|
||||||
%{_libdir}/libpqos.so.2
|
%{_libdir}/libpqos.so.4
|
||||||
%{_includedir}/pqos.h
|
%{_includedir}/pqos.h
|
||||||
%{_usrsrc}/%{githubfull}/c/CAT/Makefile
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/Makefile
|
||||||
%{_usrsrc}/%{githubfull}/c/CAT/reset_app.c
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/reset_app.c
|
||||||
%{_usrsrc}/%{githubfull}/c/CAT/association_app.c
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/association_app.c
|
||||||
%{_usrsrc}/%{githubfull}/c/CAT/allocation_app.c
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/allocation_app_l2cat.c
|
||||||
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/allocation_app_l3cat.c
|
||||||
|
%{_usrsrc}/%{githubfull}/c/CAT_MBA/allocation_app_mba.c
|
||||||
%{_usrsrc}/%{githubfull}/c/CMT_MBM/Makefile
|
%{_usrsrc}/%{githubfull}/c/CMT_MBM/Makefile
|
||||||
%{_usrsrc}/%{githubfull}/c/CMT_MBM/monitor_app.c
|
%{_usrsrc}/%{githubfull}/c/CMT_MBM/monitor_app.c
|
||||||
%doc %{_usrsrc}/%{githubfull}/LICENSE
|
%doc %{_usrsrc}/%{githubfull}/LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 12 2020 Jiri Olsa <jolsa@redhat.com> - 4.0.0-0
|
||||||
|
- New release 4.0.0
|
||||||
|
|
||||||
|
* Thu Jun 11 2020 Martin Cermak <mcermak@redhat.com> - 2.0.0-3
|
||||||
|
- NVR bump and rebuild because of CI gating.
|
||||||
|
Related: #1682388
|
||||||
|
|
||||||
* Mon Oct 08 2018 Jiri Olsa <jolsa@redhat.com> - 2.0.0-2
|
* Mon Oct 08 2018 Jiri Olsa <jolsa@redhat.com> - 2.0.0-2
|
||||||
- New release 2.0.0-2
|
- New release 2.0.0-2
|
||||||
- passing distro CFLAGS/LDFLAGS
|
- passing distro CFLAGS/LDFLAGS
|
||||||
|
Loading…
Reference in New Issue
Block a user