This commit is contained in:
Bill Nottingham 2012-12-07 16:16:28 -05:00
parent ff31925b49
commit ce34f2bef7
6 changed files with 11 additions and 214 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/initscripts-9.42.tar.bz2
/initscripts-9.43.tar.bz2

View File

@ -1,40 +0,0 @@
From a1f80c69c76070e33bd2c0228738115f2c9c1473 Mon Sep 17 00:00:00 2001
From: Jiri Popelka <jpopelka@redhat.com>
Date: Fri, 5 Oct 2012 16:57:32 +0200
Subject: [PATCH] Fix calling of firewall-cmd in ifup-post/ifdown-post.
firewall-cmd has been using combined longopts since 0.2.6
---
sysconfig/network-scripts/ifdown-post | 2 +-
sysconfig/network-scripts/ifup-post | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/sysconfig/network-scripts/ifdown-post b/sysconfig/network-scripts/ifdown-post
index 68354de..bcf4765 100755
--- a/sysconfig/network-scripts/ifdown-post
+++ b/sysconfig/network-scripts/ifdown-post
@@ -48,7 +48,7 @@ fi
# Inform firewall
if [ -x /usr/bin/firewall-cmd -a "${REALDEVICE}" != "lo" ]; then
- /usr/bin/firewall-cmd --remove --interface="${DEVICE}" > /dev/null 2>&1
+ /usr/bin/firewall-cmd --remove-interface="${DEVICE}" > /dev/null 2>&1
fi
# Notify programs that have requested notification
diff --git a/sysconfig/network-scripts/ifup-post b/sysconfig/network-scripts/ifup-post
index 1ebb9c2..ca14acf 100755
--- a/sysconfig/network-scripts/ifup-post
+++ b/sysconfig/network-scripts/ifup-post
@@ -95,7 +95,7 @@ fi
# Inform firewall which network zone (empty means default) this interface belongs to
if [ -x /usr/bin/firewall-cmd -a "${REALDEVICE}" != "lo" ]; then
- /usr/bin/firewall-cmd --zone="${ZONE}" --change --interface="${DEVICE}" > /dev/null 2>&1
+ /usr/bin/firewall-cmd --zone="${ZONE}" --change-interface="${DEVICE}" > /dev/null 2>&1
fi
# Notify programs that have requested notification
--
1.7.11.4

View File

@ -1,147 +0,0 @@
commit 6091b58b60f532d8e3f317b99f7ea85d99853db3 (HEAD, master)
Author: Bill Nottingham <notting@redhat.com>
Date: Wed Oct 31 13:31:48 2012 -0400
Drop fedora-storage-init; conflict with older lvm & dmraid so we get the required versions that allow us to do so. (<prajnoha@redhat.com>)
diff --git a/Makefile b/Makefile
index e8f3fb5..233ab00 100644
--- a/Makefile
+++ b/Makefile
@@ -96,8 +96,6 @@ install:
ln -s ../fedora-autorelabel-mark.service $(ROOT)/lib/systemd/system/basic.target.wants
ln -s ../fedora-readonly.service $(ROOT)/lib/systemd/system/local-fs.target.wants
ln -s ../fedora-import-state.service $(ROOT)/lib/systemd/system/local-fs.target.wants
- ln -s ../fedora-storage-init.service $(ROOT)/lib/systemd/system/local-fs.target.wants
- ln -s ../fedora-storage-init-late.service $(ROOT)/lib/systemd/system/local-fs.target.wants
mkdir -p $(ROOT)/lib/tmpfiles.d
install -m 644 initscripts.tmpfiles.d $(ROOT)/lib/tmpfiles.d/initscripts.conf
diff --git a/initscripts.spec b/initscripts.spec
index 675debc..be577c9 100644
--- a/initscripts.spec
+++ b/initscripts.spec
@@ -18,6 +18,8 @@ Requires: bash >= 3.0
Requires: sysvinit-tools >= 2.87-5
Conflicts: systemd < 23-1
Conflicts: systemd-units < 23-1
+Conflicts: lvm2 < 2.02.98-3
+Conflicts: dmraid < 1.0.0.rc16-18
Requires: systemd
Requires: iproute, /sbin/arping, findutils
# Not strictly required, but nothing else requires it
diff --git a/systemd/fedora-storage-init b/systemd/fedora-storage-init
deleted file mode 100755
index 565d811..0000000
--- a/systemd/fedora-storage-init
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/bash
-#
-# Storage initialization
-
-. /etc/init.d/functions
-
-[ -z "${cmdline}" ] && cmdline=$(cat /proc/cmdline)
-
-if ! strstr "$cmdline" nompath && [ -f /etc/multipath.conf ] && \
- [ -x /sbin/multipath ]; then
- modprobe dm-multipath > /dev/null 2>&1
- /sbin/multipath -u -v 0
- if [ -x /sbin/kpartx ]; then
- /sbin/dmsetup ls --target multipath --exec "/sbin/kpartx -u -a -p p" >/dev/null
- fi
-fi
-
-if ! strstr "$cmdline" nodmraid && [ -x /sbin/dmraid ]; then
- modprobe dm-mirror >/dev/null 2>&1
- dmraidsets=$(LC_ALL=C /sbin/dmraid -s -c -i)
- if [ "$?" = "0" ]; then
- SAVEIFS=$IFS
- IFS=$(echo -en "\n\b")
- for dmname in $dmraidsets; do
- if [[ "$dmname" == isw_* ]] && \
- ! strstr "$cmdline" noiswmd; then
- continue
- fi
- /sbin/dmraid -ay -i --rm_partitions -p "$dmname" >/dev/null 2>&1
- /sbin/kpartx -u -a -p p "/dev/mapper/$dmname"
- done
- IFS=$SAVEIFS
- fi
-fi
-
-# Start any MD RAID arrays that haven't been started yet
-[ -r /proc/mdstat ] && [ -r /dev/md/md-device-map ] && /sbin/mdadm -IRs
-
-if [ -x /sbin/lvm ]; then
- action $"Setting up Logical Volume Management:" /sbin/lvm vgchange -a y --sysinit
-fi
diff --git a/systemd/system/fedora-storage-init-late.service b/systemd/system/fedora-storage-init-late.service
deleted file mode 100644
index 69ad089..0000000
--- a/systemd/system/fedora-storage-init-late.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Initialize storage subsystems (RAID, LVM, etc.)
-DefaultDependencies=no
-Conflicts=shutdown.target
-After=cryptsetup.target fedora-storage-init.service
-Before=local-fs.target shutdown.target
-Wants=fedora-wait-storage.service
-ConditionFileIsExecutable=|/sbin/lvm
-ConditionFileIsExecutable=|/sbin/dmraid
-ConditionPathExists=|/etc/multipath.conf
-
-[Service]
-ExecStart=/lib/systemd/fedora-storage-init
-Type=oneshot
-TimeoutSec=0
-RemainAfterExit=yes
diff --git a/systemd/system/fedora-storage-init.service b/systemd/system/fedora-storage-init.service
deleted file mode 100644
index 6d8e39f..0000000
--- a/systemd/system/fedora-storage-init.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Initialize storage subsystems (RAID, LVM, etc.)
-DefaultDependencies=no
-Conflicts=shutdown.target
-After=fedora-wait-storage.service
-Before=local-fs.target shutdown.target
-Wants=fedora-wait-storage.service
-ConditionFileIsExecutable=|/sbin/lvm
-ConditionFileIsExecutable=|/sbin/dmraid
-ConditionPathExists=|/etc/multipath.conf
-
-[Service]
-ExecStart=/lib/systemd/fedora-storage-init
-Type=oneshot
-TimeoutSec=0
-RemainAfterExit=yes
diff --git a/systemd/system/fedora-wait-storage.service b/systemd/system/fedora-wait-storage.service
deleted file mode 100644
index 9d3b6ae..0000000
--- a/systemd/system/fedora-wait-storage.service
+++ /dev/null
@@ -1,18 +0,0 @@
-[Unit]
-Description=Wait for storage scan
-DefaultDependencies=no
-Conflicts=shutdown.target
-After=systemd-udev-settle.service
-Before=local-fs.target shutdown.target
-Wants=systemd-udev-settle.service
-
-[Service]
-ExecStart=-/sbin/rmmod scsi_wait_scan
-ExecStart=-/sbin/modprobe scsi_wait_scan
-ExecStart=-/sbin/rmmod scsi_wait_scan
-Type=oneshot
-TimeoutSec=0
-RemainAfterExit=yes
-StandardInput=null
-StandardOutput=null
-StandardError=null

View File

@ -1,19 +0,0 @@
commit d7cc6f6b94ee125ec3642368493766d38992af10 (HEAD, origin/master, origin/HEAD, master)
Author: Bill Nottingham <notting@redhat.com>
Date: Mon Oct 8 16:20:56 2012 -0400
Don't pass -F to fixfiles (#863662, <dwalsh@redhat.com>)
diff --git a/systemd/fedora-autorelabel b/systemd/fedora-autorelabel
index 61dc551..689908a 100755
--- a/systemd/fedora-autorelabel
+++ b/systemd/fedora-autorelabel
@@ -27,7 +27,7 @@ relabel_selinux() {
echo $"*** Relabeling could take a very long time, depending on file"
echo $"*** system size and speed of hard drives."
- /sbin/fixfiles -F restore > /dev/null 2>&1
+ /sbin/fixfiles restore > /dev/null 2>&1
fi
rm -f /.autorelabel
systemctl --force reboot

View File

@ -1,10 +1,10 @@
Summary: The inittab file and the /etc/init.d scripts
Name: initscripts
Version: 9.42
Version: 9.43
# ppp-watch is GPLv2+, everything else is GPLv2
License: GPLv2 and GPLv2+
Group: System Environment/Base
Release: 2%{?dist}
Release: 1%{?dist}
URL: http://fedorahosted.org/releases/i/n/initscripts/
Source: http://fedorahosted.org/releases/i/n/initscripts/initscripts-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@ -32,7 +32,6 @@ Requires(pre): /usr/sbin/groupadd
Requires(post): /sbin/chkconfig, coreutils
Requires(preun): /sbin/chkconfig
BuildRequires: glib2-devel popt-devel gettext pkgconfig
Patch0: 6091b58.patch
%description
The initscripts package contains the basic system scripts used to boot
@ -53,7 +52,6 @@ Currently, this consists of various memory checking code.
%prep
%setup -q
%patch0 -p1
%build
make
@ -218,10 +216,13 @@ rm -rf $RPM_BUILD_ROOT
/etc/profile.d/debug*
%changelog
* Thu Nov 1 2012 Peter Rajnoha <prajnoha@redhat.com> - 9.42-2
- add Conflicts: lvm2 < 2.02.98-3 and2 Conflicts: dmraid < 1.0.0.rc16-18
as these new packages ship parts of the fedora-storage-init functionality
- remove obsolete fedora-storage-init script and respective systemd units
* Fri Dec 7 2012 Bill Nottingham <notting@redhat.com> - 9.43-1
- 60-net.rules: explicitly set the interface name (#870859)
- ifup-eth: set firewall zone before ifup-ipv6 for DHCPv6 (#802415)
- migrate to /etc/locale.conf, /etc/vconsole.conf (#881923)
- rename_device: fix bogus locking
- fix wireless device detection for kernel 3.6 (#875328)
- drop fedora-storage-init, fedora-wait-storage (<prajinoha@redhat.com>)
* Wed Oct 31 2012 Bill Nottingham <notting@redhat.com> - 9.42-1
- Halloween release!

View File

@ -1 +1,2 @@
d5bde672cc94973cd8af8ac0354dbe8f initscripts-9.42.tar.bz2
a225c9b7b0786e395b38a4d919e7d72f initscripts-9.43.tar.bz2