9.44-1
This commit is contained in:
parent
a29438ae63
commit
74a8b609bd
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/initscripts-9.43.tar.bz2
|
||||
/initscripts-9.44.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
commit 65173d72f1a662a8596aa0e14232556ba40e452f (origin/master, origin/HEAD, master)
|
||||
Author: Bill Nottingham <notting@redhat.com>
|
||||
Date: Fri Dec 7 16:21:59 2012 -0500
|
||||
|
||||
Fix build.
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 1c6bce8..c6fc7a0 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,7 @@ install:
|
||||
install -m644 adjtime $(ROOT)/etc
|
||||
install -m644 inittab $(ROOT)/etc
|
||||
install -m644 rwtab statetab networks $(ROOT)/etc
|
||||
+ install -m755 service $(ROOT)/sbin
|
||||
install -m644 lang.csh lang.sh $(ROOT)/etc/profile.d
|
||||
install -m644 term256.csh term256.sh $(ROOT)/etc/profile.d
|
||||
install -m644 debug.csh debug.sh $(ROOT)/etc/profile.d
|
||||
diff --git a/initscripts.spec b/initscripts.spec
|
||||
index ce34c7f..c7f3a1c 100644
|
||||
--- a/initscripts.spec
|
||||
+++ b/initscripts.spec
|
||||
@@ -175,7 +175,6 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%exclude /etc/profile.d/debug*
|
||||
/etc/profile.d/*
|
||||
/usr/sbin/sys-unconfig
|
||||
-/sbin/setsysfont
|
||||
/bin/ipcalc
|
||||
/bin/usleep
|
||||
%attr(4755,root,root) /usr/sbin/usernetctl
|
@ -1,10 +1,10 @@
|
||||
Summary: The inittab file and the /etc/init.d scripts
|
||||
Name: initscripts
|
||||
Version: 9.43
|
||||
Version: 9.44
|
||||
# ppp-watch is GPLv2+, everything else is GPLv2
|
||||
License: GPLv2 and GPLv2+
|
||||
Group: System Environment/Base
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
URL: http://fedorahosted.org/releases/i/n/initscripts/
|
||||
Source: http://fedorahosted.org/releases/i/n/initscripts/initscripts-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
@ -32,7 +32,6 @@ Requires(pre): /usr/sbin/groupadd
|
||||
Requires(post): /sbin/chkconfig, coreutils
|
||||
Requires(preun): /sbin/chkconfig
|
||||
BuildRequires: glib2-devel popt-devel gettext pkgconfig
|
||||
Patch1: 65173d7.patch
|
||||
|
||||
%description
|
||||
The initscripts package contains the basic system scripts used to boot
|
||||
@ -53,7 +52,6 @@ Currently, this consists of various memory checking code.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
make
|
||||
@ -107,7 +105,7 @@ exit 0
|
||||
|
||||
%postun
|
||||
if [ $1 -ge 1 ]; then
|
||||
/bin/systemctl daemon-reload > /dev/null 2>&1 || :
|
||||
/bin/systemctl daemon-reload > /dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%clean
|
||||
@ -209,6 +207,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/crypttab
|
||||
%dir /lib/tmpfiles.d
|
||||
/lib/tmpfiles.d/initscripts.conf
|
||||
%dir /usr/libexec/initscripts
|
||||
%dir /usr/libexec/initscripts/legacy-actions
|
||||
|
||||
%files -n debugmode
|
||||
@ -217,8 +216,29 @@ rm -rf $RPM_BUILD_ROOT
|
||||
/etc/profile.d/debug*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 9.43-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
* Wed Feb 20 2013 Lukáš Nykrýn <lnykryn@redhat.com> - 9.44-1
|
||||
- limit udev rule for network renaming (#907365, mschmidt@redhat.com)
|
||||
- fix path for arpwatch, seems to be in /var/lib on Fedora 18
|
||||
- fix the path for lvm cache, there is no file /etc/lvm/.cache ( but there is one /etc/lvm/cache )
|
||||
- fix path for dhcpd, is /var/lib/dhcpd since 2005 ( see 31cdb58df77 on the dhcp package git )
|
||||
- fix the patch for apache modules in rwtab, that are now in /var/cache/httpd
|
||||
- remove no longer used directory ( at least in Fedora ), hald is deprecated,
|
||||
/var/tux cannot be found and xend seems to use a subdirectory of /var/lib/xen
|
||||
- correct the path for puppet directory in /etc/rwtab, now use /var/lib/puppet by default
|
||||
- allow passing -F from /.autorelabel to fixfiles when relabeling system (#904279)
|
||||
- correctly detect Open vSwitch device types
|
||||
- clear DEVICE and TYPE variables before every iteration (#902463)
|
||||
- sets BONDING_OPTS before interface is brougth up
|
||||
- check an IP address for existence in ifup-alias (#852005)
|
||||
- sync FSF address with GPL 2 text.
|
||||
- fix rpmlint's spaces vs tabs warning.
|
||||
- fix bogus %changelog dates.
|
||||
- build with $RPM_LD_FLAGS.
|
||||
- use -sf, not -s. (#901827)
|
||||
- add /usr/libexec/initscripts to file list (#894475)
|
||||
- rename term256 to 256term (glob sort) (#849429)
|
||||
- readd missing shebang. (#885821)
|
||||
- migrate even further away from /etc/sysconfig/network for hostname, and /etc/sysconfig/i18n.
|
||||
|
||||
* Fri Dec 7 2012 Bill Nottingham <notting@redhat.com> - 9.43-1
|
||||
- 60-net.rules: explicitly set the interface name (#870859)
|
||||
@ -1448,7 +1468,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Thu Oct 07 2004 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- change /etc/sysctl.conf to not allow source routed packets per default
|
||||
|
||||
* Fri Oct 6 2004 Bill Nottingham <notting@redhat.com> - 7.88-1
|
||||
* Wed Oct 6 2004 Bill Nottingham <notting@redhat.com> - 7.88-1
|
||||
- fix requires
|
||||
|
||||
* Tue Oct 5 2004 Dan Walsh <dwalsh@redhat.com> - 7.87-1
|
||||
@ -1546,7 +1566,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Tue Aug 24 2004 Karsten Hopp <karsten@redhat.de> 7.68-1
|
||||
- execute zfcfconf.sh if available (mainframe)
|
||||
|
||||
* Mon Aug 20 2004 Jason Vas Dias <jvdias@redhat.com> 7.67-1
|
||||
* Mon Aug 23 2004 Jason Vas Dias <jvdias@redhat.com> 7.67-1
|
||||
- fix change_resolv_conf: if pre-existing /etc/resolv.conf
|
||||
- non-existent or empty, replace with new file contents.
|
||||
|
||||
@ -1579,7 +1599,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- fix nfs unmounting (#129765)
|
||||
- fix URL (#129433)
|
||||
|
||||
* Tue Aug 11 2004 Jason Vas Dias <jvdias@redhat.com> 7.61-1
|
||||
* Wed Aug 11 2004 Jason Vas Dias <jvdias@redhat.com> 7.61-1
|
||||
- fix for bug 120093: add PERSISTENT_DHCLIENT option to ifcfg files
|
||||
|
||||
* Tue Aug 3 2004 Karsten Hopp <karsten@redhat.de> 7.60-1
|
||||
@ -1923,7 +1943,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- loop checking for network link state, don't unilterally wait five
|
||||
seconds
|
||||
|
||||
* Fri Dec 14 2002 Karsten Hopp <karsten@redhat.de> 6.99-1
|
||||
* Sat Dec 14 2002 Karsten Hopp <karsten@redhat.de> 6.99-1
|
||||
- remove call to /sbin/update for S/390, too
|
||||
|
||||
* Wed Dec 11 2002 Bill Nottingham <notting@redhat.com> 6.98-1
|
||||
@ -2276,7 +2296,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Mon Jul 16 2001 Than Ngo <than@redhat.com>
|
||||
- fix country_code for ISDN
|
||||
|
||||
* Tue Jul 9 2001 Bill Nottingham <notting@redhat.com>
|
||||
* Mon Jul 9 2001 Bill Nottingham <notting@redhat.com>
|
||||
- fix '--check'
|
||||
- prereq sh-utils (#43065)
|
||||
- fix some invocations of reboot/halt (#45966)
|
||||
@ -2292,7 +2312,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Fix up kernel versioning on binary-only modules (S390)
|
||||
- don't use newt scripts on S390 console
|
||||
|
||||
* Sat Jul 01 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Sun Jul 01 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- reenable pump, but make sure dhcpcd is the default. This
|
||||
way, upgrades of systems without dhcpcd has a better chance at
|
||||
working.
|
||||
@ -2530,7 +2550,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Tue Aug 15 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||
- be more careful about creating files in netreport (#16164)
|
||||
|
||||
* Sat Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||
* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||
- move documentation for the DEMAND and IDLETIMEOUT values to the right
|
||||
section of sysconfig.txt
|
||||
|
||||
@ -2599,7 +2619,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Sun Jul 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- don't use tail
|
||||
|
||||
* Thu Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- add support for USB controllers and HID devices
|
||||
(mice, keyboards)
|
||||
|
||||
@ -2641,7 +2661,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- fix lang.csh, again (oops)
|
||||
- use /poweroff, /halt to determine whether to poweroff
|
||||
|
||||
* Thu Apr 14 2000 Bill Nottingham <notting@redhat.com>
|
||||
* Fri Apr 14 2000 Bill Nottingham <notting@redhat.com>
|
||||
- fix testing of RESOLV_MODS (which shouldn't be used anyways)
|
||||
|
||||
* Tue Apr 04 2000 Ngo Than <than@redhat.de>
|
||||
@ -2745,7 +2765,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- better signal handling in ppp-watch
|
||||
- yet another attempt to fix those rare PAP/CHAP problems
|
||||
|
||||
* Sat Nov 28 1999 Bill Nottingham <notting@redhat.com>
|
||||
* Sun Nov 28 1999 Bill Nottingham <notting@redhat.com>
|
||||
- impressive. Three new features, three new bugs.
|
||||
|
||||
* Mon Nov 22 1999 Michael K. Johnson <johnsonm@redhat.com>
|
||||
@ -3018,7 +3038,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Tue Nov 10 1998 Michael K. Johnson <johnsonm@redhat.com>
|
||||
- handle new linuxconf output for ipaliases
|
||||
|
||||
* Mon Oct 15 1998 Erik Troan <ewt@redhat.com>
|
||||
* Thu Oct 15 1998 Erik Troan <ewt@redhat.com>
|
||||
- fixed raid start stuff
|
||||
- added raidstop to halt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user