imath/imath-docs.patch

46 lines
1.7 KiB
Diff

Index: Imath-3.1.3/docs/CMakeLists.txt
===================================================================
--- Imath-3.1.3.orig/docs/CMakeLists.txt
+++ Imath-3.1.3/docs/CMakeLists.txt
@@ -23,11 +23,10 @@ file(MAKE_DIRECTORY ${DOXYGEN_OUTPUT_DIR
add_custom_command(OUTPUT ${DOXYGEN_INDEX_FILE}
COMMAND ${DOXYGEN_EXECUTABLE} ${DOXYFILE_OUT}
MAIN_DEPENDENCY ${DOXYFILE_OUT} ${DOXYFILE_IN}
+ DEPENDS ${DOXYGEN_OUTPUT_DIR}
COMMENT "Running doxygen"
VERBATIM)
-add_custom_target(Doxygen ALL DEPENDS ${DOXYGEN_INDEX_FILE})
-
add_custom_command(OUTPUT ${SPHINX_INDEX_FILE}
COMMAND
${SPHINX_EXECUTABLE} -b html
@@ -39,9 +38,11 @@ add_custom_command(OUTPUT ${SPHINX_INDEX
MAIN_DEPENDENCY conf.py
COMMENT "Generating documentation with Sphinx")
-add_custom_target(Sphinx ALL DEPENDS ${SPHINX_INDEX_FILE})
+add_custom_target(docs ALL DEPENDS ${SPHINX_INDEX_FILE} ${DOXYGEN_INDEX_FILE})
# Add an install target to install the docs
-include(GNUInstallDirs)
-install(DIRECTORY ${SPHINX_BUILD}
-DESTINATION ${CMAKE_INSTALL_DOCDIR})
+if(INSTALL_DOCS)
+ include(GNUInstallDirs)
+ install(DIRECTORY ${SPHINX_BUILD}
+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+endif()
Index: Imath-3.1.3/CMakeLists.txt
===================================================================
--- Imath-3.1.3.orig/CMakeLists.txt
+++ Imath-3.1.3/CMakeLists.txt
@@ -75,6 +75,7 @@ endif()
option(DOCS "Set ON to build html documentation")
if (DOCS)
+ option(INSTALL_DOCS "Set ON to install html documentation" ON)
add_subdirectory(docs)
endif()