Update to 3.1.3.

This commit is contained in:
Richard Shaw 2021-10-24 09:55:31 -05:00
parent c3e408c84b
commit c94e3f8c65
2 changed files with 42 additions and 12 deletions

28
imath-docs.patch Normal file
View File

@ -0,0 +1,28 @@
Index: Imath-3.1.3/docs/CMakeLists.txt
===================================================================
--- Imath-3.1.3.orig/docs/CMakeLists.txt
+++ Imath-3.1.3/docs/CMakeLists.txt
@@ -42,6 +42,8 @@ add_custom_command(OUTPUT ${SPHINX_INDEX
add_custom_target(Sphinx ALL DEPENDS ${SPHINX_INDEX_FILE})
# Add an install target to install the docs
-include(GNUInstallDirs)
-install(DIRECTORY ${SPHINX_BUILD}
-DESTINATION ${CMAKE_INSTALL_DOCDIR})
+if(INSTALL_DOCS)
+ include(GNUInstallDirs)
+ install(DIRECTORY ${SPHINX_BUILD}
+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+endif()
Index: Imath-3.1.3/CMakeLists.txt
===================================================================
--- Imath-3.1.3.orig/CMakeLists.txt
+++ Imath-3.1.3/CMakeLists.txt
@@ -75,6 +75,7 @@ endif()
option(DOCS "Set ON to build html documentation")
if (DOCS)
+ option(INSTALL_DOCS "Set ON to install html documentation" ON)
add_subdirectory(docs)
endif()

View File

@ -3,7 +3,7 @@
%global pyver_under %(%{python3} -Esc "import sys; sys.stdout.write('{0.major}_{0.minor}'.format(sys.version_info))") %global pyver_under %(%{python3} -Esc "import sys; sys.stdout.write('{0.major}_{0.minor}'.format(sys.version_info))")
Name: imath Name: imath
Version: 3.1.2 Version: 3.1.3
Release: 1%{?dist} Release: 1%{?dist}
Summary: Library of 2D and 3D vector, matrix, and math operations for computer graphics Summary: Library of 2D and 3D vector, matrix, and math operations for computer graphics
@ -14,6 +14,7 @@ Source0: https://github.com/AcademySoftwareFoundation/%{srcname}/archive/
Patch0: imath-python-test.patch Patch0: imath-python-test.patch
# https://github.com/AcademySoftwareFoundation/Imath/pull/209 # https://github.com/AcademySoftwareFoundation/Imath/pull/209
Patch1: https://github.com/AcademySoftwareFoundation/Imath/pull/209.patch Patch1: https://github.com/AcademySoftwareFoundation/Imath/pull/209.patch
Patch2: imath-docs.patch
BuildRequires: cmake BuildRequires: cmake
@ -57,23 +58,21 @@ Requires: python3-devel
%build %build
%cmake -DPYTHON=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} %cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
%cmake_build -DPYTHON=ON \
-DDOCS=ON \
-DINSTALL_DOCS=OFF
# Generate man docs %cmake_build
cd docs
# https://github.com/AcademySoftwareFoundation/Imath/issues/196#issuecomment-896433898
rm classes/half.rst
doxygen
cd ..
PYTHONPATH=${PWD} sphinx-build-3 docs/ html
# Remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}
%install %install
%cmake_install %cmake_install
# Fixup documentation so it can get installed correctly in imath-devel
rm -rf %{__cmake_builddir}/docs/sphinx/.{doctrees,buildinfo}
mv %{__cmake_builddir}/docs/sphinx ./html
%check %check
%ctest %ctest
@ -101,6 +100,9 @@ rm -rf html/.{doctrees,buildinfo}
%changelog %changelog
* Sun Oct 24 2021 Richard Shaw <hobbes1069@gmail.com> - 3.1.3-1
- Update to 3.1.3.
* Wed Aug 11 2021 Josef Ridky <jridky@redhat.com> - 3.1.2-1 * Wed Aug 11 2021 Josef Ridky <jridky@redhat.com> - 3.1.2-1
- New upstream release 3.1.2 - New upstream release 3.1.2