Import rpm: c8s
This commit is contained in:
commit
18bf8b04c0
10
.gitignore
vendored
Normal file
10
.gitignore
vendored
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
SOURCES/gccmakedep-1.0.3.tar.bz2
|
||||||
|
SOURCES/imake-1.0.7.tar.bz2
|
||||||
|
SOURCES/lndir-1.0.3.tar.bz2
|
||||||
|
SOURCES/makedepend-1.0.4.tar.bz2
|
||||||
|
SOURCES/xorg-cf-files-1.0.6.tar.bz2
|
||||||
|
/gccmakedep-1.0.3.tar.bz2
|
||||||
|
/imake-1.0.7.tar.bz2
|
||||||
|
/lndir-1.0.3.tar.bz2
|
||||||
|
/makedepend-1.0.4.tar.bz2
|
||||||
|
/xorg-cf-files-1.0.6.tar.bz2
|
18
imake-1.0.2-abort.patch
Normal file
18
imake-1.0.2-abort.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -up imake-1.0.2/imake.c.jx imake-1.0.2/imake.c
|
||||||
|
--- imake-1.0.2/imake.c.jx 2006-05-15 16:28:14.000000000 -0400
|
||||||
|
+++ imake-1.0.2/imake.c 2010-10-25 17:14:37.000000000 -0400
|
||||||
|
@@ -1030,8 +1030,12 @@ get_libc_version(FILE *inFile)
|
||||||
|
|
||||||
|
len = pclose (fp);
|
||||||
|
remove (aout);
|
||||||
|
- if (len)
|
||||||
|
- abort ();
|
||||||
|
+ if (len) {
|
||||||
|
+ /* handwave furiously */
|
||||||
|
+ printf("#define DefaultLinuxCLibMajorVersion 6\n");
|
||||||
|
+ printf("#define DefaultLinuxCLibMinorVersion 12\n");
|
||||||
|
+ printf("#define DefaultLinuxCLibTeenyVersion 0\n");
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
164
imake.spec
Normal file
164
imake.spec
Normal file
@ -0,0 +1,164 @@
|
|||||||
|
Summary: imake source code configuration and build system
|
||||||
|
Name: imake
|
||||||
|
Version: 1.0.7
|
||||||
|
Release: 11%{?dist}
|
||||||
|
License: MIT
|
||||||
|
Group: User Interface/X
|
||||||
|
URL: http://www.x.org
|
||||||
|
|
||||||
|
Source0: https://www.x.org/pub/individual/util/imake-1.0.7.tar.bz2
|
||||||
|
Source1: https://www.x.org/pub/individual/util/makedepend-1.0.4.tar.bz2
|
||||||
|
Source2: https://www.x.org/pub/individual/util/gccmakedep-1.0.3.tar.bz2
|
||||||
|
Source3: https://www.x.org/pub/individual/util/xorg-cf-files-1.0.6.tar.bz2
|
||||||
|
Source4: https://www.x.org/pub/individual/util/lndir-1.0.3.tar.bz2
|
||||||
|
# this has been merged post 1.0.6
|
||||||
|
Patch2: xorg-cf-files-1.0.2-redhat.patch
|
||||||
|
Patch11: imake-1.0.2-abort.patch
|
||||||
|
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: xorg-x11-util-macros
|
||||||
|
BuildRequires: xorg-x11-proto-devel
|
||||||
|
|
||||||
|
Provides: ccmakedep cleanlinks gccmakedep lndir makedepend makeg
|
||||||
|
Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
|
||||||
|
|
||||||
|
%description
|
||||||
|
Imake is a deprecated source code configuration and build system which
|
||||||
|
has traditionally been supplied by and used to build the X Window System
|
||||||
|
in X11R6 and previous releases. As of the X Window System X11R7 release,
|
||||||
|
the X Window system has switched to using GNU autotools as the primary
|
||||||
|
build system, and the Imake system is now deprecated, and should not be
|
||||||
|
used by new software projects. Software developers are encouraged to
|
||||||
|
migrate software to the GNU autotools system.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
|
||||||
|
%patch2 -p0 -b .redhat
|
||||||
|
|
||||||
|
# imake patches
|
||||||
|
pushd %{name}-%{version}
|
||||||
|
%patch11 -p1 -b .abort
|
||||||
|
popd
|
||||||
|
|
||||||
|
%build
|
||||||
|
# Build everything
|
||||||
|
{
|
||||||
|
for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
|
||||||
|
pushd $pkg-*
|
||||||
|
case $pkg in
|
||||||
|
imake|xorg-cf-files)
|
||||||
|
%configure --with-config-dir=%{_datadir}/X11/config
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
%configure
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
make
|
||||||
|
popd
|
||||||
|
done
|
||||||
|
}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
# Install everything
|
||||||
|
{
|
||||||
|
for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
|
||||||
|
pushd $pkg-*
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
popd
|
||||||
|
done
|
||||||
|
}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc
|
||||||
|
%{_bindir}/ccmakedep
|
||||||
|
%{_bindir}/cleanlinks
|
||||||
|
%{_bindir}/gccmakedep
|
||||||
|
%{_bindir}/imake
|
||||||
|
%{_bindir}/lndir
|
||||||
|
%{_bindir}/makedepend
|
||||||
|
%{_bindir}/makeg
|
||||||
|
%{_bindir}/mergelib
|
||||||
|
%{_bindir}/mkdirhier
|
||||||
|
%{_bindir}/mkhtmlindex
|
||||||
|
%{_bindir}/revpath
|
||||||
|
%{_bindir}/xmkmf
|
||||||
|
%dir %{_datadir}/X11/config
|
||||||
|
%{_datadir}/X11/config/*.cf
|
||||||
|
%{_datadir}/X11/config/*.def
|
||||||
|
%{_datadir}/X11/config/*.rules
|
||||||
|
%{_datadir}/X11/config/*.tmpl
|
||||||
|
#%%dir %%{_mandir}/man1x
|
||||||
|
%{_mandir}/man1/ccmakedep.1*
|
||||||
|
%{_mandir}/man1/cleanlinks.1*
|
||||||
|
%{_mandir}/man1/gccmakedep.1*
|
||||||
|
%{_mandir}/man1/imake.1*
|
||||||
|
%{_mandir}/man1/lndir.1*
|
||||||
|
%{_mandir}/man1/makedepend.1*
|
||||||
|
%{_mandir}/man1/makeg.1*
|
||||||
|
%{_mandir}/man1/mergelib.1*
|
||||||
|
%{_mandir}/man1/mkdirhier.1*
|
||||||
|
%{_mandir}/man1/mkhtmlindex.1*
|
||||||
|
%{_mandir}/man1/revpath.1*
|
||||||
|
%{_mandir}/man1/xmkmf.1*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jul 05 2018 Adam Jackson <ajax@redhat.com> - 1.0.7-11
|
||||||
|
- xorg-cf-files 1.0.6
|
||||||
|
- Drop pointless %%defattr
|
||||||
|
- HTTPS URLs
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Oct 01 2014 Adam Jackson <ajax@redhat.com> 1.0.7-4
|
||||||
|
- imake 1.0.7
|
||||||
|
- gccmakedep 1.0.3
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 17 2014 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 1.0.6-2
|
||||||
|
- Backport AArch64 support
|
||||||
|
|
||||||
|
* Mon Jan 20 2014 Adam Jackson <ajax@redhat.com> 1.0.6-1
|
||||||
|
- imake 1.0.6
|
||||||
|
|
||||||
|
* Mon Dec 09 2013 Adam Jackson <ajax@redhat.com> 1.0.5-8
|
||||||
|
- Fix imake build with -Werror=format-security (#1037129)
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 07 2013 Jon Ciesla <limburgher@gmail.com> 1.0.5-7
|
||||||
|
- Merge review fixes, BZ 225898.
|
||||||
|
|
||||||
|
* Thu Jan 03 2013 Adam Jackson <ajax@redhat.com> 1.0.5-6
|
||||||
|
- Drop unused patches
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 08 2012 Adam Jackson <ajax@redhat.com> 1.0.5-4
|
||||||
|
- imake 1.0.5
|
||||||
|
- lndir 1.0.3
|
||||||
|
- makedepend 1.0.4
|
5
sources
Normal file
5
sources
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
SHA512 (gccmakedep-1.0.3.tar.bz2) = 563b2897770a4df2792ea3eae8183a1f9e78192b7efc9c8296ee68d1cba6e72fa962a88e3251bb780df776e2aa7e80d74d5096675c61526c232aefa4f9e6a5fc
|
||||||
|
SHA512 (imake-1.0.7.tar.bz2) = b3527c8fead25c6e093e1fe4a39e60ff210212dcd323e206505b9e872a3f36d9db85f85cab5a6f0fa914fa5c558ef54b499b2b13ccd66739223e4e72ef805d08
|
||||||
|
SHA512 (lndir-1.0.3.tar.bz2) = c9f03c825c627935abe399bf8292bbf69304cb9e9d65a4c860b49e32e2ed4dde25bf658a5ab2116cd215381d0a52f464a8a53469c27adddbd9fa2bfd135a7289
|
||||||
|
SHA512 (makedepend-1.0.4.tar.bz2) = b4e276847deed9f52b86d89e4b14b5521aabc409fabb840aaaec6097fae2284be3c0f723b60e77267b6bea37c24ea8ad84afb81c4104e5f22049810e9ad6802e
|
||||||
|
SHA512 (xorg-cf-files-1.0.6.tar.bz2) = 1749a5fbcda2c15c300028abce79a3304cfb10f215bf98cf30558144eb64f9fa06a69203159f44405224ed567ac5bc0ff1222e3656367f69acc99f44871424fa
|
17
xorg-cf-files-1.0.2-redhat.patch
Normal file
17
xorg-cf-files-1.0.2-redhat.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
--- xorg-cf-files-1.0.6/linux.cf.redhat 2005-10-21 21:10:27.000000000 +0200
|
||||||
|
+++ xorg-cf-files-1.0.6/linux.cf 2005-12-21 11:27:16.000000000 +0100
|
||||||
|
@@ -190,7 +190,13 @@
|
||||||
|
#endif /* LinuxDebian */
|
||||||
|
|
||||||
|
#if LinuxDistribution == LinuxRedHat
|
||||||
|
-#define FSUseSyslog YES
|
||||||
|
+# define FSUseSyslog YES
|
||||||
|
+# define BuildRman NO
|
||||||
|
+# define BuildHtmlManPages NO
|
||||||
|
+# define ProjectRoot /usr
|
||||||
|
+# define ManPath /usr/share/man
|
||||||
|
+# define XAppLoadDir /usr/share/X11/app-defaults
|
||||||
|
+# define ConfigDir /usr/share/X11/config
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HasDevRandom
|
Loading…
Reference in New Issue
Block a user