icu/icu.XXXX.buildfix.patch
2009-11-19 09:21:31 +00:00

26 lines
924 B
Diff

--- icu/source/Makefile.in 2009-08-31 21:15:03.000000000 +0100
+++ icu/source/Makefile.in 2009-08-31 21:19:23.000000000 +0100
@@ -146,7 +146,7 @@
install-doc: doc
$(RM) -r $(DESTDIR)$(docdir)/$(docsubdir)
$(MKINSTALLDIRS) $(DESTDIR)$(docdir)/$(docsubdir)
- $(INSTALL_DATA) doc/html/* $(DESTDIR)$(docdir)/$(docsubdir)
+ cp -r doc/html/* $(DESTDIR)$(docdir)/$(docsubdir)
endif
$(DESTDIR)$(pkglibdir)/%: $(top_srcdir)/../data/%
--- icu/source/configure.in 2009-07-01 19:51:26.000000000 +0100
+++ icu/source/configure.in 2009-11-19 09:12:23.000000000 +0000
@@ -57,6 +57,11 @@
AC_SUBST(cross_compiling)
+dnl use the pld hack to get ac_fn_cxx_try_link defined globally and not local
+AC_LANG_PUSH([C++])
+AC_LINK_IFELSE([AC_LANG_PROGRAM()])
+AC_LANG_POP([C++])
+
# make sure install is relative to srcdir - if a script
if test "$srcdir" = "."; then
# If srcdir isn't just ., then (srcdir) is already prepended.