Resolves: rhbz#437761 worst case expansions
This commit is contained in:
parent
1b2591bf49
commit
f9cd813991
@ -1,11 +0,0 @@
|
||||
--- icu.orig/source/layout/IndicClassTables.cpp 2008-03-17 18:45:59.000000000 +0000
|
||||
+++ icu/source/layout/IndicClassTables.cpp 2008-03-17 18:46:08.000000000 +0000
|
||||
@@ -269,7 +269,7 @@
|
||||
//
|
||||
static const IndicClassTable devaClassTable = {0x0900, 0x0970, 2, DEVA_SCRIPT_FLAGS, devaCharClasses, NULL};
|
||||
|
||||
-static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 3, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
+static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 4, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
|
||||
static const IndicClassTable punjClassTable = {0x0A00, 0x0A74, 2, PUNJ_SCRIPT_FLAGS, punjCharClasses, NULL};
|
||||
|
27
icu.icu6213.worstcase.patch
Normal file
27
icu.icu6213.worstcase.patch
Normal file
@ -0,0 +1,27 @@
|
||||
--- icu/source/layout/IndicClassTables.cpp.icu5418.malayam.patch 2007-12-12 18:58:06.000000000 +0000
|
||||
+++ icu/source/layout/IndicClassTables.cpp 2008-03-18 10:10:51.000000000 +0000
|
||||
@@ -255,7 +269,7 @@
|
||||
//
|
||||
static const IndicClassTable devaClassTable = {0x0900, 0x0970, 2, DEVA_SCRIPT_FLAGS, devaCharClasses, NULL};
|
||||
|
||||
-static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 3, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
+static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 4, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
|
||||
static const IndicClassTable punjClassTable = {0x0A00, 0x0A74, 2, PUNJ_SCRIPT_FLAGS, punjCharClasses, NULL};
|
||||
|
||||
@@ -263,13 +277,13 @@
|
||||
|
||||
static const IndicClassTable oryaClassTable = {0x0B00, 0x0B71, 3, ORYA_SCRIPT_FLAGS, oryaCharClasses, oryaSplitTable};
|
||||
|
||||
-static const IndicClassTable tamlClassTable = {0x0B80, 0x0BF2, 3, TAML_SCRIPT_FLAGS, tamlCharClasses, tamlSplitTable};
|
||||
+static const IndicClassTable tamlClassTable = {0x0B80, 0x0BF2, 4, TAML_SCRIPT_FLAGS, tamlCharClasses, tamlSplitTable};
|
||||
|
||||
static const IndicClassTable teluClassTable = {0x0C00, 0x0C6F, 3, TELU_SCRIPT_FLAGS, teluCharClasses, teluSplitTable};
|
||||
|
||||
static const IndicClassTable kndaClassTable = {0x0C80, 0x0CEF, 4, KNDA_SCRIPT_FLAGS, kndaCharClasses, kndaSplitTable};
|
||||
|
||||
-static const IndicClassTable mlymClassTable = {0x0D00, 0x0D6F, 3, MLYM_SCRIPT_FLAGS, mlymCharClasses, mlymSplitTable};
|
||||
+static const IndicClassTable mlymClassTable = {0x0D00, 0x0D6F, 4, MLYM_SCRIPT_FLAGS, mlymCharClasses, mlymSplitTable};
|
||||
|
||||
static const IndicClassTable sinhClassTable = {0x0D80, 0x0DF4, 4, SINH_SCRIPT_FLAGS, sinhCharClasses, sinhSplitTable};
|
||||
|
8
icu.spec
8
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 3.8.1
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
@ -20,6 +20,7 @@ Patch8: icu.icuXXXX.malayalam.bysyllable.patch
|
||||
Patch9: icu.icu6008.arm.padding.patch
|
||||
Patch10: icu.icu5498.openoffice.org.patch
|
||||
Patch11: icu.regexp.patch
|
||||
Patch12: icu.icu6213.worstcase.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -68,6 +69,7 @@ Group: Documentation
|
||||
%patch9 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch10 -p1 -b .icu5498.openoffice.org.patch
|
||||
%patch11 -p0 -b .regexp.patch
|
||||
%patch12 -p0 -b .icu6213.worstcase.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -145,6 +147,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Mar 18 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-7
|
||||
- Resolves: rhbz#437761 modify to icu.icu6213.worstcase.patch for
|
||||
other worst case expansions
|
||||
|
||||
* Mon Mar 17 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-6
|
||||
- Resolves: rhbz#437761 add icu.icu6213.bengali.worstcase.patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user