clean up
This commit is contained in:
parent
318d8b5550
commit
cf1ab4d255
@ -1,11 +0,0 @@
|
||||
--- icu/source/layout/IndicReordering.cpp.orig 2006-09-05 17:01:15.000000000 +0100
|
||||
+++ icu/source/layout/IndicReordering.cpp 2006-09-05 17:01:19.000000000 +0100
|
||||
@@ -377,7 +377,7 @@
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, -1, 5, 9, 5, 5, 4, 12}, // 2 - consonant with nukta
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, 2, 5, 9, 5, 5, 4, 12}, // 3 - consonant
|
||||
{-1, -1, -1, -1, -1, -1, 3, 2, -1, -1, -1, -1, -1, -1, 7}, // 4 - consonant virama
|
||||
- {-1, 6, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1}, // 5 - dependent vowels
|
||||
+ {-1, 6, 1, -1, -1, -1, -1, -1, -1, 5, -1, -1, -1, -1, -1}, // 5 - dependent vowels
|
||||
{-1, -1, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1}, // 6 - vowel mark
|
||||
{-1, -1, -1, -1, -1, -1, 3, 2, -1, -1, -1, -1, -1, -1, -1}, // 7 - consonant virama ZWJ, consonant ZWJ virama
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, 4, -1}, // 8 - independent vowels that can take a virama
|
@ -1,15 +1,6 @@
|
||||
diff -ur icu.orig/source/layout/IndicReordering.cpp icu/source/layout/IndicReordering.cpp
|
||||
--- icu.orig/source/layout/IndicReordering.cpp 2006-11-10 09:42:44.000000000 +0000
|
||||
+++ icu/source/layout/IndicReordering.cpp 2006-11-10 09:47:05.000000000 +0000
|
||||
@@ -395,7 +395,7 @@
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, -1, 5, 9, 5, 5, 4, 12}, // 2 - consonant with nukta
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, 2, 5, 9, 5, 5, 4, 12}, // 3 - consonant
|
||||
{-1, -1, -1, -1, -1, -1, 3, 2, -1, -1, -1, -1, -1, -1, 7}, // 4 - consonant virama
|
||||
- {-1, 6, 1, -1, -1, -1, -1, -1, -1, 5, -1, -1, -1, -1, -1}, // 5 - dependent vowels
|
||||
+ {-1, 6, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1}, // 5 - dependent vowels
|
||||
{-1, -1, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1}, // 6 - vowel mark
|
||||
{-1, -1, -1, -1, -1, -1, 3, 2, -1, -1, -1, -1, -1, -1, -1}, // 7 - consonant virama ZWJ, consonant ZWJ virama
|
||||
{-1, 6, 1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, 4, -1}, // 8 - independent vowels that can take a virama
|
||||
@@ -423,6 +423,48 @@
|
||||
|
||||
state = stateTable[state][charClass & CF_CLASS_MASK];
|
||||
|
41
icu.spec
41
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 3.8.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
@ -11,15 +11,14 @@ BuildRequires: doxygen, autoconf
|
||||
|
||||
Patch1: icu-3.4-multiarchdevel.patch
|
||||
Patch2: icu-config
|
||||
Patch3: icu.icu5365.dependantvowels.patch
|
||||
Patch4: icu.icu5418.malayam.patch
|
||||
Patch5: icu.icu5431.malayam.patch
|
||||
Patch6: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch7: icu.icu5557.safety.patch
|
||||
Patch8: icu.icu5506.multiplevowels.patch
|
||||
Patch9: icu.icuXXXX.malayalam.bysyllable.patch
|
||||
Patch10: icu.icu6008.arm.padding.patch
|
||||
Patch11: icu.icu5498.openoffice.org.patch
|
||||
Patch3: icu.icu5418.malayam.patch
|
||||
Patch4: icu.icu5431.malayam.patch
|
||||
Patch5: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch6: icu.icu5557.safety.patch
|
||||
Patch7: icu.icu5506.multiplevowels.patch
|
||||
Patch8: icu.icuXXXX.malayalam.bysyllable.patch
|
||||
Patch9: icu.icu6008.arm.padding.patch
|
||||
Patch10: icu.icu5498.openoffice.org.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -59,15 +58,14 @@ Group: Documentation
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p1 -b .multiarchdevel
|
||||
%patch3 -p1 -b .dependantvowels
|
||||
%patch4 -p1 -b .icu5418.malayam.patch
|
||||
%patch5 -p1 -b .icu5431.malayam.patch
|
||||
%patch6 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
%patch7 -p1 -b .icu5557.safety.patch
|
||||
%patch8 -p1 -b .icu5506.multiplevowels.patch
|
||||
%patch9 -p1 -b .icuXXXX.malayalam.bysyllable.patch
|
||||
%patch10 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch11 -p1 -b .icu5498.openoffice.org.patch
|
||||
%patch3 -p1 -b .icu5418.malayam.patch
|
||||
%patch4 -p1 -b .icu5431.malayam.patch
|
||||
%patch5 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
%patch6 -p1 -b .icu5557.safety.patch
|
||||
%patch7 -p1 -b .icu5506.multiplevowels.patch
|
||||
%patch8 -p1 -b .icuXXXX.malayalam.bysyllable.patch
|
||||
%patch9 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch10 -p1 -b .icu5498.openoffice.org.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -145,6 +143,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 11 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-2
|
||||
- remove icu.icu5365.dependantvowels.patch and cleanup
|
||||
icu.icu5506.multiplevowels.patch as they patch and unpatch
|
||||
eachother (thanks George Rhoten for pointing out that madness)
|
||||
|
||||
* Fri Jan 11 2008 Caolan McNamara <caolanm@redhat.com> - 3.8.1-1
|
||||
- latest version
|
||||
- drop fixed icu.icu6084.zwnj.notdef.patch
|
||||
|
Loading…
Reference in New Issue
Block a user