upgrade to upstream ICU 57.1
This commit is contained in:
parent
a151138332
commit
cc9ec21036
@ -1,7 +1,7 @@
|
|||||||
diff -ur orig.icu/source/test/cintltst/cnmdptst.c icu/source/test/cintltst/cnmdptst.c
|
diff -ru orig.icu/source/test/cintltst/cnmdptst.c icu/source/test/cintltst/cnmdptst.c
|
||||||
--- orig.icu/source/test/cintltst/cnmdptst.c 2015-10-08 05:51:46.000000000 +0200
|
--- orig.icu/source/test/cintltst/cnmdptst.c 2016-03-23 21:48:18.000000000 +0100
|
||||||
+++ icu/source/test/cintltst/cnmdptst.c 2015-10-27 19:40:27.537963317 +0100
|
+++ icu/source/test/cintltst/cnmdptst.c 2016-04-15 18:34:06.148251985 +0200
|
||||||
@@ -185,6 +185,12 @@
|
@@ -186,6 +186,12 @@
|
||||||
/* Test exponential pattern*/
|
/* Test exponential pattern*/
|
||||||
static void TestExponential(void)
|
static void TestExponential(void)
|
||||||
{
|
{
|
||||||
@ -14,9 +14,9 @@ diff -ur orig.icu/source/test/cintltst/cnmdptst.c icu/source/test/cintltst/cnmdp
|
|||||||
int32_t pat_length, val_length, lval_length;
|
int32_t pat_length, val_length, lval_length;
|
||||||
int32_t ival, ilval, p, v, lneed;
|
int32_t ival, ilval, p, v, lneed;
|
||||||
UNumberFormat *fmt;
|
UNumberFormat *fmt;
|
||||||
diff -ur orig.icu/source/test/intltest/dcfmtest.cpp icu/source/test/intltest/dcfmtest.cpp
|
diff -ru orig.icu/source/test/intltest/dcfmtest.cpp icu/source/test/intltest/dcfmtest.cpp
|
||||||
--- orig.icu/source/test/intltest/dcfmtest.cpp 2015-10-08 05:52:10.000000000 +0200
|
--- orig.icu/source/test/intltest/dcfmtest.cpp 2016-03-23 21:48:38.000000000 +0100
|
||||||
+++ icu/source/test/intltest/dcfmtest.cpp 2015-10-27 19:40:27.537963317 +0100
|
+++ icu/source/test/intltest/dcfmtest.cpp 2016-04-15 18:34:06.148251985 +0200
|
||||||
@@ -279,6 +279,13 @@
|
@@ -279,6 +279,13 @@
|
||||||
//
|
//
|
||||||
formatLineMat.reset(testLine);
|
formatLineMat.reset(testLine);
|
||||||
@ -31,9 +31,9 @@ diff -ur orig.icu/source/test/intltest/dcfmtest.cpp icu/source/test/intltest/dcf
|
|||||||
execFormatTest(lineNum,
|
execFormatTest(lineNum,
|
||||||
formatLineMat.group(1, status), // Pattern
|
formatLineMat.group(1, status), // Pattern
|
||||||
formatLineMat.group(2, status), // rounding mode
|
formatLineMat.group(2, status), // rounding mode
|
||||||
diff -ur orig.icu/source/test/intltest/numfmtspectest.cpp icu/source/test/intltest/numfmtspectest.cpp
|
diff -ru orig.icu/source/test/intltest/numfmtspectest.cpp icu/source/test/intltest/numfmtspectest.cpp
|
||||||
--- orig.icu/source/test/intltest/numfmtspectest.cpp 2015-10-08 05:52:10.000000000 +0200
|
--- orig.icu/source/test/intltest/numfmtspectest.cpp 2016-03-23 21:48:40.000000000 +0100
|
||||||
+++ icu/source/test/intltest/numfmtspectest.cpp 2015-10-27 19:41:47.660444972 +0100
|
+++ icu/source/test/intltest/numfmtspectest.cpp 2016-04-15 18:34:06.148251985 +0200
|
||||||
@@ -137,11 +137,14 @@
|
@@ -137,11 +137,14 @@
|
||||||
|
|
||||||
void NumberFormatSpecificationTest::TestScientificNotation() {
|
void NumberFormatSpecificationTest::TestScientificNotation() {
|
||||||
@ -66,10 +66,10 @@ diff -ur orig.icu/source/test/intltest/numfmtspectest.cpp icu/source/test/intlte
|
|||||||
}
|
}
|
||||||
|
|
||||||
void NumberFormatSpecificationTest::assertPatternFr(
|
void NumberFormatSpecificationTest::assertPatternFr(
|
||||||
diff -ur orig.icu/source/test/intltest/numfmtst.cpp icu/source/test/intltest/numfmtst.cpp
|
diff -ru orig.icu/source/test/intltest/numfmtst.cpp icu/source/test/intltest/numfmtst.cpp
|
||||||
--- orig.icu/source/test/intltest/numfmtst.cpp 2015-10-08 05:52:12.000000000 +0200
|
--- orig.icu/source/test/intltest/numfmtst.cpp 2016-03-23 21:48:40.000000000 +0100
|
||||||
+++ icu/source/test/intltest/numfmtst.cpp 2015-10-27 19:40:27.539963329 +0100
|
+++ icu/source/test/intltest/numfmtst.cpp 2016-04-15 18:34:06.150251997 +0200
|
||||||
@@ -729,6 +729,12 @@
|
@@ -730,6 +730,12 @@
|
||||||
void
|
void
|
||||||
NumberFormatTest::TestExponential(void)
|
NumberFormatTest::TestExponential(void)
|
||||||
{
|
{
|
||||||
@ -82,7 +82,7 @@ diff -ur orig.icu/source/test/intltest/numfmtst.cpp icu/source/test/intltest/num
|
|||||||
UErrorCode status = U_ZERO_ERROR;
|
UErrorCode status = U_ZERO_ERROR;
|
||||||
DecimalFormatSymbols sym(Locale::getUS(), status);
|
DecimalFormatSymbols sym(Locale::getUS(), status);
|
||||||
if (U_FAILURE(status)) { errcheckln(status, "FAIL: Bad status returned by DecimalFormatSymbols ct - %s", u_errorName(status)); return; }
|
if (U_FAILURE(status)) { errcheckln(status, "FAIL: Bad status returned by DecimalFormatSymbols ct - %s", u_errorName(status)); return; }
|
||||||
@@ -1847,8 +1853,11 @@
|
@@ -1846,8 +1852,11 @@
|
||||||
(int32_t) 45678000, "5E7", status);
|
(int32_t) 45678000, "5E7", status);
|
||||||
expect(new DecimalFormat("00E0", US, status),
|
expect(new DecimalFormat("00E0", US, status),
|
||||||
(int32_t) 45678000, "46E6", status);
|
(int32_t) 45678000, "46E6", status);
|
||||||
|
@ -1,5 +1,6 @@
|
|||||||
--- icu/source/layout/IndicReordering.cpp 2009-07-01 20:51:26.000000000 +0200
|
diff -ru orig.icu/source/layout/IndicReordering.cpp icu/source/layout/IndicReordering.cpp
|
||||||
+++ icu/source/layout/IndicReordering.cpp 2011-01-08 11:12:49.950566538 +0100
|
--- orig.icu/source/layout/IndicReordering.cpp 2016-04-15 18:30:15.788856946 +0200
|
||||||
|
+++ icu/source/layout/IndicReordering.cpp 2016-04-15 18:30:39.244998995 +0200
|
||||||
@@ -13,6 +13,7 @@
|
@@ -13,6 +13,7 @@
|
||||||
|
|
||||||
U_NAMESPACE_BEGIN
|
U_NAMESPACE_BEGIN
|
||||||
@ -25,7 +26,7 @@
|
|||||||
#define positioningFormsMask ( kernFeatureMask | distFeatureMask | abvmFeatureMask | blwmFeatureMask )
|
#define positioningFormsMask ( kernFeatureMask | distFeatureMask | abvmFeatureMask | blwmFeatureMask )
|
||||||
#define presentationFormsMask ( presFeatureMask | abvsFeatureMask | blwsFeatureMask | pstsFeatureMask | halnFeatureMask | caltFeatureMask )
|
#define presentationFormsMask ( presFeatureMask | abvsFeatureMask | blwsFeatureMask | pstsFeatureMask | halnFeatureMask | caltFeatureMask )
|
||||||
|
|
||||||
@@ -480,6 +482,7 @@
|
@@ -484,6 +486,7 @@
|
||||||
#define tagArray0 (rphfFeatureMask | tagArray1)
|
#define tagArray0 (rphfFeatureMask | tagArray1)
|
||||||
|
|
||||||
static const FeatureMap featureMap[] = {
|
static const FeatureMap featureMap[] = {
|
||||||
@ -33,7 +34,7 @@
|
|||||||
{loclFeatureTag, loclFeatureMask},
|
{loclFeatureTag, loclFeatureMask},
|
||||||
{initFeatureTag, initFeatureMask},
|
{initFeatureTag, initFeatureMask},
|
||||||
{nuktFeatureTag, nuktFeatureMask},
|
{nuktFeatureTag, nuktFeatureMask},
|
||||||
@@ -502,6 +505,7 @@
|
@@ -506,6 +509,7 @@
|
||||||
static const le_int32 featureCount = LE_ARRAY_SIZE(featureMap);
|
static const le_int32 featureCount = LE_ARRAY_SIZE(featureMap);
|
||||||
|
|
||||||
static const FeatureMap v2FeatureMap[] = {
|
static const FeatureMap v2FeatureMap[] = {
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
diff -ru orig.icu/source/layout/LookupProcessor.cpp icu/source/layout/LookupProcessor.cpp
|
diff -ru orig.icu/source/layout/LookupProcessor.cpp icu/source/layout/LookupProcessor.cpp
|
||||||
--- orig.icu/source/layout/LookupProcessor.cpp 2013-04-18 23:32:30.000000000 +0200
|
--- orig.icu/source/layout/LookupProcessor.cpp 2016-03-23 21:56:44.000000000 +0100
|
||||||
+++ icu/source/layout/LookupProcessor.cpp 2013-07-17 01:09:57.792635999 +0200
|
+++ icu/source/layout/LookupProcessor.cpp 2016-04-15 18:19:26.903927005 +0200
|
||||||
@@ -220,7 +220,9 @@
|
@@ -223,7 +223,9 @@
|
||||||
|
|
||||||
if (requiredFeatureIndex != 0xFFFF) {
|
if (requiredFeatureIndex != 0xFFFF) {
|
||||||
requiredFeatureTable = featureListTable->getFeatureTable(featureListTable, requiredFeatureIndex, &requiredFeatureTag, success);
|
requiredFeatureTable = featureListTable->getFeatureTable(featureListTable, requiredFeatureIndex, &requiredFeatureTag, success);
|
||||||
- featureReferences += SWAPW(featureTable->lookupCount);
|
- featureReferences += SWAPW(requiredFeatureTable->lookupCount);
|
||||||
+ if (requiredFeatureTable.isValid()) {
|
+ if (requiredFeatureTable.isValid()) {
|
||||||
+ featureReferences += SWAPW(requiredFeatureTable->lookupCount);
|
+ featureReferences += SWAPW(requiredFeatureTable->lookupCount);
|
||||||
+ }
|
+ }
|
||||||
|
19
icu.spec
19
icu.spec
@ -1,13 +1,13 @@
|
|||||||
#%%global debugtrace 1
|
#%%global debugtrace 1
|
||||||
|
|
||||||
Name: icu
|
Name: icu
|
||||||
Version: 56.1
|
Version: 57.1
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
|
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
URL: http://www.icu-project.org/
|
URL: http://www.icu-project.org/
|
||||||
Source0: http://download.icu-project.org/files/icu4c/56.1/icu4c-56_1-src.tgz
|
Source0: http://download.icu-project.org/files/icu4c/57.1/icu4c-57_1-src.tgz
|
||||||
Source1: icu-config.sh
|
Source1: icu-config.sh
|
||||||
|
|
||||||
BuildRequires: doxygen, autoconf, python
|
BuildRequires: doxygen, autoconf, python
|
||||||
@ -143,7 +143,7 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%license license.html
|
%license license.html
|
||||||
%exclude %{_datadir}/%{name}/*/license.html
|
%exclude %{_datadir}/%{name}/*/LICENSE
|
||||||
%{_bindir}/derb
|
%{_bindir}/derb
|
||||||
%{_bindir}/genbrk
|
%{_bindir}/genbrk
|
||||||
%{_bindir}/gencfu
|
%{_bindir}/gencfu
|
||||||
@ -166,12 +166,12 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
|||||||
%{_mandir}/man8/*.8*
|
%{_mandir}/man8/*.8*
|
||||||
|
|
||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
%license license.html
|
%license LICENSE
|
||||||
%doc readme.html
|
%doc readme.html
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
%files -n lib%{name}-devel
|
%files -n lib%{name}-devel
|
||||||
%license license.html
|
%license LICENSE
|
||||||
%doc source/samples/
|
%doc source/samples/
|
||||||
%{_bindir}/%{name}-config*
|
%{_bindir}/%{name}-config*
|
||||||
%{_bindir}/icuinfo
|
%{_bindir}/icuinfo
|
||||||
@ -189,14 +189,17 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
|||||||
%{_datadir}/%{name}/%{version}/config
|
%{_datadir}/%{name}/%{version}/config
|
||||||
|
|
||||||
%files -n lib%{name}-doc
|
%files -n lib%{name}-doc
|
||||||
%license license.html
|
%license LICENSE
|
||||||
%doc readme.html
|
%doc readme.html
|
||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 15 2016 Eike Rathke <erack@redhat.com> - 57.1-1
|
||||||
|
- upgrade to upstream ICU 57.1
|
||||||
|
|
||||||
* Tue Apr 05 2016 Eike Rathke <erack@redhat.com> - 56.1-7
|
* Tue Apr 05 2016 Eike Rathke <erack@redhat.com> - 56.1-7
|
||||||
- make check failure is fatal again, still fails in rawhide/f25 i686
|
- make check failure is fatal again
|
||||||
|
|
||||||
* Tue Apr 05 2016 Eike Rathke <erack@redhat.com> - 56.1-6
|
* Tue Apr 05 2016 Eike Rathke <erack@redhat.com> - 56.1-6
|
||||||
- remove icu-56.1-codes-cache-extend.patch
|
- remove icu-56.1-codes-cache-extend.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user