update to 50.1.2
This commit is contained in:
parent
c830678fab
commit
cc65fb5809
@ -1,36 +0,0 @@
|
||||
--- icu/source/i18n/regexcmp.cpp (revision 31398)
|
||||
+++ icu/source/i18n/regexcmp.cpp (revision 31782)
|
||||
@@ -3307,8 +3307,29 @@
|
||||
|
||||
case URX_STRING_I:
|
||||
- // TODO: Is the case-folded string the longest?
|
||||
- // If so we can optimize this the same as URX_STRING.
|
||||
- loc++;
|
||||
- currentLen = INT32_MAX;
|
||||
+ // TODO: This code assumes that any user string that matches will be no longer
|
||||
+ // than our compiled string, with case insensitive matching.
|
||||
+ // Our compiled string has been case-folded already.
|
||||
+ //
|
||||
+ // Any matching user string will have no more code points than our
|
||||
+ // compiled (folded) string. Folding may add code points, but
|
||||
+ // not remove them.
|
||||
+ //
|
||||
+ // There is a potential problem if a supplemental code point
|
||||
+ // case-folds to a BMP code point. In this case our compiled string
|
||||
+ // could be shorter (in code units) than a matching user string.
|
||||
+ //
|
||||
+ // At this time (Unicode 6.1) there are no such characters, and this case
|
||||
+ // is not being handled. A test, intltest regex/Bug9283, will fail if
|
||||
+ // any problematic characters are added to Unicode.
|
||||
+ //
|
||||
+ // If this happens, we can make a set of the BMP chars that the
|
||||
+ // troublesome supplementals fold to, scan our string, and bump the
|
||||
+ // currentLen one extra for each that is found.
|
||||
+ //
|
||||
+ {
|
||||
+ loc++;
|
||||
+ int32_t stringLenOp = (int32_t)fRXPat->fCompiledPat->elementAti(loc);
|
||||
+ currentLen = safeIncrement(currentLen, URX_VAL(stringLenOp));
|
||||
+ }
|
||||
break;
|
||||
|
27
icu.spec
27
icu.spec
@ -1,19 +1,18 @@
|
||||
Name: icu
|
||||
Version: 49.1.1
|
||||
Release: 7%{?dist}
|
||||
Version: 50.1.2
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT and UCD and Public Domain
|
||||
URL: http://www.icu-project.org/
|
||||
Source0: http://download.icu-project.org/files/icu4c/49.1.1/icu4c-49_1_1-src.tgz
|
||||
Source0: http://download.icu-project.org/files/icu4c/50.1.2/icu4c-50_1_2-src.tgz
|
||||
Source1: icu-config.sh
|
||||
BuildRequires: doxygen, autoconf
|
||||
BuildRequires: doxygen, autoconf, python
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
Patch1: icu.8198.revert.icu5431.patch
|
||||
Patch2: icu.8800.freeserif.crash.patch
|
||||
Patch3: icu.7601.Indic-ccmp.patch
|
||||
Patch4: icu.9283.regexcmp.crash.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -51,20 +50,25 @@ BuildArch: noarch
|
||||
%description -n lib%{name}-doc
|
||||
%{summary}.
|
||||
|
||||
%{!?endian: %global endian %(%{__python} -c "import sys;print (0 if sys.byteorder=='big' else 1)")}
|
||||
# " this line just fixes syntax highlighting for vim that is confused by the above and continues literal
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
||||
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
||||
%patch4 -p1 -b .icu9283.regexcmp.crash.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
autoconf
|
||||
CFLAGS='%optflags -fno-strict-aliasing'
|
||||
CXXFLAGS='%optflags -fno-strict-aliasing'
|
||||
#rhbz#856594 to-do add --disable-renaming on next soname bump
|
||||
%configure --with-data-packaging=library --disable-samples
|
||||
# Endian: BE=0 LE=1
|
||||
%if ! 0%{?endian}
|
||||
CPPFLAGS='-DU_IS_BIG_ENDIAN=1'
|
||||
%endif
|
||||
%configure --with-data-packaging=library --disable-samples --disable-renaming
|
||||
#rhbz#225896
|
||||
sed -i 's|-nodefaultlibs -nostdlib||' config/mh-linux
|
||||
#rhbz#681941
|
||||
@ -110,7 +114,6 @@ make %{?_smp_mflags} -C source check
|
||||
%{_bindir}/genbrk
|
||||
%{_bindir}/gencfu
|
||||
%{_bindir}/gencnval
|
||||
%{_bindir}/genctd
|
||||
%{_bindir}/genrb
|
||||
%{_bindir}/makeconv
|
||||
%{_bindir}/pkgdata
|
||||
@ -120,7 +123,6 @@ make %{?_smp_mflags} -C source check
|
||||
%{_mandir}/man1/gencnval.1*
|
||||
%{_mandir}/man1/genrb.1*
|
||||
%{_mandir}/man1/genbrk.1*
|
||||
%{_mandir}/man1/genctd.1*
|
||||
%{_mandir}/man1/makeconv.1*
|
||||
%{_mandir}/man1/pkgdata.1*
|
||||
%{_mandir}/man1/uconv.1*
|
||||
@ -154,6 +156,11 @@ make %{?_smp_mflags} -C source check
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 25 2013 Eike Rathke <erack@redhat.com> - 50.1.2-1
|
||||
- Update to 50.1.2
|
||||
- Resolves: rhbz#856594 to-do add --disable-renaming on next soname bump
|
||||
- removed upstream applied icu.9283.regexcmp.crash.patch
|
||||
|
||||
* Wed Sep 12 2012 Caolán McNamara <caolanm@redhat.com> - 49.1.1-7
|
||||
- Related: rhbz#856594 reenable icu symbol renaming
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user