drop integrated patches
This commit is contained in:
parent
2cd6c312fd
commit
c0a11fa0c7
@ -1,14 +0,0 @@
|
||||
--- icu.orig/source/layout/CoverageTables.cpp 2007-01-09 12:57:41.000000000 +0000
|
||||
+++ icu/source/layout/CoverageTables.cpp 2007-01-09 12:59:09.000000000 +0000
|
||||
@@ -44,6 +44,11 @@
|
||||
le_uint16 count = SWAPW(glyphCount);
|
||||
le_uint8 bit = OpenTypeUtilities::highBit(count);
|
||||
le_uint16 power = 1 << bit;
|
||||
+
|
||||
+ if (count == 0) {
|
||||
+ return -1;
|
||||
+ }
|
||||
+
|
||||
le_uint16 extra = count - power;
|
||||
le_uint16 probe = power;
|
||||
le_uint16 index = 0;
|
19
icu.spec
19
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 4.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
@ -12,10 +12,9 @@ BuildRequires: doxygen, autoconf
|
||||
Patch1: icu-config
|
||||
Patch2: icu-3.4-multiarchdevel.patch
|
||||
Patch3: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch4: icu.icu5557.safety.patch
|
||||
Patch5: icu.icu6008.arm.padding.patch
|
||||
Patch6: icu.icu6213.worstcase.patch
|
||||
Patch7: icu.icu6284.strictalias.patch
|
||||
Patch4: icu.icu6008.arm.padding.patch
|
||||
Patch5: icu.icu6213.worstcase.patch
|
||||
Patch6: icu.icu6284.strictalias.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -56,10 +55,9 @@ Group: Documentation
|
||||
%setup -q -n %{name}
|
||||
%patch2 -p1 -b .multiarchdevel
|
||||
%patch3 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
%patch4 -p1 -b .icu5557.safety.patch
|
||||
%patch5 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch6 -p1 -b .icu6213.worstcase.patch
|
||||
%patch7 -p1 -b .icu6284.strictalias.patch
|
||||
%patch4 -p1 -b .icu6008.arm.padding.patch
|
||||
%patch5 -p1 -b .icu6213.worstcase.patch
|
||||
%patch6 -p1 -b .icu6284.strictalias.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -132,6 +130,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 16 2008 Caolan McNamara <caolanm@redhat.com> - 4.0-5
|
||||
- drop integrated icu.icu5557.safety.patch
|
||||
|
||||
* Thu Nov 20 2008 Caolan McNamara <caolanm@redhat.com> - 4.0-4
|
||||
- annoyingly upstream tarball was repacked apparently to remove
|
||||
some unused/cached dirs
|
||||
|
Loading…
Reference in New Issue
Block a user