rpmlint warnings
This commit is contained in:
parent
cb6927cab2
commit
a89e134cfc
@ -1,27 +0,0 @@
|
||||
--- icu.orig/source/layout/IndicClassTables.cpp 2007-12-12 18:58:06.000000000 +0000
|
||||
+++ icu/source/layout/IndicClassTables.cpp 2008-03-18 10:10:51.000000000 +0000
|
||||
@@ -255,7 +269,7 @@
|
||||
//
|
||||
static const IndicClassTable devaClassTable = {0x0900, 0x0970, 2, DEVA_SCRIPT_FLAGS, devaCharClasses, NULL};
|
||||
|
||||
-static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 3, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
+static const IndicClassTable bengClassTable = {0x0980, 0x09FA, 4, BENG_SCRIPT_FLAGS, bengCharClasses, bengSplitTable};
|
||||
|
||||
static const IndicClassTable punjClassTable = {0x0A00, 0x0A74, 2, PUNJ_SCRIPT_FLAGS, punjCharClasses, NULL};
|
||||
|
||||
@@ -263,13 +277,13 @@
|
||||
|
||||
static const IndicClassTable oryaClassTable = {0x0B00, 0x0B71, 3, ORYA_SCRIPT_FLAGS, oryaCharClasses, oryaSplitTable};
|
||||
|
||||
-static const IndicClassTable tamlClassTable = {0x0B80, 0x0BF2, 3, TAML_SCRIPT_FLAGS, tamlCharClasses, tamlSplitTable};
|
||||
+static const IndicClassTable tamlClassTable = {0x0B80, 0x0BF2, 4, TAML_SCRIPT_FLAGS, tamlCharClasses, tamlSplitTable};
|
||||
|
||||
static const IndicClassTable teluClassTable = {0x0C00, 0x0C6F, 3, TELU_SCRIPT_FLAGS, teluCharClasses, teluSplitTable};
|
||||
|
||||
static const IndicClassTable kndaClassTable = {0x0C80, 0x0CEF, 4, KNDA_SCRIPT_FLAGS, kndaCharClasses, kndaSplitTable};
|
||||
|
||||
-static const IndicClassTable mlymClassTable = {0x0D00, 0x0D6F, 3, MLYM_SCRIPT_FLAGS, mlymCharClasses, mlymSplitTable};
|
||||
+static const IndicClassTable mlymClassTable = {0x0D00, 0x0D6F, 4, MLYM_SCRIPT_FLAGS, mlymCharClasses, mlymSplitTable};
|
||||
|
||||
static const IndicClassTable sinhClassTable = {0x0D80, 0x0DF4, 4, SINH_SCRIPT_FLAGS, sinhCharClasses, sinhSplitTable};
|
||||
|
@ -1,98 +0,0 @@
|
||||
diff -ur icu.orig/source/common/rbbi.cpp icu/source/common/rbbi.cpp
|
||||
--- icu.orig/source/common/rbbi.cpp 2006-10-05 11:54:13.000000000 +0100
|
||||
+++ icu/source/common/rbbi.cpp 2006-10-05 11:57:31.000000000 +0100
|
||||
@@ -879,6 +879,22 @@
|
||||
RBBI_END // state machine processing is after end of user text.
|
||||
};
|
||||
|
||||
+#define VIRAMA_SCRIPT(wc) ((wc) >= 0x0901 && (wc) <= 0x17FF)
|
||||
+#define VIRAMA(wc) ((wc) == 0x094D || \
|
||||
+ (wc) == 0x09CD || \
|
||||
+ (wc) == 0x0A4D || \
|
||||
+ (wc) == 0x0ACD || \
|
||||
+ (wc) == 0x0B4D || \
|
||||
+ (wc) == 0x0BCD || \
|
||||
+ (wc) == 0x0C4D || \
|
||||
+ (wc) == 0x0CCD || \
|
||||
+ (wc) == 0x0D4D || \
|
||||
+ (wc) == 0x0DCA || \
|
||||
+ (wc) == 0x0E3A || \
|
||||
+ (wc) == 0x0F84 || \
|
||||
+ (wc) == 0x1039 || \
|
||||
+ (wc) == 0x17D2 || \
|
||||
+ (wc) == 0x200D)
|
||||
|
||||
//-----------------------------------------------------------------------------------
|
||||
//
|
||||
@@ -896,6 +911,7 @@
|
||||
RBBIRunMode mode;
|
||||
|
||||
RBBIStateTableRow *row;
|
||||
+ UChar32 prevchar;
|
||||
UChar32 c;
|
||||
int32_t lookaheadStatus = 0;
|
||||
int32_t lookaheadTagIdx = 0;
|
||||
@@ -919,6 +935,7 @@
|
||||
// if we're already at the end of the text, return DONE.
|
||||
initialPosition = (int32_t)UTEXT_GETNATIVEINDEX(fText);
|
||||
result = initialPosition;
|
||||
+ prevchar = 0;
|
||||
c = UTEXT_NEXT32(fText);
|
||||
if (fData == NULL || c==U_SENTINEL) {
|
||||
return BreakIterator::DONE;
|
||||
@@ -1001,6 +1018,11 @@
|
||||
|
||||
// State Transition - move machine to its next state
|
||||
//
|
||||
+ if (VIRAMA_SCRIPT(c) && VIRAMA(prevchar))
|
||||
+ {
|
||||
+ state = START_STATE;
|
||||
+ row = (RBBIStateTableRow *) (tableData + tableRowLen * state);
|
||||
+ }
|
||||
state = row->fNextState[category];
|
||||
row = (RBBIStateTableRow *)
|
||||
// (statetable->fTableData + (statetable->fRowLen * state));
|
||||
@@ -1059,6 +1081,7 @@
|
||||
// the input position. The next iteration will be processing the
|
||||
// first real input character.
|
||||
if (mode == RBBI_RUN) {
|
||||
+ prevchar = c;
|
||||
c = UTEXT_NEXT32(fText);
|
||||
} else {
|
||||
if (mode == RBBI_START) {
|
||||
@@ -1107,6 +1130,7 @@
|
||||
int16_t category = 0;
|
||||
RBBIRunMode mode;
|
||||
RBBIStateTableRow *row;
|
||||
+ UChar32 prevchar;
|
||||
UChar32 c;
|
||||
int32_t lookaheadStatus = 0;
|
||||
int32_t result = 0;
|
||||
@@ -1135,6 +1159,7 @@
|
||||
// Set up the starting char.
|
||||
initialPosition = (int32_t)UTEXT_GETNATIVEINDEX(fText);
|
||||
result = initialPosition;
|
||||
+ prevchar = 0;
|
||||
c = UTEXT_PREVIOUS32(fText);
|
||||
|
||||
// Set the initial state for the state machine
|
||||
@@ -1218,6 +1243,11 @@
|
||||
|
||||
// State Transition - move machine to its next state
|
||||
//
|
||||
+ if (VIRAMA_SCRIPT(prevchar) && VIRAMA(c))
|
||||
+ {
|
||||
+ state = START_STATE;
|
||||
+ row = (RBBIStateTableRow *) (statetable->fTableData + (statetable->fRowLen * state));
|
||||
+ }
|
||||
state = row->fNextState[category];
|
||||
row = (RBBIStateTableRow *)
|
||||
(statetable->fTableData + (statetable->fRowLen * state));
|
||||
@@ -1269,6 +1299,7 @@
|
||||
// the input position. The next iteration will be processing the
|
||||
// first real input character.
|
||||
if (mode == RBBI_RUN) {
|
||||
+ prevchar = c;
|
||||
c = UTEXT_PREVIOUS32(fText);
|
||||
} else {
|
||||
if (mode == RBBI_START) {
|
14
icu.spec
14
icu.spec
@ -1,6 +1,6 @@
|
||||
Name: icu
|
||||
Version: 4.2.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT
|
||||
@ -13,9 +13,7 @@ Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
Patch1: icu-3.4-multiarchdevel.patch
|
||||
Patch2: icu.icu6284.strictalias.patch
|
||||
Patch3: icu.icuXXXX.virama.prevnext.patch
|
||||
Patch4: icu.icu6213.worstcase.patch
|
||||
Patch5: icu.6995.kannada.patch
|
||||
Patch3: icu.6995.kannada.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -56,10 +54,7 @@ Group: Documentation
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p1 -b .multiarchdevel
|
||||
%patch2 -p1 -b .icu6284.strictalias.patch
|
||||
#let's skip these for now, hopefully unneccessary
|
||||
#%patch3 -p1 -b .icuXXXX.virama.prevnext.patch
|
||||
#%patch4 -p1 -b .icu6213.worstcase.patch
|
||||
%patch5 -p1 -b .icu.6995.kannada.patch
|
||||
%patch3 -p1 -b .icu.6995.kannada.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -135,6 +130,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 14 2009 Caolan McNamara <caolanm@redhat.com> - 4.2.1-2
|
||||
- rpmlint warnings
|
||||
|
||||
* Fri Jul 03 2009 Caolan McNamara <caolanm@redhat.com> - 4.2.1-1
|
||||
- 4.2.1 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user