Update to 74.1
This commit is contained in:
parent
38f4395552
commit
9fad722852
11
icu.spec
11
icu.spec
@ -8,8 +8,8 @@
|
||||
%define version_underscore %{gsub %{version} %. _}
|
||||
|
||||
Name: icu
|
||||
Version: 73.2
|
||||
Release: 5%{?dist}
|
||||
Version: 74.1
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
|
||||
License: Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
|
||||
@ -24,10 +24,6 @@ Source5: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/ic
|
||||
%endif
|
||||
Source10: icu-config.sh
|
||||
|
||||
# Fix broken TestHebrewCalendarInTemporalLeapYear
|
||||
# https://github.com/unicode-org/icu/pull/2610 (fixed in icu 74)
|
||||
Patch0: intltest-fix-hebrew-cal.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: doxygen, autoconf, python3
|
||||
@ -198,6 +194,9 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 29 2024 Pete Walter <pwalter@fedoraproject.org> - 74.1-1
|
||||
- Update to 74.1
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 73.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
@ -1,33 +0,0 @@
|
||||
From f3b869cbb0b9ced42d7ca4e24626a868a14ddcfc Mon Sep 17 00:00:00 2001
|
||||
From: Frank Tang <ftang@chromium.org>
|
||||
Date: Mon, 18 Sep 2023 20:20:42 -0700
|
||||
Subject: [PATCH] ICU-22512 Fix broken TestHebrewCalendarInTemporalLeapYear
|
||||
|
||||
Fix broken test mistakenly landed in
|
||||
https://github.com/unicode-org/icu/pull/2274
|
||||
|
||||
Some important steps were missed in the last landing.
|
||||
---
|
||||
icu4c/source/test/intltest/caltest.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/icu4c/source/test/intltest/caltest.cpp b/icu4c/source/test/intltest/caltest.cpp
|
||||
index 9d89f468eef0..18b96f231ba3 100644
|
||||
--- a/source/test/intltest/caltest.cpp
|
||||
+++ b/source/test/intltest/caltest.cpp
|
||||
@@ -4028,6 +4028,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
|
||||
for (gc.set(startYear, UCAL_JANUARY, 1);
|
||||
gc.get(UCAL_YEAR, status) <= stopYear;
|
||||
gc.add(UCAL_DATE, incrementDays, status)) {
|
||||
+ cal->setTime(gc.getTime(status), status);
|
||||
if (failure(status, "add/get/set/getTime/setTime incorrect")) return;
|
||||
|
||||
int32_t cal_year = cal->get(UCAL_EXTENDED_YEAR, status);
|
||||
@@ -4036,6 +4037,7 @@ void CalendarTest::TestHebrewCalendarInTemporalLeapYear() {
|
||||
leapTest->set(UCAL_MONTH, 0);
|
||||
leapTest->set(UCAL_DATE, 1);
|
||||
// If 10 months after TISHRI is TAMUZ, then it is a leap year.
|
||||
+ leapTest->add(UCAL_MONTH, 10, status);
|
||||
hasLeapMonth = leapTest->get(UCAL_MONTH, status) == icu::HebrewCalendar::TAMUZ;
|
||||
yearForHasLeapMonth = cal_year;
|
||||
}
|
4
sources
4
sources
@ -3,5 +3,5 @@ SHA512 (timezoneTypes.txt) = 11fa693a0cc1a232ea23befdf9906f04896190210e85ecad82c
|
||||
SHA512 (windowsZones.txt) = 0244076828692df657b48f05d0f1537ae0fb08f5f91ef8858e08097ce5df70363e11594ca24c735e71620504b68241ae4901a481ad59f1b6ec6b9eb28a30eda5
|
||||
SHA512 (zoneinfo64.txt) = 289ac8dbdcdf39221d0cc41562134270433210658acd57d20c3ba3d727bfeba007ddcc7123634300b7a93cccafe8bb367f8c134e3414dc00d0dd309a29dd9373
|
||||
SHA512 (icu-config.sh) = 04e00dbbd40c84ef355f149ab8d20dd0fa7fa7abacac849ea065ebab5de2746c13626e61f2a543c5207aa246a5805d2d9e64be9221a40eb8314d720c7824d314
|
||||
SHA512 (icu4c-73_2-src.tgz) = 76dd782db6205833f289d7eb68b60860dddfa3f614f0ba03fe7ec13117077f82109f0dc1becabcdf4c8a9c628b94478ab0a46134bdb06f4302be55f74027ce62
|
||||
SHA512 (icu4c-72_1-data.zip) = 9c7a85d22bcd27ccb8503ce3a64a0f88c6c495d6c0619398ec3a693f156dadd22bbc5c2993730cf6f25b4869206562f875c35ba35c462c6d3420d5d4e8de4faf
|
||||
SHA512 (icu4c-74_1-src.tgz) = 32c28270aa5d94c58d2b1ef46d4ab73149b5eaa2e0621d4a4c11597b71d146812f5e66db95f044e8aaa11b94e99edd4a48ab1aa8efbe3d72a73870cd56b564c2
|
||||
SHA512 (icu4c-74_1-data.zip) = 7e411e0f190428588a872a3c65477eed60063f6fef0c84d09822c3b6b7ebba3c956a484cd91da1e26f93360f4b3e08da6ba226b674f2d139c44f86fdb2ac90a3
|
||||
|
Loading…
Reference in New Issue
Block a user