latest version
This commit is contained in:
parent
447931d632
commit
93e640133a
@ -1,2 +1,2 @@
|
|||||||
icu-config
|
icu-config
|
||||||
icu4c-4_4-src.tgz
|
icu4c-4_4_1-src.tgz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
Index: /icu/trunk/source/tools/ctestfw/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- icu/source/tools/ctestfw/Makefile.in (revision 26596)
|
|
||||||
+++ icu/source/tools/ctestfw/Makefile.in (revision 27878)
|
|
||||||
@@ -80,4 +80,26 @@
|
|
||||||
|
|
||||||
install-library: all-local
|
|
||||||
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(ENABLE_STATIC),)
|
|
||||||
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
|
|
||||||
+endif
|
|
||||||
+ifneq ($(ENABLE_SHARED),)
|
|
||||||
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
|
|
||||||
+ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
+ifneq ($(IMPORT_LIB_EXT),)
|
|
||||||
+ $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
|
|
||||||
+endif
|
|
||||||
+ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
|
|
||||||
dist-local:
|
|
10
icu.spec
10
icu.spec
@ -1,11 +1,11 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 4.4
|
Version: 4.4.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
URL: http://www.icu-project.org/
|
URL: http://www.icu-project.org/
|
||||||
Source0: http://download.icu-project.org/files/icu4c/4.4/icu4c-4_4-src.tgz
|
Source0: http://download.icu-project.org/files/icu4c/4.4.1/icu4c-4_4_1-src.tgz
|
||||||
Source1: icu-config
|
Source1: icu-config
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: doxygen, autoconf
|
BuildRequires: doxygen, autoconf
|
||||||
@ -15,7 +15,6 @@ Patch1: icu-3.4-multiarchdevel.patch
|
|||||||
Patch2: icu.icu6284.strictalias.patch
|
Patch2: icu.icu6284.strictalias.patch
|
||||||
Patch3: icu.6995.kannada.patch
|
Patch3: icu.6995.kannada.patch
|
||||||
Patch4: icu.XXXX.buildfix.patch
|
Patch4: icu.XXXX.buildfix.patch
|
||||||
Patch5: icu.icu7567.libctest.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tools and utilities for developing with icu.
|
Tools and utilities for developing with icu.
|
||||||
@ -59,7 +58,6 @@ BuildArch: noarch
|
|||||||
%patch2 -p1 -b .icu6284.strictalias.patch
|
%patch2 -p1 -b .icu6284.strictalias.patch
|
||||||
%patch3 -p1 -b .icu6995.kannada.patch
|
%patch3 -p1 -b .icu6995.kannada.patch
|
||||||
%patch4 -p1 -b .icuXXXX.buildfix.patch
|
%patch4 -p1 -b .icuXXXX.buildfix.patch
|
||||||
%patch5 -p1 -b .icu7567.libctest.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -138,6 +136,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 29 2010 Caolan McNamara <caolanm@redhat.com> - 4.4.1-1
|
||||||
|
- latest version
|
||||||
|
- drop integrated icu.icu7567.libctest.patch
|
||||||
|
|
||||||
* Fri Apr 02 2010 Caolan McNamara <caolanm@redhat.com> - 4.4-1
|
* Fri Apr 02 2010 Caolan McNamara <caolanm@redhat.com> - 4.4-1
|
||||||
- latest version
|
- latest version
|
||||||
- drop integrated icu.6969.pkgdata.patch
|
- drop integrated icu.6969.pkgdata.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user