Update to 65.1
- Add a patch from gentoo to fix the build on s390x - Drop arm test disabling patches as they are no longer needed
This commit is contained in:
parent
15c9bb2cd7
commit
72d6316190
@ -1,96 +0,0 @@
|
||||
diff -ru orig.icu/source/test/cintltst/cnmdptst.c icu/source/test/cintltst/cnmdptst.c
|
||||
--- orig.icu/source/test/cintltst/cnmdptst.c 2016-03-23 21:48:18.000000000 +0100
|
||||
+++ icu/source/test/cintltst/cnmdptst.c 2016-04-15 18:34:06.148251985 +0200
|
||||
@@ -186,6 +186,12 @@
|
||||
/* Test exponential pattern*/
|
||||
static void TestExponential(void)
|
||||
{
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 1
|
||||
+ /* Actually only 3 tests fail, but given the nested structure depending on
|
||||
+ * array sizes there's no simple "disable this and that". */
|
||||
+ return;
|
||||
+#endif
|
||||
int32_t pat_length, val_length, lval_length;
|
||||
int32_t ival, ilval, p, v, lneed;
|
||||
UNumberFormat *fmt;
|
||||
diff -ru orig.icu/source/test/intltest/dcfmtest.cpp icu/source/test/intltest/dcfmtest.cpp
|
||||
--- orig.icu/source/test/intltest/dcfmtest.cpp 2016-03-23 21:48:38.000000000 +0100
|
||||
+++ icu/source/test/intltest/dcfmtest.cpp 2016-04-15 18:34:06.148251985 +0200
|
||||
@@ -279,6 +279,13 @@
|
||||
//
|
||||
formatLineMat.reset(testLine);
|
||||
if (formatLineMat.lookingAt(status)) {
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 1
|
||||
+// [Formattable] file dcfmtest.txt, line 62: expected "12.35E5", got "1.235E6"
|
||||
+// [StringPiece] file dcfmtest.txt, line 62: expected "12.35E5", got "1.235E6"
|
||||
+ if (lineNum == 62)
|
||||
+ continue;
|
||||
+#endif
|
||||
execFormatTest(lineNum,
|
||||
formatLineMat.group(1, status), // Pattern
|
||||
formatLineMat.group(2, status), // rounding mode
|
||||
diff -ru orig.icu/source/test/intltest/numfmtspectest.cpp icu/source/test/intltest/numfmtspectest.cpp
|
||||
--- orig.icu/source/test/intltest/numfmtspectest.cpp 2016-03-23 21:48:40.000000000 +0100
|
||||
+++ icu/source/test/intltest/numfmtspectest.cpp 2016-04-15 18:34:06.148251985 +0200
|
||||
@@ -137,11 +137,14 @@
|
||||
|
||||
void NumberFormatSpecificationTest::TestScientificNotation() {
|
||||
assertPatternFr("1,23E4", 12345.0, "0.00E0", TRUE);
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 0
|
||||
assertPatternFr("123,00E2", 12300.0, "000.00E0", TRUE);
|
||||
assertPatternFr("123,0E2", 12300.0, "000.0#E0", TRUE);
|
||||
assertPatternFr("123,0E2", 12300.1, "000.0#E0", TRUE);
|
||||
assertPatternFr("123,01E2", 12301.0, "000.0#E0", TRUE);
|
||||
assertPatternFr("123,01E+02", 12301.0, "000.0#E+00", TRUE);
|
||||
+#endif
|
||||
assertPatternFr("12,3E3", 12345.0, "##0.00E0", TRUE);
|
||||
assertPatternFr("12,300E3", 12300.1, "##0.0000E0", TRUE);
|
||||
assertPatternFr("12,30E3", 12300.1, "##0.000#E0", TRUE);
|
||||
@@ -221,6 +224,8 @@
|
||||
assertEquals("", "USD (433.22)", result, TRUE);
|
||||
}
|
||||
}
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 0
|
||||
const char *paddedSciPattern = "QU**00.#####E0";
|
||||
assertPatternFr("QU***43,3E-1", 4.33, paddedSciPattern, TRUE);
|
||||
{
|
||||
@@ -242,6 +247,7 @@
|
||||
}
|
||||
// padding cannot work as intended with scientific notation.
|
||||
assertPatternFr("QU**43,32E-1", 4.332, paddedSciPattern, TRUE);
|
||||
+#endif
|
||||
}
|
||||
|
||||
void NumberFormatSpecificationTest::assertPatternFr(
|
||||
diff -ru orig.icu/source/test/intltest/numfmtst.cpp icu/source/test/intltest/numfmtst.cpp
|
||||
--- orig.icu/source/test/intltest/numfmtst.cpp 2016-03-23 21:48:40.000000000 +0100
|
||||
+++ icu/source/test/intltest/numfmtst.cpp 2016-04-15 18:34:06.150251997 +0200
|
||||
@@ -730,6 +730,12 @@
|
||||
void
|
||||
NumberFormatTest::TestExponential(void)
|
||||
{
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 1
|
||||
+ /* Actually only 3 tests fail, but given the nested structure depending on
|
||||
+ * array sizes there's no simple "disable this and that". */
|
||||
+ return;
|
||||
+#endif
|
||||
UErrorCode status = U_ZERO_ERROR;
|
||||
DecimalFormatSymbols sym(Locale::getUS(), status);
|
||||
if (U_FAILURE(status)) { errcheckln(status, "FAIL: Bad status returned by DecimalFormatSymbols ct - %s", u_errorName(status)); return; }
|
||||
@@ -1846,8 +1852,11 @@
|
||||
(int32_t) 45678000, "5E7", status);
|
||||
expect(new DecimalFormat("00E0", US, status),
|
||||
(int32_t) 45678000, "46E6", status);
|
||||
+/* erAck: fails on armv7hl, https://bugzilla.redhat.com/show_bug.cgi?id=1239574 */
|
||||
+#if 0
|
||||
expect(new DecimalFormat("000E0", US, status),
|
||||
(int32_t) 45678000, "457E5", status);
|
||||
+#endif
|
||||
/*
|
||||
expect(new DecimalFormat("###E0", US, status),
|
||||
new Object[] { new Double(0.0000123), "12.3E-6",
|
14
icu-64.1-data_archive_generation.patch
Normal file
14
icu-64.1-data_archive_generation.patch
Normal file
@ -0,0 +1,14 @@
|
||||
https://bugs.gentoo.org/682170
|
||||
|
||||
--- a/source/data/Makefile.in
|
||||
+++ b/source/data/Makefile.in
|
||||
@@ -148,7 +148,8 @@
|
||||
# and convert it to the current type.
|
||||
ifneq ($(ICUDATA_ARCHIVE),)
|
||||
ICUDATA_SOURCE_ARCHIVE = $(OUTDIR)/$(ICUDATA_PLATFORM_NAME).dat
|
||||
-$(ICUDATA_SOURCE_ARCHIVE): $(ICUDATA_ARCHIVE) $(OUTDIR)
|
||||
+$(ICUDATA_SOURCE_ARCHIVE): $(ICUDATA_ARCHIVE)
|
||||
+ $(MKINSTALLDIRS) $(OUTDIR)
|
||||
$(INVOKE) $(TOOLBINDIR)/icupkg -t$(ICUDATA_CHAR) $(ICUDATA_ARCHIVE) $(ICUDATA_SOURCE_ARCHIVE)
|
||||
endif
|
||||
else
|
24
icu.spec
24
icu.spec
@ -1,13 +1,13 @@
|
||||
#%%global debugtrace 1
|
||||
|
||||
Name: icu
|
||||
Version: 63.2
|
||||
Release: 4%{?dist}
|
||||
Version: 65.1
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
|
||||
License: MIT and UCD and Public Domain
|
||||
URL: http://site.icu-project.org/
|
||||
Source0: https://github.com/unicode-org/icu/releases/download/release-63-2/icu4c-63_2-src.tgz
|
||||
Source0: https://github.com/unicode-org/icu/releases/download/release-65-1/icu4c-65_1-src.tgz
|
||||
Source1: icu-config.sh
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -15,11 +15,10 @@ BuildRequires: gcc-c++
|
||||
BuildRequires: doxygen, autoconf, python3
|
||||
Requires: lib%{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1708935 temporarily roll back to 63.1
|
||||
Patch0: roll-back-63.2-to-63.1-patched.patch
|
||||
# Fix the build on s390x
|
||||
Patch0: icu-64.1-data_archive_generation.patch
|
||||
Patch4: gennorm2-man.patch
|
||||
Patch5: icuinfo-man.patch
|
||||
Patch100: armv7hl-disable-tests.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -59,13 +58,7 @@ BuildArch: noarch
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p2 -b .roll-back-63.2-to-63.1-patched.patch
|
||||
%patch4 -p1 -b .gennorm2-man.patch
|
||||
%patch5 -p1 -b .icuinfo-man.patch
|
||||
%ifarch armv7hl
|
||||
%patch100 -p1 -b .armv7hl-disable-tests.patch
|
||||
%endif
|
||||
%autosetup -p1 -n %{name}
|
||||
|
||||
|
||||
%build
|
||||
@ -188,6 +181,11 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 01 2019 Pete Walter <pwalter@fedoraproject.org> - 65.1-1
|
||||
- Update to 65.1
|
||||
- Add a patch from gentoo to fix the build on s390x
|
||||
- Drop arm test disabling patches as they are no longer needed
|
||||
|
||||
* Fri Nov 01 2019 Pete Walter <pwalter@fedoraproject.org> - 63.2-4
|
||||
- Build with Python 3
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (icu4c-63_2-src.tgz) = 5fa9092efd8d6da6dfc8d498e4026167fda43423eaafc754d1789cf8fd4f6e76377878ebcaa32e14f314836136b764873511a93bfbcc5419b758841cc6df8f32
|
||||
SHA512 (icu4c-65_1-src.tgz) = 8f1ef33e1f4abc9a8ee870331c59f01b473d6da1251a19ce403f822f3e3871096f0791855d39c8f20c612fc49cda2c62c06864aa32ddab2dbd186d2b21ce9139
|
||||
SHA512 (icu-config.sh) = 04e00dbbd40c84ef355f149ab8d20dd0fa7fa7abacac849ea065ebab5de2746c13626e61f2a543c5207aa246a5805d2d9e64be9221a40eb8314d720c7824d314
|
||||
|
Loading…
Reference in New Issue
Block a user