upgrade to upstream ICU 52.1
This commit is contained in:
parent
f4a0426c03
commit
6f19c01a11
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,2 @@
|
||||
/icu4c-5*-src.tgz
|
||||
/icu-51-layout-fix-10107.tgz
|
||||
/icu-config.sh
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -ru orig.icu/source/layout/LayoutEngine.cpp icu/source/layout/LayoutEngine.cpp
|
||||
--- orig.icu/source/layout/LayoutEngine.cpp 2013-04-18 23:32:39.000000000 +0200
|
||||
+++ icu/source/layout/LayoutEngine.cpp 2013-07-17 01:52:18.208537348 +0200
|
||||
@@ -512,7 +512,6 @@
|
||||
{
|
||||
if(fGlyphStorage!=NULL) {
|
||||
fGlyphStorage->reset();
|
||||
- fGlyphStorage = NULL;
|
||||
}
|
||||
}
|
||||
|
@ -1,36 +0,0 @@
|
||||
Index: /icu/trunk/source/i18n/csrucode.cpp
|
||||
===================================================================
|
||||
--- orig.icu/source/i18n/csrucode.cpp (revision 34075)
|
||||
+++ icu/source/i18n/csrucode.cpp (revision 34076)
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
**********************************************************************
|
||||
- * Copyright (C) 2005-2012, International Business Machines
|
||||
+ * Copyright (C) 2005-2013, International Business Machines
|
||||
* Corporation and others. All Rights Reserved.
|
||||
**********************************************************************
|
||||
@@ -34,6 +34,7 @@
|
||||
const uint8_t *input = textIn->fRawInput;
|
||||
int32_t confidence = 0;
|
||||
+ int32_t length = textIn->fRawLength;
|
||||
|
||||
- if (input[0] == 0xFE && input[1] == 0xFF) {
|
||||
+ if (length >=2 && input[0] == 0xFE && input[1] == 0xFF) {
|
||||
confidence = 100;
|
||||
}
|
||||
@@ -58,6 +59,7 @@
|
||||
const uint8_t *input = textIn->fRawInput;
|
||||
int32_t confidence = 0;
|
||||
+ int32_t length = textIn->fRawLength;
|
||||
|
||||
- if (input[0] == 0xFF && input[1] == 0xFE && (input[2] != 0x00 || input[3] != 0x00)) {
|
||||
+ if (length >= 4 && input[0] == 0xFF && input[1] == 0xFE && (input[2] != 0x00 || input[3] != 0x00)) {
|
||||
confidence = 100;
|
||||
}
|
||||
@@ -82,5 +84,5 @@
|
||||
int32_t confidence = 0;
|
||||
|
||||
- if (getChar(input, 0) == 0x0000FEFFUL) {
|
||||
+ if (limit > 0 && getChar(input, 0) == 0x0000FEFFUL) {
|
||||
hasBOM = TRUE;
|
||||
}
|
26
icu.spec
26
icu.spec
@ -1,15 +1,12 @@
|
||||
Name: icu
|
||||
Version: 50.1.2
|
||||
Release: 10%{?dist}
|
||||
Version: 52.1
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT and UCD and Public Domain
|
||||
URL: http://www.icu-project.org/
|
||||
Source0: http://download.icu-project.org/files/icu4c/50.1.2/icu4c-50_1_2-src.tgz
|
||||
# According to ICU the layout "patch" should be applied to all versions earlier than 51.2
|
||||
# See also http://site.icu-project.org/download/51#TOC-Known-Issues
|
||||
Source1: http://download.icu-project.org/files/icu4c/51.1/icu-51-layout-fix-10107.tgz
|
||||
Source2: icu-config.sh
|
||||
Source0: http://download.icu-project.org/files/icu4c/52.1/icu4c-52_1-src.tgz
|
||||
Source1: icu-config.sh
|
||||
BuildRequires: doxygen, autoconf, python
|
||||
Requires: lib%{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
@ -19,8 +16,6 @@ Patch3: icu.7601.Indic-ccmp.patch
|
||||
Patch4: icu.9948.mlym-crash.patch
|
||||
Patch5: gennorm2-man.patch
|
||||
Patch6: icuinfo-man.patch
|
||||
Patch7: icu.10143.memory.leak.crash.patch
|
||||
Patch8: icu.10318.CVE-2013-2924_changeset_34076.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -63,15 +58,12 @@ BuildArch: noarch
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%setup -q -n %{name} -T -D -a 1
|
||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||
%patch2 -p1 -b .icu8800.freeserif.crash.patch
|
||||
%patch3 -p1 -b .icu7601.Indic-ccmp.patch
|
||||
%patch4 -p1 -b .icu9948.mlym-crash.patch
|
||||
%patch5 -p1 -b .gennorm2-man.patch
|
||||
%patch6 -p1 -b .icuinfo-man.patch
|
||||
%patch7 -p1 -b .icu10143.memory.leak.crash.patch
|
||||
%patch8 -p1 -b .icu10318.CVE-2013-2924_changeset_34076.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -114,7 +106,7 @@ chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
|
||||
cd $RPM_BUILD_ROOT%{_bindir}
|
||||
mv icu-config icu-config-%{__isa_bits}
|
||||
)
|
||||
install -p -m755 -D %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/icu-config
|
||||
install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/icu-config
|
||||
|
||||
%check
|
||||
# test to ensure that -j(X>1) didn't "break" man pages. b.f.u #2357
|
||||
@ -179,6 +171,14 @@ make %{?_smp_mflags} -C source check
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 11 2014 Eike Rathke <erack@redhat.com> - 52.1-1
|
||||
- upgrade to upstream ICU 52.1
|
||||
- Resolves: rhbz#1049265 icu-52.1 is available
|
||||
- Resolves: rhbz#1050063 Trivial change to icu-config to support ppc64le
|
||||
- drop icu-51-layout-fix-10107.tgz source
|
||||
- drop integrated icu.10318.CVE-2013-2924_changeset_34076.patch
|
||||
- drop integrated icu.10143.memory.leak.crash.patch
|
||||
|
||||
* Wed Oct 09 2013 Eike Rathke <erack@redhat.com> - 50.1.2-10
|
||||
- Resolves: rhbz#1015594 CVE-2013-2924 use-after-free
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user