Resolves: rhbz#674328 freeserif crashes libicu
This commit is contained in:
parent
5e9a58532c
commit
69ffdeb52a
14
icu.8320.freeserif.crash.patch
Normal file
14
icu.8320.freeserif.crash.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -ru icu.orig/source/layout/LookupProcessor.cpp icu/source/layout/LookupProcessor.cpp
|
||||||
|
--- icu/source/layout/LookupProcessor.cpp 2011-02-02 12:29:54.369077099 +0000
|
||||||
|
+++ icu/source/layout/LookupProcessor.cpp 2011-02-02 12:31:54.215503036 +0000
|
||||||
|
@@ -70,6 +70,10 @@
|
||||||
|
|
||||||
|
if (selectMask != 0) {
|
||||||
|
const LookupTable *lookupTable = lookupListTable->getLookupTable(lookup);
|
||||||
|
+
|
||||||
|
+ if (!lookupTable)
|
||||||
|
+ continue;
|
||||||
|
+
|
||||||
|
le_uint16 lookupFlags = SWAPW(lookupTable->lookupFlags);
|
||||||
|
|
||||||
|
glyphIterator.reset(lookupFlags, selectMask);
|
7
icu.spec
7
icu.spec
@ -1,6 +1,6 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 4.4.2
|
Version: 4.4.2
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
@ -18,6 +18,7 @@ Patch4: icu.7972.buildfix.patch
|
|||||||
Patch5: icu.7932.doublecompare.patch
|
Patch5: icu.7932.doublecompare.patch
|
||||||
Patch6: icu.8011.buildfix.patch
|
Patch6: icu.8011.buildfix.patch
|
||||||
Patch7: icu.8198.revert.icu5431.patch
|
Patch7: icu.8198.revert.icu5431.patch
|
||||||
|
Patch8: icu.8320.freeserif.crash.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tools and utilities for developing with icu.
|
Tools and utilities for developing with icu.
|
||||||
@ -64,6 +65,7 @@ BuildArch: noarch
|
|||||||
%patch5 -p1 -b .icu7932.doublecompare.patch
|
%patch5 -p1 -b .icu7932.doublecompare.patch
|
||||||
%patch6 -p1 -b .icu8011.buildfix.patch
|
%patch6 -p1 -b .icu8011.buildfix.patch
|
||||||
%patch7 -p2 -R -b .icu8198.revert.icu5431.patch
|
%patch7 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||||
|
%patch8 -p1 -b .icu8320.freeserif.crash.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -146,6 +148,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 02 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-5
|
||||||
|
- Resolves: rhbz#674328 freeserif crashes libicu
|
||||||
|
|
||||||
* Thu Jan 13 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-4
|
* Thu Jan 13 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-4
|
||||||
- Resolves: rhbz#669237 strip libicudata
|
- Resolves: rhbz#669237 strip libicudata
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user